Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)

F10 / F11 (2011 - Current)
The new chapter in the highly successful story of the BMW 5 Series Sedan (F10) and wagon (F11)

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2012, 11:54 AM
lcadena lcadena is offline
Registered User
Location: Northern Virginia
 
Join Date: Dec 2011
Posts: 15
Mein Auto: 528i xDrive
Angry Help-Nav screen has gone dark!

Yesterday I turned on my seven-month-old 528xi F10 after leaving the movie theater and, lo and behold, the nav/infotainment screen did not come on at all. The radio and iPod play just fine, and I can switch between then with the steering wheel scroll wheel and buttons, but the main console screen is completely black. I also used the iDrive controller to switch station presets (I had turned off the car while the screen was on the radio presets) without incident. Does anyone know what could cause this, and if this is a common problem?

I've got an appointment to take the car in for service on Friday (it's under warranty, after all), but I'm curious to see if others have experienced this, too.
Reply With Quote
Advertisement
  #2  
Old 06-11-2012, 04:45 AM
Jack the cat Jack the cat is offline
Jack the cat
Location: Tennessee
 
Join Date: Jan 2011
Posts: 93
Mein Auto: 2011 535i
I have had two issues with my screen:
1. Back light was not on. I could see the words, but were very dim due to no backlight. Turned engine off, then on, and all worked fine.
2. Right side of split screen was black. Left side so ok. Car had set in sun and heat several hours. Changed to full screen then back to split screen and all was fine.

Didn't think to mention these during routine maintenance visits.
__________________
2011 535i - Imperial Blue Metallic / Venetian Beige Dakota Leather / Light Wood Trim - Premium 1&2 - Smartphone integration
Reply With Quote
  #3  
Old 06-11-2012, 05:36 AM
miotoo miotoo is offline
Officially Welcomed to the 'Fest
Location: Zürich, Switzerland
 
Join Date: May 2012
Posts: 306
Mein Auto: F10 520d
Quote:
Originally Posted by lcadena View Post
Yesterday I turned on my seven-month-old 528xi F10 after leaving the movie theater and, lo and behold, the nav/infotainment screen did not come on at all. The radio and iPod play just fine, and I can switch between then with the steering wheel scroll wheel and buttons, but the main console screen is completely black. I also used the iDrive controller to switch station presets (I had turned off the car while the screen was on the radio presets) without incident. Does anyone know what could cause this, and if this is a common problem?

I've got an appointment to take the car in for service on Friday (it's under warranty, after all), but I'm curious to see if others have experienced this, too.
Did you try to hold the volume/mute button in for 30 seconds to reboot the cic?
__________________

F10 520d born 11.04.2011 Deep Sea Blue

205, 230, 322, 403, 415, 423, 428, 430, 431, 459, 464, 465, 494, 502, 508, 522, 524, 534, 548, 609, 614, 615, 620, 644, 654, 676, 698, 851, 879, 962, 1CA, 1CB, 1CD, 2K1, 2PA, 3AG, 4AT, 4UR, 5AC, 6AA, 6AB, 6FL, 6NF, 6NR, 6VC, 8KA, 8TF, 8TL, 8TN, 8V1
Reply With Quote
  #4  
Old 06-11-2012, 06:52 AM
Needsdecaf's Avatar
Needsdecaf Needsdecaf is offline
Everything's Bigger in TX
Location: The Woodlands, TX
 
Join Date: Sep 2006
Posts: 7,106
Mein Auto: 2007 MDX
Quote:
Originally Posted by miotoo View Post
Did you try to hold the volume/mute button in for 30 seconds to reboot the cic?
good to know about that trick!
__________________
2011 535i
Sophisto Grau / Oyster - Black Nappa, Anthracite Wood Gone but not forgotten.

Heaven is where the police are British, the cooks are French, the cars are German, the lovers are Italian and it is all organised by the Swiss.

Hell is where the police are German, the cooks are English, the cars are French, the lovers are Swiss, and it is all organised by the Italians
Reply With Quote
  #5  
Old 06-11-2012, 07:06 AM
mkossler mkossler is offline
Matty K.
Location: Georgia
 
Join Date: Sep 2011
Posts: 118
Mein Auto: 2011 535i Jet Black
Also, if you have an older iPod plugged in via glovebox USB, you might want to try unplugging it. Had this issue some time back with a 40 Gig click-wheel vintage unit.
__________________
2011 535i (8/2011 build) Jet Black, Black Dakota leather, Dark Wood, Convenience, Premium 1 & 2, SmartPhone, BMW Apps
Reply With Quote
  #6  
Old 06-12-2012, 04:43 AM
lcadena lcadena is offline
Registered User
Location: Northern Virginia
 
Join Date: Dec 2011
Posts: 15
Mein Auto: 528i xDrive
Thanks for the tips and replies, everyone. Yesterday evening after work the screen came back on all by itself when I turned the car on to drive home from work. Not sure what the cause was, but I'll keep the solutions in mind if it happens again!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms