Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2012, 12:42 PM
hazee hazee is offline
Registered User
Location: UAE
 
Join Date: Jun 2012
Posts: 8
Mein Auto: X5
Question Rear seat entertainment system not working

I have bought a used X5 2009 model with below attached entertainment system installed. Its not switching on and I have no idea how to open or repair it.

Can any one help?
Attached Thumbnails
Click image for larger version

Name:	3.jpg
Views:	539
Size:	99.2 KB
ID:	330072   Click image for larger version

Name:	4.jpg
Views:	459
Size:	315.4 KB
ID:	330073   Click image for larger version

Name:	2.jpg
Views:	145
Size:	86.3 KB
ID:	330074  

Last edited by hazee; 06-22-2012 at 06:32 PM.
Reply With Quote
Advertisement
  #2  
Old 06-22-2012, 08:32 AM
hazee hazee is offline
Registered User
Location: UAE
 
Join Date: Jun 2012
Posts: 8
Mein Auto: X5
I have found the part number (65 12 0 421 339) but can not figure out what is faulty? I have got no idea how to open the screens from the seats or find the wiring path to find the issue or may be resolve it. I have also found the below

http://bmwfans.info/parts/catalog/E7..._dvd_advanced/


I even prefer to remove the system and install a new one if this one cant be repaired.

Refer to attached pics.

Any help is appreciated.
Attached Thumbnails
Click image for larger version

Name:	01.jpg
Views:	135
Size:	185.1 KB
ID:	330174   Click image for larger version

Name:	02.jpg
Views:	151
Size:	222.9 KB
ID:	330175   Click image for larger version

Name:	03.jpg
Views:	151
Size:	217.4 KB
ID:	330176   Click image for larger version

Name:	04.jpg
Views:	137
Size:	233.1 KB
ID:	330177   Click image for larger version

Name:	05.jpg
Views:	131
Size:	254.1 KB
ID:	330178  


Last edited by hazee; 06-22-2012 at 08:36 AM.
Reply With Quote
  #3  
Old 12-03-2012, 10:50 AM
lirimb1 lirimb1 is offline
Registered User
Location: SE WI
 
Join Date: Dec 2012
Posts: 3
Mein Auto: bmw
Updates?

Did you get this figured out or does anyone have any information on this? I have the same system and i do have the remotes, and nothing powers on at all, neither screen or the DVD player turns on at all. Any ideas or where to start?
Reply With Quote
  #4  
Old 12-05-2012, 01:09 AM
hazee hazee is offline
Registered User
Location: UAE
 
Join Date: Jun 2012
Posts: 8
Mein Auto: X5
You need to switch on the screens first with remote. Then you will notice LED lights on the dvd player which can be switched on with a remote or touch on the power button.
Reply With Quote
  #5  
Old 12-07-2012, 03:45 PM
lirimb1 lirimb1 is offline
Registered User
Location: SE WI
 
Join Date: Dec 2012
Posts: 3
Mein Auto: bmw
WOW>>> this is the dumbest system ever, especially since its a BMW one would think they were smarter. OK thanks Hazee because i have spent hours testing and retesting and checking wires all over the place and it turns out, its just a DEAD BATTERY IN THE REMOTE!!!!! The only way you can turn anything on with this system is by the remote, you must first turn on the Screen/s then the power to the DVD player will come on. You cannot manually power anything on. So if you loose the remote or have a dead battery, it will not work! Pretty dumb!. Anyways....now ya know.

Good luck and hope this helps other people in the future.

Last edited by lirimb1; 12-07-2012 at 03:46 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms