Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-25-2012, 12:00 PM
retailagent retailagent is offline
Registered User
Location: Vegas
 
Join Date: Jun 2012
Posts: 2
Mein Auto: 04 7.45i
Squealing Air Conditioner

I searched around a bit and couldn't come across much so I thought I'd throw this out to the board:

Here are the bullet points, a little more description below:
-Squealing noise similar to bad power steering happening
-Definite freon leak, has been recharged twice in the past 12 months
-Noise stops/reduces when freon is low
-Noise was only happening at engine start
-Noise is now happening while driving (today)
-Unit stopped blowing cold air all together (today)
-Freon was recharged last week

2004 7.45i: Makes a sound like a flock of small birds flew into the engine compartment (re: it sounds like a typical bad power steering noise, but a bit higher pitched), primarily when the A/C is on. It has happened upon start up previously, but not more than a couple of times. Last year I had to recharge the freon, and the noise began then. The car was driven, and then sat for about 2 months until a couple of weeks ago. For the past two weeks the sound was not happening. The A/C was blowing fairly warm, so I checked the pressure in the low valve, and it was indeed low. Freon was added once again last week. Today I took a short drive, and the noise never went away, as it typically did. Within a few miles on my back home, I turned the A/C on and off a couple of times, and noticed the noise going way when it was off, and starting again when it was on. Then it suddenly stopped blowing cold air all together.

My question is, could the squealing noise be coming from a freon leak? Or is it fairly certain that I'm looking at a full Compressor/Clutch replacement? Any other suggestions before I drop a grand + to fix the compressor?

As a side bar, anyone have a good AC tech recommendation in Vegas?
Reply With Quote
Ads by Google
  #2  
Old 06-25-2012, 01:14 PM
pkathee's Avatar
pkathee pkathee is offline
Officially Welcomed to the 'Fest
Location: SALT LAKE CITY, UT
 
Join Date: Jan 2012
Posts: 563
Mein Auto: 760 Li
It could be presence of moisture/ condensation on the AC belt that results in slippage of the belt upon activation of the AC compressor.

Have it removed. Clean and completely dry off the belt groves on both the AC compressor and Vibration damper then install the new belt. It only costs $18 at the local auto store.

This would be a good starting point.

Good luck.

Quote:
Originally Posted by retailagent View Post
I searched around a bit and couldn't come across much so I thought I'd throw this out to the board:

Here are the bullet points, a little more description below:
-Squealing noise similar to bad power steering happening
-Definite freon leak, has been recharged twice in the past 12 months
-Noise stops/reduces when freon is low
-Noise was only happening at engine start
-Noise is now happening while driving (today)
-Unit stopped blowing cold air all together (today)
-Freon was recharged last week

2004 7.45i: Makes a sound like a flock of small birds flew into the engine compartment (re: it sounds like a typical bad power steering noise, but a bit higher pitched), primarily when the A/C is on. It has happened upon start up previously, but not more than a couple of times. Last year I had to recharge the freon, and the noise began then. The car was driven, and then sat for about 2 months until a couple of weeks ago. For the past two weeks the sound was not happening. The A/C was blowing fairly warm, so I checked the pressure in the low valve, and it was indeed low. Freon was added once again last week. Today I took a short drive, and the noise never went away, as it typically did. Within a few miles on my back home, I turned the A/C on and off a couple of times, and noticed the noise going way when it was off, and starting again when it was on. Then it suddenly stopped blowing cold air all together.

My question is, could the squealing noise be coming from a freon leak? Or is it fairly certain that I'm looking at a full Compressor/Clutch replacement? Any other suggestions before I drop a grand + to fix the compressor?

As a side bar, anyone have a good AC tech recommendation in Vegas?
__________________
1) 760Li- Logic7, Rear entert', Rear Climate, Comfort Access, 20" DP Wheels.
2) Lexus LX470- Mark Levinson Video/Audio, 22" Diablo Elite Wheels.


Reply With Quote
  #3  
Old 06-25-2012, 04:00 PM
retailagent retailagent is offline
Registered User
Location: Vegas
 
Join Date: Jun 2012
Posts: 2
Mein Auto: 04 7.45i
Quick update: belt is shredded to pieces. Compressors seems to be spinning freely, with any luck it'll just be the belt.
Reply With Quote
Reply

Bookmarks

Tags
2004, ac, compressor, freon, squeal


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms