Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Thread Tools Display Modes
Old 06-29-2012, 05:50 AM
chansen1 chansen1 is offline
Registered User
Location: Maine
Join Date: Feb 2012
Posts: 5
Mein Auto: X5
Camshaft Position Sensor

The other day my SES light came on and I have an error code of P0345, camshaft position sensor. I was wondering if anyone knew where it is located? The vehicle is a 2001 X5 4.4i. Thanks for the help

Last edited by chansen1; 06-29-2012 at 05:59 AM.
Reply With Quote
Old 06-29-2012, 07:53 AM
tmvE39/E53/Z32's Avatar
tmvE39/E53/Z32 tmvE39/E53/Z32 is online now
Officially Welcomed to the 'Fest
Location: Seattle --> Atlanta
Join Date: Dec 2010
Posts: 1,928
Mein Auto: Dinan //M5, Dinan 4.8iS,
Part#12 in this diagram


2000 Dinan S1 //M5 (my DD), 06 DINAN E53 4.8iS (wife's DD), 90 Straman Z32TT (my pride & joy ride)
Gone, but not forgotten: 01 E53 3.0i, 01 525i Sport, 03 DINAN 540i MSport, 01 //M5 and 91 Z32TT
Reply With Quote
Old 06-29-2012, 09:16 AM
ChezWhiz ChezWhiz is offline
Officially Welcomed to the 'Fest
Location: Austin, TX
Join Date: Jun 2005
Posts: 101
Send a message via AIM to ChezWhiz Send a message via MSN to ChezWhiz Send a message via Yahoo to ChezWhiz
Mein Auto: 2001 X5 4.4i

1. There are two of them.
2. Buy this part from BMW only (don't go cheap).
3. I had the same issue w/ my '01. I believe that error code can also be caused by faulty O2 sensors (4 of those). You might want to consider replacing those anyway since it's an '01.
[Dead] 2001 X5 4.4i w/ 139K miles (probable cracked engine block)
2005 X5 4.4i w/ 97K miles
Reply With Quote

See More Related BMW Stories

Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -7. The time now is 04:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms