Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-02-2012, 04:23 PM
microswitch's Avatar
microswitch microswitch is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Dec 2009
Posts: 299
Mein Auto: 2006 5251
Weird Radio acting

I used a out of market radio for few months, till my son decide He needed his stereo back.
I put back the stock radio on my 2002 E39, however something very funny is happening.
When I shot off the car the radio keep on playing even if the light on the radio are off and I mean all the light are off. I have to physically push on the power button and then push again to shot off the radio. What gives ?
I used a Metra adapter so I did not cut any wire just plug and go.
Any one had same experience or know of the reason and a fix?
__________________
Reply With Quote
Advertisement
  #2  
Old 07-03-2012, 11:43 AM
microswitch's Avatar
microswitch microswitch is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Dec 2009
Posts: 299
Mein Auto: 2006 5251
After driving for about 20 min the radio shut off on its own indicating to me that only the temp/delay power to the radio is working( will play for about 20 min when car is off).
So now the issue is a probably piched wire that prevent switched power to work on the radio ..
__________________
Reply With Quote
  #3  
Old 07-03-2012, 12:29 PM
Topaz540i's Avatar
Topaz540i Topaz540i is offline
Agnostic Priest
Location: Hillsborogh, NJ
 
Join Date: Apr 2012
Posts: 1,023
Mein Auto: 2001 540i/6
there is probably more than one positive wire. you may have them switched. One positive is constant the other only works when the key is in usually.
__________________
ESS Tuning m60 version software
m60 intake manifold
a.f.e. c.a.i.
3" obx catback
full powerflex urethane setup
545 ssk
cdv delete
m5 rear sway bar
M5 chassis rods
M5 3.15 lsd
Bc-r coilovers w/ swift springs
Akebono=suck
ss braided brake lines

coming soon:

Jb lwfw

Reply With Quote
  #4  
Old 07-03-2012, 03:46 PM
microswitch's Avatar
microswitch microswitch is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Dec 2009
Posts: 299
Mein Auto: 2006 5251
Yes indeed however there is no switching possibility. There is a harness that plugs directly into the radio, the original one. No wire were spliced..
And when i installed the after market radio I had to fish the switched power form the fuse box to make the radio work. With the original radio is not necessary. I only need a diagram to find the switched power wire so i can test it.
__________________
Reply With Quote
  #5  
Old 03-14-2014, 09:13 AM
UsedBits UsedBits is offline
BMW CCA Member #: 444067
Location: Central Arkansas
 
Join Date: Jul 2010
Posts: 265
Mein Auto: 2002 540iA with sport pkg
Radio plays after ignition is off and keys removed

The radio in my e39 presents the exact problems shown in the original post, except that it plays for only a minute (or so) after the car is shut down and the keys removed from the ignition. The problem started immediately after it was in the shop (water pump plus collateral damage from overheating).

1) the radio plays even though all dash lights (including clock) are off.
.a volume control doesn't affect volume
.b radio presets do not change stations

2) the radio randomly turns off

3) radio does not 'remember' station through power cycle
.a preset #1, when pressed, goes to station then immediately changes to another

This might (or might not) be related. While the car was in the shop (5 weeks), the battery went dead. Overnight temperatures were well below freezing (low 20s). Shop owner replaced the battery (was Interstate, now NAPA). I don't know how long the car was without power.

We can not find a setting for "radio power-off delay" anywhere, including the shop's AutoLogic computer interface.

I'm hoping someone in this forum can suggest some diagnostics or places to look.

Regards,
Steve
__________________

2002 e39 (540iA) with factory 'sport package' modified with:
'03 fr. and r. bumpers, front air ducts, and spoiler
18" Staggered MPars (style 37)
Dinan exhaust
shorter springs
European center console arm rest
VECTOR radar detector (non-working)

....-------------------.
[ /.....................\ ]
.|(oOO)\(lll)(lll)/(OOo)|
. \o\0=======|=======0/o/
...|__|.............|__|
Reply With Quote
  #6  
Old 03-16-2014, 11:26 AM
UsedBits UsedBits is offline
BMW CCA Member #: 444067
Location: Central Arkansas
 
Join Date: Jul 2010
Posts: 265
Mein Auto: 2002 540iA with sport pkg
Radio plays 20 minutes then powers off

Regarding #2 in my list of symptoms: the power does not shut off randomly. Instead, the power shuts off *exactly* 20 minutes after powering it on.

To review, the radio worked perfectly until it came back from the shop (water pump and extra stuff replaced). Upon return, the radio does not turn off when the ignition is switched off, keys removed, and door opened. Instead, the radio continues playing for about a minute.

When wanting to listen to the radio, it powers down exactly 20 minutes after powering it on.

I've not tested this with CDs (yet).

Regards,
Steve
__________________

2002 e39 (540iA) with factory 'sport package' modified with:
'03 fr. and r. bumpers, front air ducts, and spoiler
18" Staggered MPars (style 37)
Dinan exhaust
shorter springs
European center console arm rest
VECTOR radar detector (non-working)

....-------------------.
[ /.....................\ ]
.|(oOO)\(lll)(lll)/(OOo)|
. \o\0=======|=======0/o/
...|__|.............|__|
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms