Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-04-2012, 07:06 PM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Name that problem - 535 xi related

A week ago Saturday I was driving my car running errands when the check engine light when on. No I-drive message but the care was not running 100%. Given that my N54 engine has been a bit temperamental (HPFP issues, fuel injectors and carbon cleaning), I decided to bring in the car. Well it has been 5 working days and not even BMW knows what is going wrong. The car is running lean and throwing codes but no clear cause. Now BMW is saying to replace the oxygen sensors. Has anyone had that problem? I find it funny that BMW does not know how to fix its car....
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
Advertisement
  #2  
Old 09-05-2012, 08:15 AM
HPIA4v2 HPIA4v2 is offline
Officially Welcomed to the 'Fest
Location: washington
 
Join Date: Mar 2006
Posts: 2,173
Mein Auto: E60, E71, E92
Quote:
Originally Posted by Munich77 View Post
A week ago Saturday I was driving my car running errands when the check engine light when on. No I-drive message but the care was not running 100%. Given that my N54 engine has been a bit temperamental (HPFP issues, fuel injectors and carbon cleaning), I decided to bring in the car. Well it has been 5 working days and not even BMW knows what is going wrong. The car is running lean and throwing codes but no clear cause. Now BMW is saying to replace the oxygen sensors. Has anyone had that problem? I find it funny that BMW does not know how to fix its car....
if you get momentary "engine" icon (not fail safe, drive moderately message) then it most likely the fuel injector. I've seen it on My N54 and a friend's N55, both cases the SA says no action can be taken until it becomes permanent (i.e. the code appears and misfiring persistently).
If you hook it up to BT tools you can see the shadow code, at least on mine telling which cylinder, time and mileage. And in my case and my friend case the car is back to normal now so I am just keeping an eye on it.
Reply With Quote
  #3  
Old 09-05-2012, 10:07 AM
gcollins gcollins is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Sep 2009
Posts: 146
Mein Auto: 2008 535i
I had the same problem and turned out to be an injector. It did take them about a week working with BMW NA to figure out the problem. They replaced the injector and all was fine....
Reply With Quote
  #4  
Old 09-05-2012, 06:50 PM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Not a momentary engine icon - icon went on and never off!
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
  #5  
Old 09-05-2012, 09:53 PM
NoQuarter's Avatar
NoQuarter NoQuarter is offline
Drink E85 & inject Meth
Location: Indiana
 
Join Date: May 2010
Posts: 839
Mein Auto: 2008 535xi
Do you know the codes?
Reply With Quote
  #6  
Old 09-06-2012, 06:24 PM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Not of the top of my head - apparently BMW does not even know what is going on...latest hypothesis - leaking valve gasket.
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
  #7  
Old 09-07-2012, 09:07 AM
HPIA4v2 HPIA4v2 is offline
Officially Welcomed to the 'Fest
Location: washington
 
Join Date: Mar 2006
Posts: 2,173
Mein Auto: E60, E71, E92
Quote:
Originally Posted by Munich77 View Post
Not of the top of my head - apparently BMW does not even know what is going on...latest hypothesis - leaking valve gasket.
You mean valve cover gasket or valve seal?
The latter is N62 4.8i V8 problem, I have not heard it on I6
Reply With Quote
  #8  
Old 09-07-2012, 07:02 PM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Quote:
Originally Posted by HPIA4v2 View Post
You mean valve cover gasket or valve seal?
The latter is N62 4.8i V8 problem, I have not heard it on I6
Valve cover gasket is what they said. According to the dealership, BMW only has had one other 535 that has had that problem. I guess my car is "special".
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
  #9  
Old 09-07-2012, 09:36 PM
Oceans10's Avatar
Oceans10 Oceans10 is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Jul 2011
Posts: 1,510
Mein Auto: BMW 535i + 535XI wagon
Quote:
Originally Posted by Munich77 View Post
Valve cover gasket is what they said. According to the dealership, BMW only has had one other 535 that has had that problem. I guess my car is "special".
I seriously doubt that is the problem. Would have to be a giant leak, and it would then cause lots of black streaks on the engine block. Some day when you get the intake valves walnut blasted, be sure to replace the gasket.

It might very well be one of the oxygen sensors, assume you have ruled out hpfp and injectors.

Were they able to pull any fault codes? How many miles on the car? Assume plugs and coils are good, fuel line is clean?
__________________
Audio: Jehnert Flatline speakers, Mobridge M1000 DA2 prepro, Helix P-DSP, Zapco Z-150.6 amp
Performance: Custom Cobb ECU flash, AR Downpipes, ER FMIC/CP, DCI, RB turbos, KW V2 coilovers, Walbro 455 LPFP, Ported fuel rail
Reply With Quote
  #10  
Old 09-08-2012, 06:24 AM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Quote:
Originally Posted by Oceans10 View Post
I seriously doubt that is the problem. Would have to be a giant leak, and it would then cause lots of black streaks on the engine block. Some day when you get the intake valves walnut blasted, be sure to replace the gasket.

It might very well be one of the oxygen sensors, assume you have ruled out hpfp and injectors.
Were they able to pull any fault codes? How many miles on the car? Assume plugs and coils are good, fuel line is clean?
It was not the oxygen sensors (they replaced those). Changing the seal seems to have fixed it - per the work order "tech replaced valve cover was leaking internally." Oh and the intake valves were blasted in February.
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member

Last edited by Munich77; 09-08-2012 at 06:25 AM.
Reply With Quote
  #11  
Old 09-16-2012, 02:02 PM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
As an update - today I was driving the car and the check engine line went on yet again . I guess I will see what it is this time around.
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
  #12  
Old 09-22-2012, 05:37 AM
NoQuarter's Avatar
NoQuarter NoQuarter is offline
Drink E85 & inject Meth
Location: Indiana
 
Join Date: May 2010
Posts: 839
Mein Auto: 2008 535xi
Try this to attempt to cause a better error: this is a 535 with lots of Power. Many problems only reveal themselves when attempting to use all of it.

Get someplace where you can really floor the pedal and go wide open for about 10 seconds or so. Manual shifter mode, third gear, ~3000 rpm, floor it to almost redline on the rpms.
Reply With Quote
  #13  
Old 09-24-2012, 04:46 PM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Quote:
Originally Posted by NoQuarter View Post
Try this to attempt to cause a better error: this is a 535 with lots of Power. Many problems only reveal themselves when attempting to use all of it.

Get someplace where you can really floor the pedal and go wide open for about 10 seconds or so. Manual shifter mode, third gear, ~3000 rpm, floor it to almost redline on the rpms.
I doubt that would have fixed it - the problem was - drum roll please -

A faulty low pressure sensor and a faulty DTML pump.
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
  #14  
Old 09-24-2012, 09:29 PM
NoQuarter's Avatar
NoQuarter NoQuarter is offline
Drink E85 & inject Meth
Location: Indiana
 
Join Date: May 2010
Posts: 839
Mein Auto: 2008 535xi
Quote:
Originally Posted by Munich77 View Post
I doubt that would have fixed it - the problem was - drum roll please -

A faulty low pressure sensor and a faulty DTML pump.
My suggestion wasn't that this would fix it. My suggestion was to stress the engine in order to induce a more significant error condition that would result in the ECU recording the error.

As I continue to tune my engine and increase the horsepower (about 420 hp at the wheels) weaknesses only reveal themselves under higher stress - improve the condition and move on up to the next level!

But probably would not have helped with that pump error anyway. Glad you got it sorted!
Reply With Quote
  #15  
Old 09-25-2012, 04:19 AM
Munich77 Munich77 is offline
Officially Welcomed to the 'Fest
Location: Washington DC
 
Join Date: Jul 2008
Posts: 3,025
Mein Auto: 2014 E550 4matic
Gotcha - I am hoping that the error is gone....
__________________
2008 535 xi, space grey, black dakota leather, premium package, sport package, cold weather package, nav, folding seats, PDC

BMW CCA Member
Reply With Quote
  #16  
Old 09-26-2012, 09:42 AM
mission hills mission hills is offline
Registered User
Location: kansas city
 
Join Date: Sep 2012
Posts: 1
Mein Auto: 2008 535x1
i have a 2008 535xi, the remote key does not work. it,s not the comfort access key. any suggestions
Reply With Quote
  #17  
Old 09-26-2012, 01:19 PM
HPIA4v2 HPIA4v2 is offline
Officially Welcomed to the 'Fest
Location: washington
 
Join Date: Mar 2006
Posts: 2,173
Mein Auto: E60, E71, E92
Quote:
Originally Posted by mission hills View Post
i have a 2008 535xi, the remote key does not work. it,s not the comfort access key. any suggestions
You may want to start a new thread for fob problem, BTW both keys or just one?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms