Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.

Do-It-Yourself H.Q.
Share your DIY projects or ask questions about how to fix something on your own. Help fellow Bimmerfest members improve your wrench turning skills! All BMW DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Display Modes
  #1  
Old 07-19-2012, 05:29 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
95 530i runs rough

First off, I am new to BMWs (and this board) and this will hopefully be my first one. I just got home after looking at a 95 bmw 530i (I am going to buy it regardless its an amazing deal) and the owner says it wont stay running he needs to feather the gas and it idles super rough. But if you get it to idle up it smooths out after 3k rpm. Also while it was idling terribly sometimes it would idle up for a few seconds and sound fine. He just replaced the battery before this happened. Any thoughts? Also a tune-up has been done not to long ago. Thank You ahead of time.
Reply With Quote
Advertisement
  #2  
Old 08-15-2012, 06:19 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Its mine all mine but...

Ok y'all I bought it. It was a great car for about 2 weeks it ran great drove great but then randomly it stalled out and wouldn't start again. I got it towed home where I could start it and move it around the parking lot. Then I drove it about a mile and it died again. Now it wont start all the way but it will kinda start and sputter and die out. I am thinking its the Crankshaft position sensor....Any ideas? It will fire and sputter out so I believe that rules out the Fuel Pump. Maybe the relay?? Alright lets hear some ideas!
Reply With Quote
  #3  
Old 08-15-2012, 07:11 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Update

Alright, I had a little sunlight left so I took a screwdriver and tapped on the CKS and it fired right up and ran for about 10 minutes. Granted it was a little rough but I think that proves that my sensor is junk and needs to be replaced. If anyone objects speak up now ha. I am ordering a new one on pelican parts in about 5 minutes.
Reply With Quote
  #4  
Old 08-15-2012, 07:48 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
One at a time jeez your a chatty bunch. Part ordered I did 1 day delivery so I will have it Fri. I will update then.
Reply With Quote
  #5  
Old 08-15-2012, 09:39 PM
ndube ndube is offline
Registered User
Location: Phoenix
 
Join Date: Jun 2012
Posts: 11
Mein Auto: 1999 BMW 540i 6-speed
You might have better luck on the E34 forum.
Reply With Quote
  #6  
Old 08-19-2012, 11:05 PM
luckydog's Avatar
luckydog luckydog is offline
Lucky to drive a BMW
Location: Ca
 
Join Date: Nov 2010
Posts: 1,356
Mein Auto: 2006 M5///
Sounds A lot like Fuel pump or filter or Both about $150 total for both 2 hrs to change both.

Last edited by luckydog; 09-08-2012 at 07:47 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms