Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 07-27-2012, 11:55 PM
Bimm3rFan Bimm3rFan is offline
Registered User
Location: clarksville
 
Join Date: May 2012
Posts: 6
Mein Auto: x3 3.0i
so whats with my car acceleration and i might of put to much r134a in it to

so this morning my mom asked me to drive her to get her rental as im driving i see the car is a bit slower and i think nothing of it but when we are leaving i let my mom get in front of me and i could barley keep up with her shes going 55-58 mph and im going 70mph and she probably half a mile away and i cant even read the license plate and ive got really good eye sight.
on top of that my ac has been acting up it has some kind of blockage and i put some r 134a and i might of put to much i saw something spit out of the engine and didnt noe if it was r134a but now im scared to even turn my ac on and the temperature has been up in the 100s and wish my ac would work. anyone that may noe whats wrong with my car please just let me noe asap have a long drive tomorrow
Reply With Quote
Advertisement
  #2  
Old 07-30-2012, 05:24 PM
BMW FAN95 BMW FAN95 is offline
Registered User
Location: Chicago Illinois
 
Join Date: Nov 2010
Posts: 84
Mein Auto: 2006 BMW X3
you might have a leak,,, and sir your eyesight has gotten worse or your mom is driving a fast ass rental
Reply With Quote
  #3  
Old 07-30-2012, 10:12 PM
Ishniknork's Avatar
Ishniknork Ishniknork is offline
I hate doing dishes
Location: Ft. Worth, TX
 
Join Date: Aug 2005
Posts: 2,954
Mein Auto: '05 X3 3.0i
So let me get this straight... She's going 55-58 mph and you are doing 70 and couldn't keep up? Did you put really small wheels on your X3? That could account for a speedo error and you were really only going 45-50.

As for the A/C problem a bit more information might help us help you. What is it doing exactly? Is it blowing warm out of the passenger side vents? If so then you are low on freon.
__________________
'05 X3 3.0i Alpine White/Gray Leather/Alum. Trim
Sport/Steptronic/Servotronic/Panoramic
Premium Sound/Staggered Style 114 18"ers
Reply With Quote
  #4  
Old 07-30-2012, 11:36 PM
Bimm3rFan Bimm3rFan is offline
Registered User
Location: clarksville
 
Join Date: May 2012
Posts: 6
Mein Auto: x3 3.0i
Bmwfan :lol my eyesight is pretty good for my age hahaha and my mom drive fast LMFAO she drives 10 under the limite
Ishniknork :i have the standard bmw rims that came with it had the car checked the say the speedo and the accel are fine. i told them the story and they were stumped and they were like oh pay us another 150 and we will do another check up , i said no. and ik i was driving around 70

ac has some kind of blockage and every time i take sharp turns water spills from the feet vents. it doesnt blow enough air like it used to. since i thought it was low i filled it up with r134a stuff with the leak stopper system which it made it worst and i over filled it so now i have no air at all before it blew more air on the driver side.
Reply With Quote
  #5  
Old 07-30-2012, 11:44 PM
BMW FAN95 BMW FAN95 is offline
Registered User
Location: Chicago Illinois
 
Join Date: Nov 2010
Posts: 84
Mein Auto: 2006 BMW X3
check to see where its leaking from,, there is this dye stuff you can get, put some in and find the leak, just pray for it to be a leak and not the compressor
Reply With Quote
  #6  
Old 07-31-2012, 04:10 AM
maxeaus maxeaus is offline
Registered User
Location: Australia
 
Join Date: Jul 2012
Posts: 79
Mein Auto: x3
Quote:
Originally Posted by Bimm3rFan View Post
i told them the story and they were stumped .
There not the only ones...........
Reply With Quote
  #7  
Old 07-31-2012, 05:12 PM
Ishniknork's Avatar
Ishniknork Ishniknork is offline
I hate doing dishes
Location: Ft. Worth, TX
 
Join Date: Aug 2005
Posts: 2,954
Mein Auto: '05 X3 3.0i
Quote:
Originally Posted by Bimm3rFan View Post
Bmwfan :lol my eyesight is pretty good for my age hahaha and my mom drive fast LMFAO she drives 10 under the limite
Ishniknork :i have the standard bmw rims that came with it had the car checked the say the speedo and the accel are fine. i told them the story and they were stumped and they were like oh pay us another 150 and we will do another check up , i said no. and ik i was driving around 70

ac has some kind of blockage and every time i take sharp turns water spills from the feet vents. it doesnt blow enough air like it used to. since i thought it was low i filled it up with r134a stuff with the leak stopper system which it made it worst and i over filled it so now i have no air at all before it blew more air on the driver side.
Ah.. The A/C condensation drain hose located under the dash that runs out underneath the front/right passenger side is probably clogged or possibly disconnected. Water is building up and overflowing into the passenger compartment.

Also, when you added freon did you use the fitting that's close to the Positive jump-start connection terminal? That's the one to use. If you tried the other fitting (the high-pressure side) you may have just let all the freon out of the system.

Not sure what to think about the acceleration problem.
__________________
'05 X3 3.0i Alpine White/Gray Leather/Alum. Trim
Sport/Steptronic/Servotronic/Panoramic
Premium Sound/Staggered Style 114 18"ers

Last edited by Ishniknork; 07-31-2012 at 05:19 PM.
Reply With Quote
  #8  
Old 07-31-2012, 05:20 PM
murderland murderland is offline
Officially Welcomed to the 'Fest
Location: s/s
 
Join Date: Jan 2011
Posts: 129
Mein Auto: x3
were you driving high? i hear driving high makes you more paranoid, maybe you thought u were driving 70.
Reply With Quote
  #9  
Old 07-31-2012, 11:25 PM
Bimm3rFan Bimm3rFan is offline
Registered User
Location: clarksville
 
Join Date: May 2012
Posts: 6
Mein Auto: x3 3.0i
hahaha smh murderland no im clean bro

Ishniknork: yeah i filled it from where the jump start is the low pressure side and ur probably right but the water it coming out of the driver side. u may be right about the drain hose
the compressor is okay for now . if i dont turn the a\c on.
tell me why childish people gotta key my light/door/hood/and bumper the bumper looks like they used there car T_T not cool.

what can i use to fix these scratches there deep
and what should i do about my hood its starting to chip its paint ????? =[
Reply With Quote
  #10  
Old 08-01-2012, 07:13 AM
can0n4 can0n4 is offline
Officially Welcomed to the 'Fest
Location: Upstate NY
 
Join Date: Sep 2011
Posts: 210
Mein Auto: '04 BMW X3, '04 330xi
get some rubbing compound scratch remover for the scratches from the local parts store. Try it. Worst case scenario buy a buffing wheel and buff it with compound, if thats not gonna happen, take it to a paint shop and have them try and buff it out. If the scratches are beyond the clear coat, you'll have trouble with any of these options.

For the paint chips, buy touch up paint. bavauto has it.

Your compressor is ok as long as its not on? so is everyones.
Reply With Quote
  #11  
Old 08-01-2012, 09:27 AM
usaret usaret is offline
Officially Welcomed to the 'Fest
Location: All Over
 
Join Date: Feb 2012
Posts: 918
Mein Auto: A Gamma Goat
Quote:
Originally Posted by Bimm3rFan View Post
hahaha smh murderland no im clean bro

Ishniknork: yeah i filled it from where the jump start is the low pressure side and ur probably right but the water it coming out of the driver side. u may be right about the drain hose
the compressor is okay for now . if i dont turn the a\c on.
tell me why childish people gotta key my light/door/hood/and bumper the bumper looks like they used there car T_T not cool.

what can i use to fix these scratches there deep
and what should i do about my hood its starting to chip its paint ????? =[
If you have full coverage I would let them handle it. Did you file a police report?
Reply With Quote
  #12  
Old 08-01-2012, 11:15 AM
can0n4 can0n4 is offline
Officially Welcomed to the 'Fest
Location: Upstate NY
 
Join Date: Sep 2011
Posts: 210
Mein Auto: '04 BMW X3, '04 330xi
Quote:
Originally Posted by usaret View Post
If you have full coverage I would let them handle it. Did you file a police report?
good point.
Reply With Quote
  #13  
Old 08-01-2012, 06:36 PM
Ishniknork's Avatar
Ishniknork Ishniknork is offline
I hate doing dishes
Location: Ft. Worth, TX
 
Join Date: Aug 2005
Posts: 2,954
Mein Auto: '05 X3 3.0i
Quote:
Originally Posted by Bimm3rFan View Post
hahaha smh murderland no im clean bro

Ishniknork: yeah i filled it from where the jump start is the low pressure side and ur probably right but the water it coming out of the driver side. u may be right about the drain hose
the compressor is okay for now . if i dont turn the a\c on.
tell me why childish people gotta key my light/door/hood/and bumper the bumper looks like they used there car T_T not cool.

what can i use to fix these scratches there deep
and what should i do about my hood its starting to chip its paint ????? =[
Well, for that water problem SOMEBODY is going to have to dig in there and find the cause. I remembered another thread in here that talked about the drains in the cabin filter housing getting clogged and causing water to enter the interior. You might check that too.
__________________
'05 X3 3.0i Alpine White/Gray Leather/Alum. Trim
Sport/Steptronic/Servotronic/Panoramic
Premium Sound/Staggered Style 114 18"ers
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms