Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 07-01-2012, 09:29 PM
BmanRRT BmanRRT is offline
Registered User
Location: Phoenix
 
Join Date: Aug 2010
Posts: 25
Mein Auto: 2000 x5 4.4L
Weird Battery Drain

I have a 2000 x5 that keeps surprising me with a dead battery. I've replaced the battery and had the alternator tested (it works), but I keep coming out to a dead battery. I must have something draining the battery. I do hear some type of fan close to the firewall kick on and off as the car sits parked, even several hours after I have driven last. Anyone know of any similar issues or solutions?
Thanks for any help you guys offer.
Reply With Quote
Ads by Google
  #2  
Old 07-02-2012, 07:42 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 843
Mein Auto: 2001 X5 3.0L
Do a "SEARCH" here and on xoutpost for FSR.
Reply With Quote
  #3  
Old 07-02-2012, 12:19 PM
BmanRRT BmanRRT is offline
Registered User
Location: Phoenix
 
Join Date: Aug 2010
Posts: 25
Mein Auto: 2000 x5 4.4L
ok will do thankyou
Reply With Quote
  #4  
Old 07-30-2012, 12:27 PM
BmanRRT BmanRRT is offline
Registered User
Location: Phoenix
 
Join Date: Aug 2010
Posts: 25
Mein Auto: 2000 x5 4.4L
thanks Zulu. That apparently was it. I read around and the picture I saw other people experiancing was the smae as I was so I changed it and the problem seems to have gone away. I really appreciate your help.
Reply With Quote
  #5  
Old 07-30-2012, 01:29 PM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 843
Mein Auto: 2001 X5 3.0L
You're welcome. These boards have saved me a small fortune over the years.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms