Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series

5 Series
Ask questions and discuss the 5 Series here. If you would like to see all new posts in all the forums, click here.

 
 
Thread Tools Display Modes
  #1  
Old 06-16-2004, 07:03 PM
Miami545 Miami545 is offline
Registered User
Location: Miami
 
Join Date: Jun 2004
Posts: 4
Mein Auto: 545i
Thumbs down Airbag Deactivated with Passenger

Happy owner of 545 - 2 months so far, but patience is running thin. Passenger airbag is deactivated with passenger sitting on it (120 lbs +/-). Took car to dealer last Tuesday. They kept it for 4 days, replaced cushion, sensor, etc. Problem back over the weekend airbag gets DEACTIVATED and the light comes on with passenger on seat. Back to dealer - 3 days without my 545. Dealer has yet to remedy this. Has anybody else experience this? Was this issue resolved for you?
Ads by Google
  #2  
Old 06-17-2004, 12:43 PM
jstredw jstredw is offline
Registered User
Location: Seattle, WA
 
Join Date: Jun 2004
Posts: 6
Mein Auto: 04 525i
Quote:
Originally Posted by Miami545
Happy owner of 545 - 2 months so far, but patience is running thin. Passenger airbag is deactivated with passenger sitting on it (120 lbs +/-). Took car to dealer last Tuesday. They kept it for 4 days, replaced cushion, sensor, etc. Problem back over the weekend airbag gets DEACTIVATED and the light comes on with passenger on seat. Back to dealer - 3 days without my 545. Dealer has yet to remedy this. Has anybody else experience this? Was this issue resolved for you?

My 525 has the same exact problem. Took it to the dealer three days ago and they are still trying to figure it out.....hopefully its done today. I'll post the information I find out if it's finished.
  #3  
Old 06-17-2004, 05:54 PM
Miami545 Miami545 is offline
Registered User
Location: Miami
 
Join Date: Jun 2004
Posts: 4
Mein Auto: 545i
Quote:
Originally Posted by jstredw
My 525 has the same exact problem. Took it to the dealer three days ago and they are still trying to figure it out.....hopefully its done today. I'll post the information I find out if it's finished.
Showed up at the dealer today too check on progress. Asst. Service Manager took me to see the car plugged into the computer. BMW N.A. Tech Dept. instructed dealer to RE-PROGRAM the car. Yikes!!!! I hope technician does not "screw up" something else. I'll post BMW's description of problem from the work order when I get the car tomorrow.
  #4  
Old 06-17-2004, 11:17 PM
jstredw jstredw is offline
Registered User
Location: Seattle, WA
 
Join Date: Jun 2004
Posts: 6
Mein Auto: 04 525i
Quote:
Originally Posted by Miami545
Showed up at the dealer today too check on progress. Asst. Service Manager took me to see the car plugged into the computer. BMW N.A. Tech Dept. instructed dealer to RE-PROGRAM the car. Yikes!!!! I hope technician does not "screw up" something else. I'll post BMW's description of problem from the work order when I get the car tomorrow.
Thats about what the service advisor I was working with said when I called him today. They reprogrammed it today and wanted to "leave it overnight" and then test drive it in the morning. He told me it "should" be ready for pickup tomorrow morning. So we will see.
__________________
2004 525i: alpine white, black leather, poplar wood, steptronic, premium, sport, winter, shades, premium/logic7 sound, sat. prep, split rear seats, adaptive xenon, PDC, clear bra.
  #5  
Old 06-18-2004, 03:49 PM
jstredw jstredw is offline
Registered User
Location: Seattle, WA
 
Join Date: Jun 2004
Posts: 6
Mein Auto: 04 525i
Got the car back from the dealer today but they said that the problem was normal. They updated the software to 11.3 since 12 isnt supposedly suppose to be there till next week. "(Shop Foreman) Spoke with Tech Support due to not being able to verify complaint/ Normal if light stays on with a light person." So the problem stays unresolved I guess.
__________________
2004 525i: alpine white, black leather, poplar wood, steptronic, premium, sport, winter, shades, premium/logic7 sound, sat. prep, split rear seats, adaptive xenon, PDC, clear bra.
  #6  
Old 06-19-2004, 06:52 PM
Mr Hyde's Avatar
Mr Hyde Mr Hyde is offline
Officially Welcomed to the 'Fest
Location: Long Island, NY
 
Join Date: May 2004
Posts: 529
Mein Auto: 03 540i M-Technic
Quote:
Originally Posted by jstredw
Got the car back from the dealer today but they said that the problem was normal. They updated the software to 11.3 since 12 isnt supposedly suppose to be there till next week. "(Shop Foreman) Spoke with Tech Support due to not being able to verify complaint/ Normal if light stays on with a light person." So the problem stays unresolved I guess.
How could they say that having that airbag deactivated when someone is sitting in the seat is normal? I wouldnt accept that as an answer, and would definitely escalate the matter.
  #7  
Old 06-19-2004, 07:33 PM
jstredw jstredw is offline
Registered User
Location: Seattle, WA
 
Join Date: Jun 2004
Posts: 6
Mein Auto: 04 525i
Quote:
Originally Posted by Mr Hyde
How could they say that having that airbag deactivated when someone is sitting in the seat is normal? I wouldnt accept that as an answer, and would definitely escalate the matter.
They checked three other cars and found it to be "normal" operation. I guess any passenger that is right at the threshold (I'm assuming +-120 lbs) is prone to this, which I find incredibly unacceptable. I stated this to the service manager over and over and he said they would look further into it and give me a definite answer by Monday.
__________________
2004 525i: alpine white, black leather, poplar wood, steptronic, premium, sport, winter, shades, premium/logic7 sound, sat. prep, split rear seats, adaptive xenon, PDC, clear bra.
  #8  
Old 06-21-2004, 05:56 PM
Miami545 Miami545 is offline
Registered User
Location: Miami
 
Join Date: Jun 2004
Posts: 4
Mein Auto: 545i
Got my 545 back late Friday afternoon.

BMW dealer completed system reprogram, and replaced the passenger seat/sensor cushion. Mechanic test drove it once with a 115 lb passenger and another time with an 80 lb passenger. They say it was OK to release to owner. Drove it over weekend and seems to respond properly.

To the other owners with similar symptoms - Do not accept flimsy answers from a dealer that says this problem is “normal”. Demand resolution. If BMW felt this airbag system was ready for production then they have to stand behind it. This is not a cheap car… it’s the ultimate driving machine and we paid for it! Proper operation of the car’s includes the airbag system. Hold the line with the BMW dealers – no cutting corners.
  #9  
Old 06-22-2004, 01:50 AM
heezyo2o heezyo2o is offline
Officially Welcomed to the 'Fest
Location: So Cali
 
Join Date: Mar 2004
Posts: 124
Mein Auto: .
This will probably be resolved with future software upgrades.

I took my car in for the service engine light, and it was more of a hassle than it was worth. I was out of the car for the weekend, had a hard time getting a loaner car and had new problems upon reciept of the car.

I say just hold on to the car as is if it doesn't bother that much and let the dealer experiment on someone else's car. Once they have a tried and true method to fix things, bring the car in then.
  #10  
Old 06-22-2004, 07:33 AM
sj3 sj3 is offline
Registered User
Location: Northern NJ
 
Join Date: Feb 2004
Posts: 73
Mein Auto: 2004 545iA
I took the following from the US users manual (~ page 85). I thought I had read that the threshold was supposed to be 50 pounds but I couldn't find that reference. They are saying that if you want the airbag and the light is on, move the person to the back set where you hopefully have the side airbag option! 120 pounds is way too much to deactvate the airbag. I can't believe they are saying that's normal. I'd be pretty peeved if I was transporting anyone I cared about. Good luck.

Sam

Although not desired, it can occur in
the case of heavier children that the
front passenger airbags remain active or in
the case of very light adults or young persons
that the front passenger airbags are
deactivated.
The state of the front passenger airbags is
shown with the telltale lamp, refer to Indicator
lamps in the following. In this case
transport the corresponding persons on
the rear seat.
__________________
Ex: 2000 540iA w/Nav., Prem. Sound, Comf. Seats, Park Distance, Fold-down rears; 30,000 mi; Baritz Blue/Beige
Delivered 5/14/04: 2004 545iA w/Nav., Prem. Sound, Comf. Seats, Cold Weather Pkg., Park Distance, Fold-down rears.; Orient Blue/Beige
  #11  
Old 06-23-2004, 10:06 AM
sam530 sam530 is offline
sam530
Location: Los Angeles, CA
 
Join Date: Jun 2004
Posts: 3
Mein Auto: 2004 530i
I've had the exact same problem...my car is at the dealer right now! Second time for the same problem. I've had this problem since October 03 when I took delivery. Dealer states software issue. We shall see...
  #12  
Old 06-23-2004, 10:36 AM
Salvator's Avatar
Salvator Salvator is offline
Livin' like Larry!
Location: NOVA
 
Join Date: Oct 2003
Posts: 8,893
Mein Auto: 2007 328XiT; 2008 328 CiC
Interesting that BMW stays mum about problems like this, and Hyundai (apparently having a similar problem) at least makes it problems known...

http://abcnews.go.com/sections/Busin..._040623-1.html
__________________
  #13  
Old 06-23-2004, 02:04 PM
BrettInLJ BrettInLJ is offline
Officially Welcomed to the 'Fest
Location: San Francisco, CA
 
Join Date: Oct 2003
Posts: 311
Mein Auto: 525i 1993
Quote:
Originally Posted by Salvator
Interesting that BMW stays mum about problems like this, and Hyundai (apparently having a similar problem) at least makes it problems known...

http://abcnews.go.com/sections/Busin..._040623-1.html
I saw that article too, and after I read it I sent abcnews.com a news tip about this and gave them a link to this thread. Hopefully it will catch one of the editors' eyes.
__________________
Brett
San Francisco, CA


*** SOLD *** (pics of my E34 to be posted soon)
1999 540i 6-speed
Dinan CAI/Stage II Software
Xenon Headlights
M-Technik Rear Bumper
CDV Delete
Clear Front/Side Blinkers
  #14  
Old 10-18-2004, 05:17 PM
xspeedy's Avatar
xspeedy xspeedy is offline
mmm... carbs!
Location: Austin, TX
 
Join Date: Apr 2003
Posts: 3,057
Mein Auto: 2007 E90 335i
I have a similar problem with my 2005 X3. I did an ED and while driving with my wife in the passenger seat, the light seems to intermittently come on. Sometimes, if my wife shifts around, the light will temporarily go off.

She weighs about 112 lbs, and should be plenty heavy to keep the bag activated. Is there any official number on the weight requirement? Seems kind of crazy to drive around and not have that airbag work in case it is needed.
  #15  
Old 10-19-2004, 07:22 PM
CapeBimmer CapeBimmer is offline
Officially Welcomed to the 'Fest
Location: SE Florida
 
Join Date: Mar 2002
Posts: 143
Mein Auto: - - - -
I had (have ?) the same problem. Since a reprogram it hasn't happened again. Or maybe my wife put on a couple of pounds (probably not).
__________________
545ia Sport, Titanium Silver, Grey, Nav., Cold Weather, folding seats, 19" Hartge Classics w/BS Pole SO3s, Bluetooth
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms