Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #26  
Old 08-08-2012, 08:16 AM
STIHLBOLTS STIHLBOLTS is offline
Hat's On, Tops Down!
Location: Georiga
 
Join Date: Feb 2008
Posts: 1,021
Mein Auto: 2008 Z4MR
There is nothing in my glove box. The Aux input is under the dash just above the ashtray. It is in that rectangle plate. The dealer did not charge me for anything, it was part of the purchase deal that they install it. But like I said earlier I was under the impression they would take out the cig lighter and put it there, but when I picked up the car and did not see it I got upset with them until they pointed out it was under the dash hidden from direct view. I'll post a picture tonight. According to Fedex and USPS, my cable and clip should be here tomorrow. Once I get it installed I will post a picture.
__________________

2008 Z4M Roadster
BMWCCA/ZSCCA Member
Reply With Quote
  #27  
Old 08-08-2012, 01:40 PM
chickdr chickdr is offline
Officially Welcomed to the 'Fest
Location: Atlanta, GA
 
Join Date: Mar 2009
Posts: 1,044
Mein Auto: '06 M Roadster Imola/Blk
Quote:
Originally Posted by STIHLBOLTS View Post
There is nothing in my glove box. The Aux input is under the dash just above the ashtray. It is in that rectangle plate. The dealer did not charge me for anything, it was part of the purchase deal that they install it. But like I said earlier I was under the impression they would take out the cig lighter and put it there, but when I picked up the car and did not see it I got upset with them until they pointed out it was under the dash hidden from direct view. I'll post a picture tonight. According to Fedex and USPS, my cable and clip should be here tomorrow. Once I get it installed I will post a picture.
I knew you didn't have a glovebox connection, but now I get it. I suspect it was there all along and the dealer just wasn't aware of it until they looked. It is very hard to see(really impossible without either feeling it, or craning your head down to look under the panel). The SpecDoc is really the cleanest install for the iPhone. Just $$$$.
Reply With Quote
  #28  
Old 08-08-2012, 04:31 PM
STIHLBOLTS STIHLBOLTS is offline
Hat's On, Tops Down!
Location: Georiga
 
Join Date: Feb 2008
Posts: 1,021
Mein Auto: 2008 Z4MR


The plug came in today, as you can see the USB goes to power and the MP3 goes under the dash. I had to use the phone to take the picture, but you get the idea. The bracket will go to the right of the A/C control. The cords are just the right length for the Iphone position. No I won't have any steering wheel or monitor control over the Iphone other than volume. But its right there and close at hand, less a whole lot of clutter.
__________________

2008 Z4M Roadster
BMWCCA/ZSCCA Member
Reply With Quote
  #29  
Old 08-08-2012, 05:52 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Quote:
Originally Posted by Cvaria View Post
use this $30 oem part and mount it in your ashtray or wherever else.

It is designed for the 3 series but works in the z4



http://www.amazon.com/BMW-Genuine-Auxiliary-Audio-Series/dp/B000PA00XM

Ordered the 30.00 aux input today. Came to 40 with shipping. I'll keep everyone updated
Reply With Quote
  #30  
Old 08-08-2012, 06:50 PM
GriffBrew GriffBrew is offline
Registered User
Location: Orlando, FL
 
Join Date: Jul 2012
Posts: 20
Mein Auto: 06 M Roadster
I just installed mine today. Very easy and completely straightforward. Pull out the vents, pull out the stereo plug it in and go!

One hiccup for me was the plug on the radio. There is a big, rotating piece that holds all the plugs in to the radio. You have to tilt that back and unplug from the radio. Then I slipped the connector into that piece and put it back together. At first, I didn't understand this and thought I had the wrong part.

I used Amazon, but bought one labelled for the X3/X5 http://www.amazon.com/BMW-Genuine-Au.../dp/B000PA03AC This worked fine on my 2006 Z4MR w/o CD Changer. I think I selected it because I could get it with Prime (I can't remember what I did two days ago).

Oh, one other hiccup. I wanted the install plate that came with the plug to be installed on the outside. I drilled holes for it and put it together, but found that the plug wasn't seated right so I could only get on channel from my headphone jack. I removed the plate (for now) and just have the 3.5mm jack there. It works fine, but I'm frustrated I have two drill holes for the screws that hold the plate in place. I need to countersink the plug a little to get the plate to seat correctly. I assume the install location in the X3/X5 is thinner than this panel we are all mounting to in the Z4. No big deal, I just didn't want to spend the extra time today and I plan to add a cigarette plug there for additional power so I'll already be taking it apart again.
Reply With Quote
  #31  
Old 08-09-2012, 05:57 AM
STIHLBOLTS STIHLBOLTS is offline
Hat's On, Tops Down!
Location: Georiga
 
Join Date: Feb 2008
Posts: 1,021
Mein Auto: 2008 Z4MR
You can always get a new cover plate, they are only $13 from BMW.
__________________

2008 Z4M Roadster
BMWCCA/ZSCCA Member
Reply With Quote
  #32  
Old 08-09-2012, 06:04 AM
GriffBrew GriffBrew is offline
Registered User
Location: Orlando, FL
 
Join Date: Jul 2012
Posts: 20
Mein Auto: 06 M Roadster
Quote:
Originally Posted by STIHLBOLTS View Post
You can always get a new cover plate, they are only $13 from BMW.
And you can order the 2007 and up version which includes the aux port name plate already installed!
Reply With Quote
  #33  
Old 08-09-2012, 06:24 AM
STIHLBOLTS STIHLBOLTS is offline
Hat's On, Tops Down!
Location: Georiga
 
Join Date: Feb 2008
Posts: 1,021
Mein Auto: 2008 Z4MR
__________________

2008 Z4M Roadster
BMWCCA/ZSCCA Member
Reply With Quote
  #34  
Old 08-09-2012, 02:39 PM
jcutrell jcutrell is offline
Registered User
Location: Georgetown, Ohio (USA)
 
Join Date: Jun 2009
Posts: 26
Mein Auto: 2003 BMW Z4
I just used a small grinder to remove some of the plastic from inside of the cover plate (where it wouldn't be seen). It worked fine.
Reply With Quote
  #35  
Old 08-09-2012, 09:04 PM
Psygnosis Psygnosis is offline
Officially Welcomed to the 'Fest
Location: WA
 
Join Date: Oct 2008
Posts: 253
Mein Auto: 2004 Z4 3.0i Sport
I left the plate off the jack when I installed mine, the jack screws together and that holds it in place.

I've heard that you might not be able to get the old panel from BMW anymore. They may only have the 2007/2008 part now, the one with the cut out for the AUX
Reply With Quote
  #36  
Old 08-09-2012, 09:29 PM
WestCDA WestCDA is offline
Officially Welcomed to the 'Fest
Location: Calgary, AB
 
Join Date: Mar 2011
Posts: 183
Mein Auto: 2006 Z4 3.0si
That does seem to be the case - I ordered the original (no cutout) panel for my 2006 so I could experiment with installing a homelink module, and was shipped the one for the later cars with the aux plug cutout in it.

I ended up modifying my original for the homelink install, and also recently added an aux jack to it as well. No 'AUX IN' name plate - you can't see it under there anyway. I just drilled a hole, stuck the jack through and screwed on the outer ring.
Reply With Quote
  #37  
Old 08-11-2012, 12:17 PM
STIHLBOLTS STIHLBOLTS is offline
Hat's On, Tops Down!
Location: Georiga
 
Join Date: Feb 2008
Posts: 1,021
Mein Auto: 2008 Z4MR
I got everything installed. Wedge the top of the clip in, push the bottom part down to grab the seam and it snaps in place with the help of a little bit of double stick tape. The holder comes in several varieties, I choose the non powered one because of the Y cable. So if you find you already have the MP3 Plug under the dash this is the simplest solutions IMHO.
Love it.

Many thanks to Skipkiller and BruceJ for the assistance.

Items Used:

1. BMW USB Power plug - Tishner $19.95
2. Y Plug - http://www.ebay.com/itm/400218936351...84.m1497.l2649 $13.89 + shipping
3. ProClip USA - Clip and Non-Powered holder. $70.00 + shipping




__________________

2008 Z4M Roadster
BMWCCA/ZSCCA Member

Last edited by STIHLBOLTS; 08-11-2012 at 12:22 PM.
Reply With Quote
  #38  
Old 08-11-2012, 12:24 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Thanks for the pics! That's exactly what I'm going to do now. I have a dual USB charger in the mail already. I also have a aux/USB cable that's been sitting in my house. Paid 2.97 for the cigarette charger, 7 for the USB/aux cable, and 40 for the aux kit on amazon.
Reply With Quote
  #39  
Old 08-13-2012, 03:35 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
My aux input came in today! ..and I'm pretty sure it's the wrong part. Here are a few pics. The part says its for a e46 3 series..

Photobucket Pictures, Images and Photos

Photobucket Pictures, Images and Photos

Photobucket Pictures, Images and Photos
Reply With Quote
  #40  
Old 08-13-2012, 04:59 PM
GriffBrew GriffBrew is offline
Registered User
Location: Orlando, FL
 
Join Date: Jul 2012
Posts: 20
Mein Auto: 06 M Roadster
Quote:
Originally Posted by Droptop85 View Post
My aux input came in today! ..and I'm pretty sure it's the wrong part. Here are a few pics. The part says its for a e46 3 series..
It should fit into the large plug that was in your stereo. It fits into the bottom-right of that plug. Then, the whole plug goes back into the stereo. Mine was for 5-series/X5, but it fit and works great. The plugs all look the same to me on the Amazon photos. http://www.amazon.com/gp/product/B00...ls_o00_s02_i00
Reply With Quote
  #41  
Old 08-13-2012, 07:21 PM
bten's Avatar
bten bten is offline
Luv'in Texas
Location: Missouri City, TX
 
Join Date: Sep 2002
Posts: 957
Mein Auto: '08 Z4 3.0si
Quote:
Originally Posted by GriffBrew View Post
It should fit into the large plug that was in your stereo. It fits into the bottom-right of that plug. Then, the whole plug goes back into the stereo. Mine was for 5-series/X5, but it fit and works great. The plugs all look the same to me on the Amazon photos. http://www.amazon.com/gp/product/B00...ls_o00_s02_i00

+1

Check the Main plug that is held in with a lever on the back of the radio. the Aux in cable plugs into the back of the Main plug (you plug it into the plug)
__________________
2008 Space Gray Z4 3.0 si, Saddle Leather interior (to haul A$$)
2011 Nissan Frontier King Cab (to haul crap)
2010 Lexus RX350 (to haul people)
2009 Club Car Precedent (to putter around the beach)
Reply With Quote
  #42  
Old 08-13-2012, 08:50 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
There is six prongs on the bottom right of the stereo and 5 holes on the connector. Is that right?
Reply With Quote
  #43  
Old 08-13-2012, 08:51 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Mine is for the e46 3 series but was said to be universal for the z4. But I just couldn't seem to get it to fit correctly
Reply With Quote
  #44  
Old 08-14-2012, 06:54 AM
Cvaria's Avatar
Cvaria Cvaria is offline
Officially Welcomed to the 'Fest
Location: Tallahassee, Florida
 
Join Date: Sep 2011
Posts: 376
Mein Auto: 2003 Z4 ; 2002 Wrangler;
Quote:
Originally Posted by Droptop85 View Post
Mine is for the e46 3 series but was said to be universal for the z4. But I just couldn't seem to get it to fit correctly

trust us... it's the right part. (http://www.bimmernav.com/store/catal...-item-156.html)


you must use the stock harness
install threads: http://www.bimmerfest.com/forums/sho...=180804&page=1
__________________
I like my 2003 Z4 2.5i... but love my smelly old 2002 Wrangler SE and evil 2007 HD Sportster 883/1200 conv!

Reply With Quote
  #45  
Old 08-14-2012, 10:38 AM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
The connection on the back of the radio is a 12 pin connector. The aux harness is a 10 pin connector. I think they shipped the wrong part?
Reply With Quote
  #46  
Old 08-14-2012, 10:53 AM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Nv! I'm going to make it work. Thanks for the help everyone!!
Reply With Quote
  #47  
Old 08-14-2012, 11:49 AM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Got it! I removed the grey cover on the aux cable and revealed the smaller black connector that allowed it to fit behind the stereo. Here are some pics so future installers can see where exactly the 3 wires need to be. And then the final product.

Removed grey cover
Photobucket Pictures, Images and Photos

Placed connector bottom right of stereo one pin to the left (hard to see)
Photobucket Pictures, Images and Photos

Photobucket Pictures, Images and Photos

Ran cable down
Photobucket Pictures, Images and Photos

Installed aux input in bottom cover.
Photobucket Pictures, Images and Photos

Photobucket Pictures, Images and Photos

And tada!
Photobucket Pictures, Images and Photos

Works like a charm. Sounds perfect.
Reply With Quote
  #48  
Old 08-15-2012, 04:23 AM
GriffBrew GriffBrew is offline
Registered User
Location: Orlando, FL
 
Join Date: Jul 2012
Posts: 20
Mein Auto: 06 M Roadster
Excellent! Mine didn't have that grey cover. Thanks for pics, that will definitely help others in the future. I regret not taking photos as I went.
Reply With Quote
  #49  
Old 08-15-2012, 07:17 AM
Cvaria's Avatar
Cvaria Cvaria is offline
Officially Welcomed to the 'Fest
Location: Tallahassee, Florida
 
Join Date: Sep 2011
Posts: 376
Mein Auto: 2003 Z4 ; 2002 Wrangler;
Quote:
Originally Posted by Droptop85 View Post
...
Works like a charm. Sounds perfect.
and you saved $!!
__________________
I like my 2003 Z4 2.5i... but love my smelly old 2002 Wrangler SE and evil 2007 HD Sportster 883/1200 conv!

Reply With Quote
  #50  
Old 08-03-2013, 07:47 AM
cuttermd cuttermd is offline
Registered User
Location: Glen Allen,VA
 
Join Date: Aug 2013
Posts: 1
Mein Auto: 2003 Z4 3.0i
New Z owner, just installed the aux input

Thanks for posting the pics for getting this to work by removing the grey cover. I had the same kit for (E46) & you saved me alot of time on the install.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms