Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #26  
Old 08-17-2012, 01:23 AM
BmwMan92's Avatar
BmwMan92 BmwMan92 is offline
I <3 my E34
Location: Seattle, Wa // Everett
 
Join Date: Dec 2009
Posts: 1,603
Send a message via Skype™ to BmwMan92
Mein Auto: 1985 318i// 1988 325e
Sending in the morning i have cash so it will be shipped first thing in the morning i set an alarm in my phone lol. I'm so sorry i haven't sent it i've been so busy then i got in an accident yesterday. afm will be headed your way tomorrow!
__________________
Brandon
http://www.facebook.com/brandon.m.fore


Quote:
Originally Posted by v8bimmer View Post
I just dont see any other logical way around this problem.
Reply With Quote
  #27  
Old 08-17-2012, 04:09 AM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
That's cool man, thanks! Text me when you ship and I'll Paypal.

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #28  
Old 09-12-2012, 05:31 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
New fuel pressure regulator installed, idles now!

Now, have to throw it together for a test drive!

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #29  
Old 09-13-2012, 06:03 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
Scratch that, not right yet.

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #30  
Old 09-14-2012, 12:12 AM
BmwMan92's Avatar
BmwMan92 BmwMan92 is offline
I <3 my E34
Location: Seattle, Wa // Everett
 
Join Date: Dec 2009
Posts: 1,603
Send a message via Skype™ to BmwMan92
Mein Auto: 1985 318i// 1988 325e
Did the afm I sent you not help? I know it works I used it on the 318 before I shipped it
__________________
Brandon
http://www.facebook.com/brandon.m.fore


Quote:
Originally Posted by v8bimmer View Post
I just dont see any other logical way around this problem.
Reply With Quote
  #31  
Old 09-14-2012, 06:33 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
Nah, don't think that's the problem. Fuel issue I believe

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #32  
Old 09-15-2012, 11:07 AM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,261
Mein Auto: E23;E30;E38;E32;E34 +
Have you run a pressure check and changed the fuel filter? Looking at what the PO's did to the dash I'm amazed it's even running! I hope you were paid to take it away. I've seen parts cars better than that. Good to see a bloke who loves a chalenge. I saw a AFM fix on another forum (can't remember which) for this style of meter. You do have to have all the bits installed and working before the engine will run properly and it's a pain to establish what the ECM is missing out on. It is always a great feeling to drive your own rebuild. Goog luck.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #33  
Old 09-18-2012, 03:09 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
Alright, real fuel pressure updates, sorry for the videos, some are quite long. I did replace the fuel and air filter as well.









To sum, fuel pressure engine off in spec, maybe a hair under.


Fuel pressure engine on, 30 or so psi, spec is 43psi or so.
__________________
Turbo Build Here


Reply With Quote
  #34  
Old 09-18-2012, 06:07 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 7,048
Mein Auto: 2012 hypermotard 796
what the timing like and looks like theres a vacuum advance on the distributor. its sounds like in the middle video that theres a miss fire, which to me sounds like bad timing
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming

Last edited by downhiller; 09-18-2012 at 06:09 PM.
Reply With Quote
  #35  
Old 09-19-2012, 03:59 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
How do I check the timing? I don't think it's missing until very low rpm, were the low fuel preassure just isn't cutting it.

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #36  
Old 10-25-2012, 05:29 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
She has no issues with no load, but under load it has a mis for sure. Thoughts? New cap rotor and plugs, old wires and old distributor. Entire fuel system is new. Going to try some seafoam tomorrow and see how that goes.


Here is a vid, the second one is weird, the idle goes up and down then eventually settles. Computer adapting or something else?








Stoked!
__________________
Turbo Build Here


Reply With Quote
  #37  
Old 10-28-2012, 08:55 AM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
I think it's a spark related miss, the wires look pretty bad. Of course no one had the wires. Oh well they'll be here Wednesday.

Did a lot if work on it the past few days. Replaced almost all the exterior bulbs as most weren't working and the turn signals were acting up. All better now.

Ran some seafoam through it too. I need to do it again and put some in the fuel and oil again. It actually didn't smoke much.

Hooked up the window switches, they had the control wires for the motors themselves, but no power or ground, odd. They work great now!

Then did some hobo floor repair. Cut out the worst rust, then cut and screwed down an old real estate sign.


I finished it up by covering it all up underneath with fiberglass. Later I'll undercoat the top, then the bottom after I sand the fiberglass.

Then I gave the engine bay and under the engine a quick clean. I'm trying to locate my oil leak. I think the majority is the valve cover gasket so I'll have to put one on order.

Pictures will be up soon.

Didn't have as many pictures as I thought lol, I'll have to take some more.


Nasty floor



Before



After

__________________
Turbo Build Here


Reply With Quote
  #38  
Old 11-01-2012, 04:17 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
New plug wires helped, still has a misfire. Thoughts? Going to pull the plugs tomorrow and inspect and check gap.


Coil maybe? It tested ever so slightly out of spec.

AFM?

O2 sensor?
__________________
Turbo Build Here


Reply With Quote
  #39  
Old 11-01-2012, 05:54 PM
ForcedFirebird's Avatar
ForcedFirebird ForcedFirebird is offline
Officially Welcomed to the 'Fest
Location: Coral Springs
 
Join Date: Feb 2007
Posts: 809
Mein Auto: 1986 327is
Compression tested yet?
__________________
Wide Open Throttle Technologies (WOT-Tech)

The 1986 325es Delphin project LINK

Project 1988 325i sedan "Pinky" LINK
Reply With Quote
  #40  
Old 11-01-2012, 05:57 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
I have not tried that, but it only misses under load. Revs perfect in neutral. I removed each wire one by one and it acted the same between each. Maybe I'll test compression tomorrow.

Thinking I'll put an O2 sensor on it since it's only 16 bucks. The idle can sometimes surge as well. Cleaned the icv already though.

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #41  
Old 11-01-2012, 08:06 PM
hornhospital's Avatar
hornhospital hornhospital is offline
D'oh, You kids!
Location: In the Grumpy Chair
 
Join Date: Jan 2008
Posts: 14,094
Mein Auto: 1995 318is / 1993 325is
Injectors clean? That sounds like an injector issue, especially the random misfires.
__________________
Quotes to live by:
guessing gets expensive...drivinfaster
nothing is more expensive than a cheap BMW...c4harpe13

Ken Kanne, Silverhill, AL, E36 Forum Mod/Craigslist addict/Hoarder of all sorts of stuff
BMW-CCA #441426
1995 318is "Bebe"; 1993 325is "Elvira" 1985 635CSi "Katja" 1984 633CSi "Sylvia"
HAVE I HAD MY MEDS YET?

Reply With Quote
  #42  
Old 11-02-2012, 05:52 AM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
I removed them long ago and soaked them over night. Then I seafoamed it last week.

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #43  
Old 11-02-2012, 08:28 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
She's running pretty good, almost perfect. New O2 senser helped I think. Slight miss at idle, I believe it's number two because using a temp gun it showed around 75 degrees or more cooler.

Still has the little hesitation under load, but it's much much reduced. I'm thinking it's low compression I'm number two or a bad fuel injector.




Sent from my ADR6400L using Bimmer App

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #44  
Old 11-02-2012, 09:21 PM
hornhospital's Avatar
hornhospital hornhospital is offline
D'oh, You kids!
Location: In the Grumpy Chair
 
Join Date: Jan 2008
Posts: 14,094
Mein Auto: 1995 318is / 1993 325is
Soaking won't remove most deposits in an injector, it just loosens them up a little. It really needs to be ultrasonically cleaned (preferably multiple times) and have cleaner run through it from both directions. I used WitchHunter Performance for the M30 injectors I sent off today because I'd used them before and had excellent results. For $21 per injector (plus $10 flat rate return shipping), it's a bargain IMO.
__________________
Quotes to live by:
guessing gets expensive...drivinfaster
nothing is more expensive than a cheap BMW...c4harpe13

Ken Kanne, Silverhill, AL, E36 Forum Mod/Craigslist addict/Hoarder of all sorts of stuff
BMW-CCA #441426
1995 318is "Bebe"; 1993 325is "Elvira" 1985 635CSi "Katja" 1984 633CSi "Sylvia"
HAVE I HAD MY MEDS YET?

Reply With Quote
  #45  
Old 11-10-2012, 03:49 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
Could my factory M50 injectors work or would it cause it to run incorrectly due to too much fuel?


Carpet on the way! 125 shipped.
Need to dye it and my door panels black.


Sent from my ADR6400L using Bimmer App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1352591301733.jpg
Views:	56
Size:	84.4 KB
ID:	349059  
__________________
Turbo Build Here


Reply With Quote
  #46  
Old 11-10-2012, 04:39 PM
hornhospital's Avatar
hornhospital hornhospital is offline
D'oh, You kids!
Location: In the Grumpy Chair
 
Join Date: Jan 2008
Posts: 14,094
Mein Auto: 1995 318is / 1993 325is
I think the M50 injectors are a difference impedence that the OEM M10 injectors, and won't work, or work poorly.

What dye are you using?
__________________
Quotes to live by:
guessing gets expensive...drivinfaster
nothing is more expensive than a cheap BMW...c4harpe13

Ken Kanne, Silverhill, AL, E36 Forum Mod/Craigslist addict/Hoarder of all sorts of stuff
BMW-CCA #441426
1995 318is "Bebe"; 1993 325is "Elvira" 1985 635CSi "Katja" 1984 633CSi "Sylvia"
HAVE I HAD MY MEDS YET?

Reply With Quote
  #47  
Old 11-11-2012, 11:14 AM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
Not sure Ken.

Dye suggestions?

Sent from my ADR6400L using Bimmer App
__________________
Turbo Build Here


Reply With Quote
  #48  
Old 11-11-2012, 11:59 AM
hornhospital's Avatar
hornhospital hornhospital is offline
D'oh, You kids!
Location: In the Grumpy Chair
 
Join Date: Jan 2008
Posts: 14,094
Mein Auto: 1995 318is / 1993 325is
Rit, believe it or not.

http://www.ritdye.com/
__________________
Quotes to live by:
guessing gets expensive...drivinfaster
nothing is more expensive than a cheap BMW...c4harpe13

Ken Kanne, Silverhill, AL, E36 Forum Mod/Craigslist addict/Hoarder of all sorts of stuff
BMW-CCA #441426
1995 318is "Bebe"; 1993 325is "Elvira" 1985 635CSi "Katja" 1984 633CSi "Sylvia"
HAVE I HAD MY MEDS YET?

Reply With Quote
  #49  
Old 11-12-2012, 04:28 PM
FenderBender's Avatar
FenderBender FenderBender is online now
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,175
Mein Auto: Red Sled
I'll check it out!

Here is my hobo floor lol. Used bedliner spray on top. I'll probably do the other side tomorrow then undercoat the bottom of the car. Sorry for being dark.



Sent from my ADR6400L using Bimmer App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1352766435043.jpg
Views:	73
Size:	66.1 KB
ID:	349329   Click image for larger version

Name:	uploadfromtaptalk1352766465479.jpg
Views:	72
Size:	63.1 KB
ID:	349330   Click image for larger version

Name:	uploadfromtaptalk1352766494128.jpg
Views:	72
Size:	67.9 KB
ID:	349331  
__________________
Turbo Build Here


Reply With Quote
  #50  
Old 11-12-2012, 11:15 PM
Nick323's Avatar
Nick323 Nick323 is offline
Nick's Toys
Location: Windhoek, Namibia, Africa
 
Join Date: Jun 2012
Posts: 704
Mein Auto: 323i E30 2-door
I think this a splendid idea
__________________
Don't take life too seriously; no one gets out alive !
1984 323 currently being resurrected from the ashes
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms