Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 08-10-2012, 05:15 PM
Harry Angus Harry Angus is offline
Registered User
Location: Gold Coast, Australia
 
Join Date: Aug 2012
Posts: 2
Mein Auto: e53 X5 2001
X5 Uncommanded Braking

Hi Ya,

I have experienced uncommanded braking on the E53 X5 2001 on 2 occasions.
Both times vehicle has been travelling at low speed and the brakes just come on without pressing the pedal, and no warning lights illuminated.

Very freaky.

First time it happened as I went over a little speed hump and my foot was on the throttle pedal.

Second time, I had just taken off from the driveway on a sealed road and was accelerating.

Both times the vehicle came to a stop without any signs or indications that it was going to happen and I could feel the ABS working ... it was quite a sudden braking.

First time the vehicle was at normal operating temp.
Second time it was cold.

I have pulled the wheels off and had a good look around but nothing obvious stands out. except the rear rotors are quite worn. All ABS sensors look fine, brake lines look fine, all the pads are OK and there has been no warnings that anything is wrong until I faceplanted the windscreen.

Its the family car / shopping trolley... so it gets a pretty easy life.

I'm hoping you can help because wifey is scared to drive it and my nose is now squished flat .
Reply With Quote
Advertisement
  #2  
Old 08-10-2012, 06:27 PM
x5alpine x5alpine is offline
Registered User
Location: reno nv
 
Join Date: Jan 2011
Posts: 47
Mein Auto: jeep wrangler
My friends dad had the same problem with his 01 x5 3.0i and it ended up being the ABS module
Reply With Quote
  #3  
Old 08-10-2012, 07:36 PM
Harry Angus Harry Angus is offline
Registered User
Location: Gold Coast, Australia
 
Join Date: Aug 2012
Posts: 2
Mein Auto: e53 X5 2001
Hi Alpine.
Thanks for the quick reply.
Sounds exe!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms