Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 08-14-2012, 10:33 AM
todd92 todd92 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Feb 2009
Posts: 628
Mein Auto: 13 X3 3.5, 05 ZHP
CPO Save

2007 X3 with 60,000 miles, 4 months left on the CPO warranty. Front and rear washer fluid pumps failed and both rear coil springs and pads are cracked. It's only costing me $50, but I'm very surprised the coil springs are broken. Anyone else see this?
Reply With Quote
Advertisement
  #2  
Old 08-14-2012, 11:17 AM
X3-terrestrial's Avatar
X3-terrestrial X3-terrestrial is offline
Aficionado
Location: N.Miss - Memphis,TN Area
 
Join Date: Aug 2008
Posts: 2,632
Mein Auto: '05 X3, '95 M3, '89 MkI
Seen a couple of cases here...How did you find out they were broken?
__________________
"If everything seems under control, you're just not going fast enough"
-Mario Andretti.

___________________
River City Bimmers BMW CCA
2005 X3 3.0i ZPP, Htd seats, Htd strng, Black Sapphire on Terracotta.
1995 ///M3 Coupe, Lux, MT, Htd seats, Cosmos Black on Black.
Reply With Quote
  #3  
Old 08-14-2012, 11:33 AM
todd92 todd92 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Feb 2009
Posts: 628
Mein Auto: 13 X3 3.5, 05 ZHP
Took it in for inop washer fluid. SA called to say both pumps bad and both springs broken. Didn't notice a thing while driving.
Reply With Quote
  #4  
Old 08-14-2012, 03:59 PM
PSUEng PSUEng is offline
Officially Welcomed to the 'Fest
Location: SE
 
Join Date: Oct 2010
Posts: 388
Mein Auto: 2007 X3
Hmmm. I have a 2007 with 65,000 miles--my CPO expires in March and the rear broken springs is something I MUSt check out. Washer pumps are no biggie. I changed the one on my M3--had to remove the entire bumper cover.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms