Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-21-2012, 02:49 PM
lpichardo70 lpichardo70 is offline
Registered User
Location: Manhattan, New York
 
Join Date: Feb 2011
Posts: 19
Mein Auto: 1998 BMW 528i
E39 528i 1998 Traction Control Light is On

I have a 1998 528i, which I currently replaced the master cylinder and the brake booster. After replacing these two parts the Traction control light has been on, constantly, indicating that the traction control is shutoff.

I have pressed the ASC button trying to see if it would make a difference, and nothing happens. At this point I can not get my traction control to work.

Any advice on what this may be?
Reply With Quote
Ads by Google
  #2  
Old 08-21-2012, 03:19 PM
acoste acoste is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Nov 2011
Posts: 464
Mein Auto: 1998 528i; 2010 550i
Did you disconnect connector to the throttle body? The very top connector. The ASC light will stay on if that is not connected.
Reply With Quote
  #3  
Old 08-21-2012, 03:46 PM
lpichardo70 lpichardo70 is offline
Registered User
Location: Manhattan, New York
 
Join Date: Feb 2011
Posts: 19
Mein Auto: 1998 BMW 528i
Quote:
Originally Posted by acoste View Post
Did you disconnect connector to the throttle body? The very top connector. The ASC light will stay on if that is not connected.
@ Acoste ---- No, I did not unplug the connector..... Is there anything that might cause this problem?
Reply With Quote
  #4  
Old 09-25-2012, 09:11 AM
pwrdave pwrdave is offline
Registered User
Location: Oregon
 
Join Date: Jan 2006
Posts: 9
Mein Auto: 98 528i
Have same conditions w/ my 98' 528i. Noticed a broken cable (see attached) but don't know if related?
Attached Thumbnails
Click image for larger version

Name:	029.jpg
Views:	273
Size:	130.3 KB
ID:	343248  
Reply With Quote
  #5  
Old 09-25-2012, 10:58 AM
acoste acoste is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Nov 2011
Posts: 464
Mein Auto: 1998 528i; 2010 550i
It is. The bowden cable going from the throttle actuator to the secondary throttle valve for ASC is broken so the computer has no control over it any more. (It can not reduce engine torque any more)
Reply With Quote
  #6  
Old 09-25-2012, 11:23 AM
bkgreene39's Avatar
bkgreene39 bkgreene39 is offline
Officially Welcomed to the 'Fest
Location: Brooklyn
 
Join Date: Aug 2011
Posts: 464
Mein Auto: 1998 BMW 528i
Very interesting so thats what moves and makes that mechanical noise when i insert my key into position 2.
Reply With Quote
  #7  
Old 09-25-2012, 11:39 AM
16valex's Avatar
16valex 16valex is offline
Officially Welcomed to the 'Fest
Location: Albany NY
 
Join Date: Jul 2004
Posts: 2,585
Mein Auto: 530I/5SC 97-528/5
Put the key in position 1 then say abdacadabra 5X turn the key off, the ASC light should go away.
If that didn't work then repeat the procedure but this time the key is at position 2.
Reply With Quote
  #8  
Old 11-05-2012, 08:23 PM
TouringinMIA TouringinMIA is offline
Registered User
Location: Miami
 
Join Date: Mar 2012
Posts: 3
Mein Auto: 528iT
Quote:
Originally Posted by lpichardo70 View Post
@ Acoste ---- No, I did not unplug the connector..... Is there anything that might cause this problem?
Did you find out what's causing the lights to be on? Indy replaced my master cylinder and now my traction, brake and abs lights are on.......
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms