Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-25-2012, 08:44 AM
LydoZ3 LydoZ3 is offline
Registered User
Location: poulton le fylde
 
Join Date: Aug 2012
Posts: 17
Mein Auto: United Kingdom
Problem with tick over z3 1.9 4cylinder

Hi, I've recently had the intake manifold off to fit a new coolant flange and crank case vent. I've put it all back together and it's running rich and struggles when I rev the engine. I thought it could be the icv so I've bought and fit a new one but is till running rich. Could it be the mixture or somethin with the choke. Any help would be grateful.

Last edited by LydoZ3; 08-25-2012 at 08:47 AM.
Reply With Quote
Advertisement
  #2  
Old 08-25-2012, 09:47 AM
wifesauto wifesauto is offline
Officially Welcomed to the 'Fest
Location: nj
 
Join Date: Jan 2012
Posts: 333
Mein Auto: sloporsche
imo go back over your work. you may have a vacuum leak
Reply With Quote
  #3  
Old 08-25-2012, 01:28 PM
LydoZ3 LydoZ3 is offline
Registered User
Location: poulton le fylde
 
Join Date: Aug 2012
Posts: 17
Mein Auto: United Kingdom
I'm gonna check over it tomorrow , I've been reluctant to because to check the intake manifold I Have to remove the fuel line. It's a pain in the ass! Still cheaper than takin it in to the garage
Reply With Quote
  #4  
Old 08-25-2012, 09:07 PM
IgotBMW's Avatar
IgotBMW IgotBMW is offline
BE IRIE
Location: So Cal
 
Join Date: Jul 2010
Posts: 771
Mein Auto: 1996 Z3 1.9L M44
+1 on possible vaccuum leak.
__________________

1996 Z3 (M44)
Reply With Quote
  #5  
Old 08-26-2012, 07:35 PM
KillerSE7EN KillerSE7EN is offline
BMW Fan Boy
Location: Blackwood, NJ
 
Join Date: Aug 2012
Posts: 16
Mein Auto: 96 z3/ 04 325i/ 11 x328i
Double check to make sure your fuel injectors are sitting in the manifold correctly. When I took mine off to clean the intake it idled really rough until I revved it up a few times. Did you change the lower manifold gasket and torque it to spec?
Reply With Quote
  #6  
Old 09-01-2012, 10:02 AM
LydoZ3 LydoZ3 is offline
Registered User
Location: poulton le fylde
 
Join Date: Aug 2012
Posts: 17
Mein Auto: United Kingdom
I've done all that and it's still running rich and becomes jittery every 60seconds for a few seconds. The spark plugs where black aswell so I've cleaned them up,
Reply With Quote
  #7  
Old 09-03-2012, 02:40 PM
KillerSE7EN KillerSE7EN is offline
BMW Fan Boy
Location: Blackwood, NJ
 
Join Date: Aug 2012
Posts: 16
Mein Auto: 96 z3/ 04 325i/ 11 x328i
Any cracks in the 4 hoses going to the injectors?
Reply With Quote
  #8  
Old 09-03-2012, 03:12 PM
LydoZ3 LydoZ3 is offline
Registered User
Location: poulton le fylde
 
Join Date: Aug 2012
Posts: 17
Mein Auto: United Kingdom
I don't think so, the only hoses are breathers from the injectors, there's only the fuel rail and that's steel I think. I've replaced the breather hoses from the injectors. Would that have anything to do with it, I couldn't see it myself but I'm lost for ideas
Reply With Quote
  #9  
Old 09-08-2012, 05:51 AM
KillerSE7EN KillerSE7EN is offline
BMW Fan Boy
Location: Blackwood, NJ
 
Join Date: Aug 2012
Posts: 16
Mein Auto: 96 z3/ 04 325i/ 11 x328i
Any way you can post a video?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms