Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-01-2012, 09:37 AM
aherman535 aherman535 is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Nov 2007
Posts: 200
Send a message via Skype™ to aherman535
Mein Auto: 2010 535xit
Hu_cic

Thanks to April1 and others, I am now coding my 2012 535i!!

Everything seems to be working fine. However, I can't get into the HU_CIC module. When I go to read coding data on the CAFD file, it reads OK, but gives me error message that it can't find the new file or it can't create it. All the other modules work OK, including KOMBI.

Any ideas? Bunch of stuff I would like to change in the HU_CIC module.

Thanks all,

Andrew
__________________
ED June 2012 535i MSport, Alpine with Cinnamon, almost all the boxes checked!!

Prior ED 2010 535xit Nepune Blue, everything but night vision -gone but not forgotten (miss the wagon)
Reply With Quote
Ads by Google
  #2  
Old 09-01-2012, 07:16 PM
aherman535 aherman535 is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Nov 2007
Posts: 200
Send a message via Skype™ to aherman535
Mein Auto: 2010 535xit
Oddball HU-CIC

After posting in the BMW Coding Forum I discovered that I have an oddball CAFD. In seems as a few builds in May 2012 got a HU_CIC ending in 157, which is no where in the software to be found.

I doubt that the dealer will re-program the car just for that. Would a cooperativedealer be able to read and code that CAFD?

I'll keep working on the other items.

Andrew
__________________
ED June 2012 535i MSport, Alpine with Cinnamon, almost all the boxes checked!!

Prior ED 2010 535xit Nepune Blue, everything but night vision -gone but not forgotten (miss the wagon)
Reply With Quote
  #3  
Old 09-01-2012, 09:00 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by aherman535 View Post
After posting in the BMW Coding Forum I discovered that I have an oddball CAFD. In seems as a few builds in May 2012 got a HU_CIC ending in 157, which is no where in the software to be found.

I doubt that the dealer will re-program the car just for that. Would a cooperativedealer be able to read and code that CAFD?

I'll keep working on the other items.

Andrew
As I tried to explain on the other forum, dealers do not Code, they Program, and when they do, they bring a car from one integration level to the next using ISTA/P. When they do this, ISTA/P initiates a Measures Plan, and determines which if any ECU's based on the car's current integration level needs their firmware updated to meet the new integration level. In this way, the Dealer can't select an individual ECU and target it for a firmware update just because they want to.

You somehow need to convince them to program the car, but you will never get there with them by discussing this oddball CAFD, which is a Process Class Designation of the Coding Application File (CAF). It won't mean anything to them. You are better off complaining that the car has some intermittent (not persistent) performance problem (e.g. occasionally shakes, etc.), which they will not be able to find a fault code for or reproduce, and that you want to make sure it has the latest software on it. Apart from that, you will have to find someone else besides the dealer that can either program the car or flash the individual CIC ECU. The latter can be done in E-Sys, but it isn't well understood or documented yet.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #4  
Old 09-02-2012, 05:54 PM
aherman535 aherman535 is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Nov 2007
Posts: 200
Send a message via Skype™ to aherman535
Mein Auto: 2010 535xit
Thanks Shawn, I've only had the car back from ED for a couple of weeks. May have to wait a while to come up with a reason for the dealer update.

I appreciate your efforts.

Andrew
__________________
ED June 2012 535i MSport, Alpine with Cinnamon, almost all the boxes checked!!

Prior ED 2010 535xit Nepune Blue, everything but night vision -gone but not forgotten (miss the wagon)
Reply With Quote
  #5  
Old 09-03-2012, 12:32 PM
Xav Xav is offline
Registered User
Location: California
 
Join Date: Mar 2012
Posts: 5
Mein Auto: 2012 535i
Quote:
Originally Posted by aherman535 View Post
Thanks to April1 and others, I am now coding my 2012 535i!!

Everything seems to be working fine. However, I can't get into the HU_CIC module. When I go to read coding data on the CAFD file, it reads OK, but gives me error message that it can't find the new file or it can't create it. All the other modules work OK, including KOMBI.

Any ideas? Bunch of stuff I would like to change in the HU_CIC module.

Thanks all,

Andrew
Just getting started as well and i got the same issue while doing the backup of the CAFD files.
Got the error on 2 files. (HU-CIC being one of them, i don't remember the other).
My car is a 2012 535i as well.
Any ideas ?
__________________
----------------------------------------------------
2012 535i Dark Graphite II, M Sport, Premium, HUD
2007 328i Jet black, Premium, Sport, Nav - Retired
2008 135i Convertible: Black - Retired
Reply With Quote
  #6  
Old 09-03-2012, 12:46 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Xav View Post
Just getting started as well and i got the same issue while doing the backup of the CAFD files.
Got the error on 2 files. (HU-CIC being one of them, i don't remember the other).
My car is a 2012 535i as well.
Any ideas ?
Which PSdZData are you working with, and what are the two exact CAFD errors?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #7  
Old 09-03-2012, 01:14 PM
Xav Xav is offline
Registered User
Location: California
 
Join Date: Mar 2012
Posts: 5
Mein Auto: 2012 535i
Quote:
Originally Posted by shawnsheridan View Post
Which PSdZData are you working with, and what are the two exact CAFD errors?
I believe i'm using 2.46.3

The 2 errors are below :

HU_CIC [63] [C816556]
readCPS o.k.
cafd_000000f9-007_002_157 Fehler:
File for "cafd_000000f9-007_002_157" not found! [C012]



JBBF [0] [C816556]
readCPS o.k.
cafd_00000014-004_045_031 Fehler:
File for "cafd_00000014-004_045_031" not found! [C012]


Does that help ?
__________________
----------------------------------------------------
2012 535i Dark Graphite II, M Sport, Premium, HUD
2007 328i Jet black, Premium, Sport, Nav - Retired
2008 135i Convertible: Black - Retired
Reply With Quote
  #8  
Old 09-03-2012, 01:58 PM
aherman535 aherman535 is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Nov 2007
Posts: 200
Send a message via Skype™ to aherman535
Mein Auto: 2010 535xit
That 157 CIC file is your problem. I have the same issue with a 5/12 build 535. See note above from ShawnSheridan. It appears that the software for the HU_CIC is an oddball install. Dealer or other will have to flash unit to update. Not sure that is going to happen.

Andrwe
__________________
ED June 2012 535i MSport, Alpine with Cinnamon, almost all the boxes checked!!

Prior ED 2010 535xit Nepune Blue, everything but night vision -gone but not forgotten (miss the wagon)
Reply With Quote
  #9  
Old 09-03-2012, 03:12 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Xav View Post
I believe i'm using 2.46.3

The 2 errors are below :

HU_CIC [63] [C816556]
readCPS o.k.
cafd_000000f9-007_002_157 Fehler:
File for "cafd_000000f9-007_002_157" not found! [C012]



JBBF [0] [C816556]
readCPS o.k.
cafd_00000014-004_045_031 Fehler:
File for "cafd_00000014-004_045_031" not found! [C012]


Does that help ?
Quote:
Originally Posted by aherman535 View Post
That 157 CIC file is your problem. I have the same issue with a 5/12 build 535. See note above from ShawnSheridan. It appears that the software for the HU_CIC is an oddball install. Dealer or other will have to flash unit to update. Not sure that is going to happen.

Andrwe
I just sent you a link for your Junction Box cafd_00000014.caf.004_045_031...although there isn't much to do in there. I'm not sure why you are missing it though, as it is not one of the missing 6 from 47.1.

As for cafd_000000f9-007_002_157, you are screwed. This is from one of my other posts, and what I was referencing in Post #6 above:

The big issue is cafd_000000f9.caf.007_002_157.

You will likely never find cafd_000000f9.caf.007_002_157, I don't think. It was not in 46.3, 46.6, 47.1, and still not in 47.4.

The story I hear is that this dates back to around March, where a handful of cars produced during a 1-2 day period of production got this CAFD, and it was a mistake that BMW caught quickly and fixed. The only solution is to have the car programmed with the latest ISTA/P or at least flash the firmware on the CIC to the newest.

Having the car programmed by the Dealer is a long shot, as unless you were coding, you would never even know you have cafd_000000f9.caf.007_002_157 to begin with, and no dealer will want to program the car just because you are stuck with an oddball CAFD that you can't code.

So, you are left with having an independent shop program the car, or wait until the dealer has some other legitimate reason to program the car, or flash the firmware on the CIC.

One option may be though is in E-Sys, if it lets you, is to delete and replace under HU_CIC in the SVT, cafd_000000f9.caf.007_002_157 with cafd_000000f9.caf.007_003_111, and then FDL Code HU_CIC. I have not tried this, but if I was personally stuck with cafd_000000f9.caf.007_002_157, this is what I would do, and if it did not work, I would flash the firmware on HU_CIC.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #10  
Old 09-03-2012, 08:25 PM
cn555ic cn555ic is offline
The Coder guy in N.Y
Location: New York, Brooklyn
 
Join Date: Mar 2012
Posts: 440
Mein Auto: bmw
Quote:
Originally Posted by shawnsheridan View Post
I just sent you a link for your Junction Box cafd_00000014.caf.004_045_031...although there isn't much to do in there. I'm not sure why you are missing it though, as it is not one of the missing 6 from 47.1.

As for cafd_000000f9-007_002_157, you are screwed. This is from one of my other posts, and what I was referencing in Post #6 above:

The big issue is cafd_000000f9.caf.007_002_157.

You will likely never find cafd_000000f9.caf.007_002_157, I don't think. It was not in 46.3, 46.6, 47.1, and still not in 47.4.

The story I hear is that this dates back to around March, where a handful of cars produced during a 1-2 day period of production got this CAFD, and it was a mistake that BMW caught quickly and fixed. The only solution is to have the car programmed with the latest ISTA/P or at least flash the firmware on the CIC to the newest.

Having the car programmed by the Dealer is a long shot, as unless you were coding, you would never even know you have cafd_000000f9.caf.007_002_157 to begin with, and no dealer will want to program the car just because you are stuck with an oddball CAFD that you can't code.

So, you are left with having an independent shop program the car, or wait until the dealer has some other legitimate reason to program the car, or flash the firmware on the CIC.

One option may be though is in E-Sys, if it lets you, is to delete and replace under HU_CIC in the SVT, cafd_000000f9.caf.007_002_157 with cafd_000000f9.caf.007_003_111, and then FDL Code HU_CIC. I have not tried this, but if I was personally stuck with cafd_000000f9.caf.007_002_157, this is what I would do, and if it did not work, I would flash the firmware on HU_CIC.
I hope someone with this weird CAFD file try what Shawn suggested...Hopefully it can work..
Reply With Quote
  #11  
Old 09-14-2012, 07:24 AM
332701 332701 is offline
Registered User
Location: Switzerland
 
Join Date: Sep 2012
Posts: 34
Mein Auto: 535xd
something similar here. I am using E-Sys 3.18.4 and my car just came back after upgrading to 47.x

HU_CIC (63)
readCPS o.k.
cafd_000000f9_007_003_067 Fehler:
File for "cafd_000000f9_007_003_067" not found! (C012)

any suggestions?
__________________
535xd with 20'' Wheel style 434 M in Sophistogrey II Brillant Metallic

Reply With Quote
  #12  
Old 09-14-2012, 08:26 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by 332701 View Post
something similar here. I am using E-Sys 3.18.4 and my car just came back after upgrading to 47.x

HU_CIC (63)
readCPS o.k.
cafd_000000f9_007_003_067 Fehler:
File for "cafd_000000f9_007_003_067" not found! (C012)

any suggestions?
If the Dealer just programmed your car, you need the latest 47.4 PSdZData. Check your PM.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #13  
Old 09-14-2012, 08:29 AM
332701 332701 is offline
Registered User
Location: Switzerland
 
Join Date: Sep 2012
Posts: 34
Mein Auto: 535xd
Thanks shawnsheridan, but I already use 47.4 (you sent me a pm just a week ago).
__________________
535xd with 20'' Wheel style 434 M in Sophistogrey II Brillant Metallic

Reply With Quote
  #14  
Old 09-14-2012, 08:38 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by 332701 View Post
Thanks shawnsheridan, but I already use 47.4 (you sent me a pm just a week ago).
Sorry. I send a lot of PM's...

cafd_000000f9_007_003_067 does not exist in any PSdZData that I have seen.

Please go into E-Sys, VCM, and read your I-Steps, and tell me what I-Step Current is?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips

Last edited by shawnsheridan; 09-14-2012 at 09:22 AM.
Reply With Quote
  #15  
Old 09-14-2012, 08:55 AM
332701 332701 is offline
Registered User
Location: Switzerland
 
Join Date: Sep 2012
Posts: 34
Mein Auto: 535xd
VCM is F010-12-07-533

does this screenshot also help?
Attached Thumbnails
Click image for larger version

Name:	Error.jpg
Views:	134
Size:	119.0 KB
ID:	341809  
__________________
535xd with 20'' Wheel style 434 M in Sophistogrey II Brillant Metallic

Reply With Quote
  #16  
Old 09-14-2012, 09:02 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Talking

Quote:
Originally Posted by 332701 View Post
VCM is F010-12-07-533

does this screenshot also help?
Yes. That is what I suspected.

Congratulations! F010-12-07-533 = ISTA/P 2.47.5.

Unfortunately, now you must wait until we get our hands on 47.5 PSdZData.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #17  
Old 09-14-2012, 09:06 AM
332701 332701 is offline
Registered User
Location: Switzerland
 
Join Date: Sep 2012
Posts: 34
Mein Auto: 535xd
good and bad at the same time

thank you anyway for your great help according to your knowledge you must be god
__________________
535xd with 20'' Wheel style 434 M in Sophistogrey II Brillant Metallic


Last edited by 332701; 09-14-2012 at 09:11 AM.
Reply With Quote
  #18  
Old 09-14-2012, 09:18 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by 332701 View Post
good and bad at the same time

thank you anyway for your great help according to your knowledge you must be god
Thanks, but more like Satan I think...
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #19  
Old 04-06-2013, 06:46 PM
Swack Swack is offline
Registered User
Location: Houston
 
Join Date: Feb 2013
Posts: 23
Mein Auto: 2012 528i
Bumping an old thread here. I've coded everything on my F10 except for the hu_cic module. Unfortunately, I have a May 2012 build F10 and am getting the "157 not found" error. I tried replacing the file as Shawn suggested, however this is not working. Any new updates regarding this matter?

I'm just looking to get rid of the nav warning message when starting the car..
Reply With Quote
  #20  
Old 04-06-2013, 06:49 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Swack View Post
Bumping an old thread here. I've coded everything on my F10 except for the hu_cic module. Unfortunately, I have a May 2012 build F10 and am getting the "157 not found" error. I tried replacing the file as Shawn suggested, however this is not working. Any new updates regarding this matter?

I'm just looking to get rid of the nav warning message when starting the car..
You have cafd_000000f9_007_003_067?

And what is "157 not found"? Normally it is a Missing CAFD [C012] error.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips

Last edited by shawnsheridan; 04-06-2013 at 06:59 PM.
Reply With Quote
  #21  
Old 04-06-2013, 07:14 PM
Swack Swack is offline
Registered User
Location: Houston
 
Join Date: Feb 2013
Posts: 23
Mein Auto: 2012 528i
It's this error:

HU_CIC [63] [C816556]
readCPS o.k.
cafd_000000f9-007_002_157 Fehler:
File for "cafd_000000f9-007_002_157" not found! [C012]
Reply With Quote
  #22  
Old 04-06-2013, 07:15 PM
Swack Swack is offline
Registered User
Location: Houston
 
Join Date: Feb 2013
Posts: 23
Mein Auto: 2012 528i
Quote:
Originally Posted by shawnsheridan View Post
You have cafd_000000f9_007_003_067?

And what is "157 not found"? Normally it is a Missing CAFD [C012] error.
Yup I have the 067 file
Reply With Quote
  #23  
Old 04-06-2013, 07:23 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,160
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Swack View Post
Yup I have the 067 file
Highlight the ECU, Select Detect CAF for SWE, and select the CAF from the latest I-Level shown, then Right Click on the ECU and Select Code.

Afterwards, you should be able to FDL Code the ECU as normal.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #24  
Old 04-09-2013, 07:51 PM
Swack Swack is offline
Registered User
Location: Houston
 
Join Date: Feb 2013
Posts: 23
Mein Auto: 2012 528i
Quote:
Originally Posted by shawnsheridan View Post
Highlight the ECU, Select Detect CAF for SWE, and select the CAF from the latest I-Level shown, then Right Click on the ECU and Select Code.

Afterwards, you should be able to FDL Code the ECU as normal.
Hey, finally have some time to sit down and do this. Forgive me for being obtuse but when you say "highlight the ECU" do you mean the hu_cic module? I don't see a "Detect CAF for SWE" option.
Reply With Quote
  #25  
Old 04-09-2013, 07:57 PM
Swack Swack is offline
Registered User
Location: Houston
 
Join Date: Feb 2013
Posts: 23
Mein Auto: 2012 528i
Wait, I think I got it..
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms