Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion of BMW's 4th generation E65/E66 7 Series flagship. The E65 generated much controversy, due to its radical styling and iDrive user difficulties. Nonetheless, the E65 broke records to become the best-selling 7-series iteration ever, especially after its 2005 facelift.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-02-2012, 11:25 AM
7Figurez's Avatar
7Figurez 7Figurez is offline
Officially Welcomed to the 'Fest
Location: Virginia
 
Join Date: Mar 2008
Posts: 267
Mein Auto: 2005 745I
Seat occupancy sensor disable Using NCS

If anyone is having the issue with the seat occupancy sensor, you can code this option out using NCS. Once you code the seat occupancy sensor out of the SSFA module you can clear the errors and the airbag light will remain off.

Change this in the SSFA or SSBF depending on the seat sensor that is failing:

FOR SSFA
From:

BELEGUNGSERKENNEUNG_FA
sbe1

TO:

BELEGUNGSERKENNEUNG_FA
keine_sbe


FOR SSBF
FROM:

BELEGUNGSERKENNEUNG_BF
oc3

To:

BELEGUNGSERKENNEUNG_BF
keine_sbe
__________________
Reply With Quote
Advertisement
  #2  
Old 09-02-2012, 01:42 PM
johndade johndade is online now
Officially Welcomed to the 'Fest
Location: chicago
 
Join Date: Nov 2006
Posts: 1,663
Mein Auto: 2002 bmw 745li
Is one driver side and one passanger? Will restraint system have any issues in an accident or any other problems? I have a light for driver side on.

Sent from my Motorola Electrify using Bimmer App
Reply With Quote
  #3  
Old 09-02-2012, 03:48 PM
MakaveliFaison's Avatar
MakaveliFaison MakaveliFaison is offline
Officially Welcomed to the 'Fest
Location: Tampa, fl
 
Join Date: Nov 2009
Posts: 1,838
Mein Auto: Bmw E64/5, Maserati GT
Nice job!
__________________

650i sport hud ac schnitzer eibach resognator delete m6 quads akebonos
Reply With Quote
  #4  
Old 09-02-2012, 03:57 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Great post!!! Move it to DIY section!
Reply With Quote
  #5  
Old 12-02-2012, 10:44 PM
mjquake mjquake is offline
Registered User
Location: Los Angeles
 
Join Date: Jan 2012
Posts: 14
Mein Auto: 02 745i
i don't see any of these lines in either the SSBF or SSBA modules, do i have to add those lines or what. having this problem and would like to code it off
__________________
Reply With Quote
  #6  
Old 12-03-2012, 06:07 PM
samadkins29's Avatar
samadkins29 samadkins29 is offline
Officially Welcomed to the 'Fest
Location: Bellevue, WA
 
Join Date: Apr 2010
Posts: 1,557
Mein Auto: '03 745Li
Will this work for a short? My rear seat headrest go up and down whenever they feel like it. Usually when its hot out.
__________________
Reply With Quote
  #7  
Old 01-18-2013, 03:26 PM
badziewo badziewo is offline
Registered User
Location: Toronto
 
Join Date: Jul 2012
Posts: 2
Mein Auto: BMW 750i
Angry

Hi
Would you please help me with the seat occupancy sensor?
I did use NCSXEPERT to upload the SSBF module file.
Then I modify the file FROM: BELEGUNGSERKENNEUNG_BF oc3 To: BELEGUNGSERKENNEUNG_BF keine_sbe, Load the file back to SSBF module.
After that the light for Passenger Airbag went off for 20 sec and then the light come back. So then I reset the SSBF module with INPA. Went back to NCSEXPERT upload the SSBF module again and notice that the file is back to original, the keine_sbe is missing and the OC3 is back. I did it 2 more times with the same effect.
Can somebody help me with this?
2006 BMW 750i

GURTSTRAFFER_BF
aktiv
ZK_MIN_GURTSTRAFFER_BF
wert_01
ZK_MAX_GURTSTRAFFER_BF
wert_01
HALLSCH_EIN_GURT_SSBF
hall_ein_gurt_an
STROMGR_KS_HSCH_ZU_SSBF
wert_01
INDEXTAB_FC_SSBF
wert_01
STROMGR_AUF_HSCH_UB_SSBF
wert_01
CHECKCTRLTAB_SSBF
wert_01
ZK_MIN_AKTIVEKOPFST_BF
wert_01
ZK_MAX_AKTIVEKOPFST_BF
wert_01
TIMEOUT_ID_UEBERW_SSBF
wert_01
VERZOEGERUNG_SBE_SSBF
wert_01
LINKS_LENKER
linkslenker
PDC3_ERR_LIMIT_SAT
wert_01
GURTSCHLOSS_BF
aktiv
ALGOPARAM_SSBF_EAM
wert_10
AKTIVE_KOPFSTUETZE_BF
aktiv
BELEGUNGSERKENNEUNG_BF
oc3

ZK1_ZF_SSBF
vom_ss_nicht_beeinflusst
ZK2_ZF_SSBF
vom_ss_beeinflusst

Last edited by badziewo; 01-18-2013 at 03:33 PM.
Reply With Quote
  #8  
Old 01-18-2013, 04:19 PM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,898
Mein Auto: 750I
Quote:
Originally Posted by badziewo View Post
Hi
Would you please help me with the seat occupancy sensor?
I did use NCSXEPERT to upload the SSBF module file.
Then I modify the file FROM: BELEGUNGSERKENNEUNG_BF oc3 To: BELEGUNGSERKENNEUNG_BF keine_sbe, Load the file back to SSBF module.
After that the light for Passenger Airbag went off for 20 sec and then the light come back. So then I reset the SSBF module with INPA. Went back to NCSEXPERT upload the SSBF module again and notice that the file is back to original, the keine_sbe is missing and the OC3 is back. I did it 2 more times with the same effect.
Can somebody help me with this?
2006 BMW 750i

GURTSTRAFFER_BF
aktiv
ZK_MIN_GURTSTRAFFER_BF
wert_01
ZK_MAX_GURTSTRAFFER_BF
wert_01
HALLSCH_EIN_GURT_SSBF
hall_ein_gurt_an
STROMGR_KS_HSCH_ZU_SSBF
wert_01
INDEXTAB_FC_SSBF
wert_01
STROMGR_AUF_HSCH_UB_SSBF
wert_01
CHECKCTRLTAB_SSBF
wert_01
ZK_MIN_AKTIVEKOPFST_BF
wert_01
ZK_MAX_AKTIVEKOPFST_BF
wert_01
TIMEOUT_ID_UEBERW_SSBF
wert_01
VERZOEGERUNG_SBE_SSBF
wert_01
LINKS_LENKER
linkslenker
PDC3_ERR_LIMIT_SAT
wert_01
GURTSCHLOSS_BF
aktiv
ALGOPARAM_SSBF_EAM
wert_10
AKTIVE_KOPFSTUETZE_BF
aktiv
BELEGUNGSERKENNEUNG_BF
oc3

ZK1_ZF_SSBF
vom_ss_nicht_beeinflusst
ZK2_ZF_SSBF
vom_ss_beeinflusst
Did you read the file again right after you wrote it to make sure it took the value?
__________________
Reply With Quote
  #9  
Old 01-18-2013, 08:45 PM
badziewo badziewo is offline
Registered User
Location: Toronto
 
Join Date: Jul 2012
Posts: 2
Mein Auto: BMW 750i
Yes I did read it and was not there. But something did go in because the passenger light was off for 20 sec before I cleared errors with INPA. What I'm doing wrong?
Reply With Quote
  #10  
Old 01-18-2013, 11:23 PM
DFEL750I's Avatar
DFEL750I DFEL750I is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,898
Mein Auto: 750I
Quote:
Originally Posted by badziewo View Post
Yes I did read it and was not there. But something did go in because the passenger light was off for 20 sec before I cleared errors with INPA. What I'm doing wrong?
What you are saying does not make much sense. Maybe then module is reset when you are reading it or something. If you are writing to the module successfully there is no way for it to revert these options. Where in Toronto are you? Probably I can help you out and code it for you.
__________________
Reply With Quote
  #11  
Old 01-18-2013, 11:34 PM
7Rage 7Rage is offline
Officially Welcomed to the 'Fest
Location: Long Beach, CA
 
Join Date: May 2012
Posts: 183
Mein Auto: 2007 750Li
Quote:
Originally Posted by samadkins29 View Post
My rear seat headrest go up and down whenever they feel like it.
WTF?!?!

Last edited by 7Rage; 01-18-2013 at 11:35 PM.
Reply With Quote
  #12  
Old 06-07-2013, 04:26 PM
utkg utkg is offline
Registered User
Location: toronto
 
Join Date: Jun 2013
Posts: 1
Mein Auto: 325i
Quote:
Originally Posted by DFEL750I View Post
What you are saying does not make much sense. Maybe then module is reset when you are reading it or something. If you are writing to the module successfully there is no way for it to revert these options. Where in Toronto are you? Probably I can help you out and code it for you.
DFEL750I

If you're in Toronto, you think I could get you to fix the srs light in my 325i (2006)? I'd pay you for your efforts. I'm in Vaughan. Let me know, thanks.
Reply With Quote
  #13  
Old 06-10-2013, 12:56 PM
magicautocenter magicautocenter is offline
Registered User
Location: texas
 
Join Date: May 2013
Posts: 10
Mein Auto: 2003 745il
is there a way to reset air bag light and seatbelt message on by 745li without having to buy models.... both front airbag are deployed and passanger side seatbealt is locked. the rest of the airbags are good.. thanks
Reply With Quote
  #14  
Old 07-11-2013, 08:52 PM
m3hk1 m3hk1 is offline
IbraCadabra
Location: Sweden
 
Join Date: Jul 2011
Posts: 32
Mein Auto: Bmw 735
Quick question guys. Has anybody that's done the procedure checked if their seats are constantly occupied or not. Wondering cause if not, there's a chance airbags won't deploy properly. Or I'm a wrong?
Had the same issue with mine backseats and chose to buy bypass plugin instead.
__________________
Reply With Quote
  #15  
Old 08-29-2013, 01:20 AM
moj0 moj0 is offline
Registered User
Location: Toronto
 
Join Date: Aug 2013
Posts: 1
Mein Auto: 530i
anyone in toronto that could code this out for me? i can pay of course for it!
Reply With Quote
  #16  
Old 03-06-2015, 10:06 AM
whytry's Avatar
whytry whytry is offline
Officially Welcomed to the 'Fest
Location: El Dorado Hills, CA
 
Join Date: Nov 2007
Posts: 328
Mein Auto: '07 750Li, 68 Camaro
Quote:
Originally Posted by 7Figurez View Post
If anyone is having the issue with the seat occupancy sensor, you can code this option out using NCS. Once you code the seat occupancy sensor out of the SSFA module you can clear the errors and the airbag light will remain off.

Change this in the SSFA or SSBF depending on the seat sensor that is failing:

FOR SSFA
From:

BELEGUNGSERKENNEUNG_FA
sbe1

TO:

BELEGUNGSERKENNEUNG_FA
keine_sbe


FOR SSBF
FROM:

BELEGUNGSERKENNEUNG_BF
oc3

To:

BELEGUNGSERKENNEUNG_BF
keine_sbe
I can't seem to find those in either SSFA or SSBF... Is there something I am doing wrong here? Please advise..
__________________
06 750i - Blk/Blk, Sport pkg, premium pkg, comfort access, ent pkg, convience pkg, 21's, sold
07 750LI - Blk/Blk, Sport, Premium, comfort access, rear DVD, convenience, 21's
68 Camaro - Procharged and injected LS2 in progress
Reply With Quote
  #17  
Old 03-07-2015, 06:02 AM
tmeis745 tmeis745 is offline
Registered User
Location: Toronto
 
Join Date: Jun 2011
Posts: 43
Mein Auto: 745
Please help me, I'm in toronto and both my passenger and driver restraint systems have restraint faults. Every time they are reset at Indy they come back several 100kms later.
__________________
Reply With Quote
  #18  
Old 04-03-2015, 12:29 PM
TerraPhantm TerraPhantm is offline
Officially Welcomed to the 'Fest
Location: State College, PA
 
Join Date: Nov 2004
Posts: 1,892
Mein Auto: 2005 M3 Coupe
Anyone know if this will cause issues with airbag deployment? I disabled the driver side sensor and as expected the code isn't coming back. Would hate for the airbags not to go off properly though
__________________
Reply With Quote
  #19  
Old 08-31-2015, 08:04 AM
crazyrobbery crazyrobbery is offline
Registered User
Location: boston
 
Join Date: Dec 2008
Posts: 61
Mein Auto: 95 e34 530/5
Quote:
Originally Posted by 7Figurez View Post
If anyone is having the issue with the seat occupancy sensor, you can code this option out using NCS. Once you code the seat occupancy sensor out of the SSFA module you can clear the errors and the airbag light will remain off.

Change this in the SSFA or SSBF depending on the seat sensor that is failing:

FOR SSFA
From:

BELEGUNGSERKENNEUNG_FA
sbe1

TO:

BELEGUNGSERKENNEUNG_FA
keine_sbe


FOR SSBF
FROM:

BELEGUNGSERKENNEUNG_BF
oc3

To:

BELEGUNGSERKENNEUNG_BF
keine_sbe


Worked like a charm... Thanks !
Reply With Quote
  #20  
Old 09-21-2015, 07:40 AM
Adam_E65 Adam_E65 is offline
Registered User
Location: Cullompton, UK
 
Join Date: Sep 2015
Posts: 8
Mein Auto: 2002 E65 735i
I had the restraint system fault on my 2002 E65 735i, and I bought a bypass sensor, as a lot of people seemed to think it was a quick,cheap fix. But it didn't work for me.

Mine seats have heating, ventilation, massage and lumbar support and after some diagnostics with INPA/DIS57, it appears that the passenger seat module is faulty.

The fault was...
"SMBF -9EC6 SMBF:Active Seat, pressure switch - no signal of value ---
-Active seat B5210_60034 / Supply 02 The power supply to the seat module is not OK."

All the seat functions worked OK - movement, heating, ventilation etc - but the message would not clear even after a complete reset.
With my MOT looming fast, I was desperate to get it sorted.
After a bit more searching, and advice on seat units from various forums, I bought a second hand seat module from Ebay for 60 with the part no. 61.35-6 920 451.9 01 (61356927319)
This unit seems to have all the options available on it, including adjustable head restraint functions that mine doesn't have.

My unit old module details as appears on the unit are:

61.35 - 6 924 875.9 01
0000 0056 A9. SerNo. 000017164
Hardware C 09
Diagnosis 1105
Codier - Ind 03
MCV 0.5.17
Aend. - Ind. 01
OSV 2.3.0
Datum 37/02
FSV 6.12.0

I replaced the unit by lifting the seat to it's highest position and tilted the seat right back (not the backrest, just the seat) as you need to get as much space under the seat as possible, then I disconnected the battery.
I unplugged all the connectors (about 8 or 9) and then unclipped the old unit. Its held in with two clips at the back left and right that are released by inserting a stubby flat-blade screwdriver in between the old unit and the casing, and pulling the screwdriver head back gently to the front of the car while lifting the edge of the old unit up. It should just lift up when released. Next slide the module rearwards by 5mm or so and the whole things just comes out.
The new one goes back in easier than getting the old one out. Plug everything back in and reconnect the battery.
There is no coding required but I had to go back into DIS57 to carry out a reset. (It didn't reset on it's own for me).
Now the message has gone and seatbelt/airbag lights have gone off.
MOT passed this morning with a couple of suspension bushes being replaced :-)

And a quick note for those people that bypass the seat occupancy sensor - it may be OK for the passengers side as all the airbags will go off in the event of an accident.
However, I believe the drivers side sensor is used for other things - like locking the gearbox into park when unoccupied to stop the car driving off if you happened to get out/fall out without putting it into park first. So just keep this in mind.

Thanks to all those people that have helped me (and countless others no doubt) by taking the time to share their experiences with others, we do appreciate it.
Reply With Quote
  #21  
Old 09-21-2015, 09:33 AM
dant9422 dant9422 is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jan 2015
Posts: 129
Mein Auto: 2006 Bmw 750i
I have a passenger side mat sensor with cushion and fan assembly for sale.
Reply With Quote
  #22  
Old 09-21-2015, 01:24 PM
H F H F is offline
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 3,869
Mein Auto: 2005 545i
Quote:
Originally Posted by Adam_E65 View Post
I had the restraint system fault on my 2002 E65 735i, and I bought a bypass sensor, as a lot of people seemed to think it was a quick,cheap fix. But it didn't work for me.

Mine seats have heating, ventilation, massage and lumbar support and after some diagnostics with INPA/DIS57, it appears that the passenger seat module is faulty.

The fault was...
"SMBF -9EC6 SMBF:Active Seat, pressure switch - no signal of value ---
-Active seat B5210_60034 / Supply 02 The power supply to the seat module is not OK."

All the seat functions worked OK - movement, heating, ventilation etc - but the message would not clear even after a complete reset.
With my MOT looming fast, I was desperate to get it sorted.
After a bit more searching, and advice on seat units from various forums, I bought a second hand seat module from Ebay for 60 with the part no. 61.35-6 920 451.9 01 (61356927319)
This unit seems to have all the options available on it, including adjustable head restraint functions that mine doesn't have.

My unit old module details as appears on the unit are:

61.35 - 6 924 875.9 01
0000 0056 A9. SerNo. 000017164
Hardware C 09
Diagnosis 1105
Codier - Ind 03
MCV 0.5.17
Aend. - Ind. 01
OSV 2.3.0
Datum 37/02
FSV 6.12.0

I replaced the unit by lifting the seat to it's highest position and tilted the seat right back (not the backrest, just the seat) as you need to get as much space under the seat as possible, then I disconnected the battery.
I unplugged all the connectors (about 8 or 9) and then unclipped the old unit. Its held in with two clips at the back left and right that are released by inserting a stubby flat-blade screwdriver in between the old unit and the casing, and pulling the screwdriver head back gently to the front of the car while lifting the edge of the old unit up. It should just lift up when released. Next slide the module rearwards by 5mm or so and the whole things just comes out.
The new one goes back in easier than getting the old one out. Plug everything back in and reconnect the battery.
There is no coding required but I had to go back into DIS57 to carry out a reset. (It didn't reset on it's own for me).
Now the message has gone and seatbelt/airbag lights have gone off.
MOT passed this morning with a couple of suspension bushes being replaced :-)

And a quick note for those people that bypass the seat occupancy sensor - it may be OK for the passengers side as all the airbags will go off in the event of an accident.
However, I believe the drivers side sensor is used for other things - like locking the gearbox into park when unoccupied to stop the car driving off if you happened to get out/fall out without putting it into park first. So just keep this in mind.

Thanks to all those people that have helped me (and countless others no doubt) by taking the time to share their experiences with others, we do appreciate it.
Nice job,, well done ..
__________________
Reply With Quote
  #23  
Old 05-26-2016, 03:27 PM
Gdoggt Gdoggt is offline
Registered User
Location: New Zealand
 
Join Date: May 2016
Posts: 5
Mein Auto: 2004 BMW 730i
Help Me Please - Seatbelt fault

Quote:
Originally Posted by 7Figurez View Post
If anyone is having the issue with the seat occupancy sensor, you can code this option out using NCS. Once you code the seat occupancy sensor out of the SSFA module you can clear the errors and the airbag light will remain off.

Change this in the SSFA or SSBF depending on the seat sensor that is failing:

FOR SSFA
From:

BELEGUNGSERKENNEUNG_FA
sbe1

TO:

BELEGUNGSERKENNEUNG_FA
keine_sbe


FOR SSBF
FROM:

BELEGUNGSERKENNEUNG_BF
oc3

To:

BELEGUNGSERKENNEUNG_BF
keine_sbe
Are you saying that doing this will cause the vehicle to not see the rear seat sensors as though the rear does not even exist to the vehicle or it will trick it to believe the seats are always occupied? I am having a constant fault saying the rear right and left seatbelts are stuffed as well as the drivers however there is nothing wrong with them. I just want the damn lights to go away. Can I simply tell all of the sensors to shut up somehow?
Reply With Quote
  #24  
Old 05-26-2016, 03:29 PM
Gdoggt Gdoggt is offline
Registered User
Location: New Zealand
 
Join Date: May 2016
Posts: 5
Mein Auto: 2004 BMW 730i
Quote:
Originally Posted by crazyrobbery View Post
Worked like a charm... Thanks !
What was your issue exactly and how did this fix it? I am wondering if I can address my seatbelt fault issue in the same manner.
Reply With Quote
  #25  
Old 05-26-2016, 05:27 PM
05_745li 05_745li is offline
Registered User
Location: Villa rica GA
 
Join Date: Jan 2016
Posts: 53
Mein Auto: 05 745li
Could you possibly tell me a step by step on how to do this. I'm new with ncs and I need this to go away
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms