Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-29-2013, 11:03 PM
cnotes628 cnotes628 is offline
Registered User
Location: brooklyn
 
Join Date: May 2013
Posts: 14
Mein Auto: x5 3.0
at my wits end

I have a x5 3.0 06, my check engine light came sand I ran the codes and was a air flow issue. Now the trans failure Prog is coming on. When I drive, I can feel a hard shift between gears and when I slow down to stop, there is a jerk like the truck is skipping gears to get back to first gear
Anyone knows if the two issues are connected
Reply With Quote
Advertisement
  #2  
Old 10-30-2013, 02:05 AM
white_lancer white_lancer is offline
Officially Welcomed to the 'Fest
Location: uk
 
Join Date: Aug 2012
Posts: 203
Mein Auto: E53 X5 2004 3.0 SPORT
Trans failsafe prog error is to do with the gearbox not air flow problems. I only had this error once and too the truck to an Indy. He told me that it was due to a speed differential picked up by the sensors in the gear box. He flushed and changed the oil in the transmission and replaced the filter - problem sorted.
__________________
E90 318i 2007 N46 2.0 Manual
E53 X5 2004 M54 3.0 Sport Auto
E83 X3 2004 M54 2.5 Auto

Last edited by white_lancer; 10-30-2013 at 02:07 AM.
Reply With Quote
  #3  
Old 10-30-2013, 05:56 AM
cnotes628 cnotes628 is offline
Registered User
Location: brooklyn
 
Join Date: May 2013
Posts: 14
Mein Auto: x5 3.0
Ok will try. Thanks
Reply With Quote
  #4  
Old 11-08-2013, 11:53 AM
cnotes628 cnotes628 is offline
Registered User
Location: brooklyn
 
Join Date: May 2013
Posts: 14
Mein Auto: x5 3.0
@white lancer
It was the air flow problem that was causing the trans failure program to kick in. I took it to my mechanic and he found a hole in air filter hose. As soon as he repaired that, the codes reset themselves. But thanks for the advice anyway.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms