Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-22-2012, 12:52 AM
luisp813 luisp813 is offline
Registered User
Location: FLorida
 
Join Date: Sep 2012
Posts: 5
Mein Auto: 04 BMW 545i
2004 BMW 545i dash light problem

i got a 2004 545i sport package 6 speed manual and i start driving and out of nowhere the traction control,ABS,Brake,DTc light turns on and sometimes the tv will go out.If i let go of the gas or step in the clutch it has like a hit/jerk to it its weird i just want to know if anyone knows the problem or came across something similar to this
Reply With Quote
Ads by Google
  #2  
Old 09-22-2012, 11:51 AM
luisp813 luisp813 is offline
Registered User
Location: FLorida
 
Join Date: Sep 2012
Posts: 5
Mein Auto: 04 BMW 545i
can anybody help me out with this?
Reply With Quote
  #3  
Old 09-22-2012, 12:14 PM
jim165 jim165 is online now
Officially Welcomed to the 'Fest
Location: Texas
 
Join Date: Oct 2006
Posts: 371
Mein Auto: 2008 BMW 550i Sport
Quote:
Originally Posted by luisp813 View Post
can anybody help me out with this?
Go to AutoZone and have your battery an alternator checked. Sounds battery-related
__________________
2008 550i Sport
Space Gray, Black Dakota, Bamboo Anthracite
SAT, Sat, Shades, Cold Wthr, Comf Access, Nav,L7, PDC, LUX V3 AEs, BMW Perf. Grilles, HID fogs, ACS Roof Spoiler, M5 Lip Spoiler, RPI GT Exhaust

Others:
2006 Corvette Conv, Z51,6sp (wife)
2007 Honda CBR1000RR
2005 Triumph Daytona 650 (wife)

Reply With Quote
  #4  
Old 09-22-2012, 02:10 PM
Kalil147 Kalil147 is offline
Officially Welcomed to the 'Fest
Location: Miami
 
Join Date: Aug 2011
Posts: 160
Mein Auto: BMW 545i
Ohhh buddy. Its the alternator. I had the exact same experience. I bought the alternator from ebay, its the same one as OEM. BMW uses a company called Valeo. Check your battery first, the alternator will act up after it heats up. So when you get it checked, they will most likely tell you it is ok.
Reply With Quote
  #5  
Old 09-22-2012, 05:06 PM
luisp813 luisp813 is offline
Registered User
Location: FLorida
 
Join Date: Sep 2012
Posts: 5
Mein Auto: 04 BMW 545i
i just put a brand new battery on it so it must be the alternator thanks everyone i appreciate it alot
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms