Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-06-2012, 07:51 PM
david brown david brown is offline
Registered User
Location: Greenville, SC
 
Join Date: Aug 2012
Posts: 4
Mein Auto: 08 335i conv & 07 X5
Unhappy Problem in Transmission

Guys, I have a 2008 335i convertible. 2 days ago my DSC LED along with "engine malfunction" LED and "problem with transmission" LED is on and my power is cut. I can only drive in what appears to be in a higher gear (its an automatic). From a stand still it pulls slowly until it gets up to speed and will not change gears. My question is, "am I looking at replacing a transmission?"
Help please and advise.

Last edited by david brown; 09-06-2012 at 08:13 PM.
Reply With Quote
Ads by Google
  #2  
Old 09-11-2012, 12:14 AM
Poist1386 Poist1386 is offline
Registered User
Location: Maryland
 
Join Date: Aug 2012
Posts: 1
Mein Auto: 2007 BMW 335I
I have a 2007 328xi that same thing happened to me last week and now getting it back tomorrow with a total rebuild. A few days after the light and power problems, I lost reverse. Hope it is not the same problem cause it is not cheap! $3600
Reply With Quote
  #3  
Old 09-11-2012, 07:12 AM
floydarogers's Avatar
floydarogers floydarogers is offline
Pedant and Curmudgeon
Location: Renton, WA
 
Join Date: Oct 2010
Posts: 3,529
Mein Auto: 335d
Quote:
Originally Posted by david brown View Post
Guys, I have a 2008 335i convertible. 2 days ago my DSC LED along with "engine malfunction" LED and "problem with transmission" LED is on and my power is cut. I can only drive in what appears to be in a higher gear (its an automatic). From a stand still it pulls slowly until it gets up to speed and will not change gears. My question is, "am I looking at replacing a transmission?"
Almost certainly yes.

BMW dealerships won't do anything but replace with re-manufactured, as they don't have any ability to repair them. BMW independents probably are in the same boat. There are a few shops that claim to be able to do it; however the cost will probably be about the same. Possibly you can find a 2nd-hand one from a wrecker, but it's still not going to be cheap as they're into making money, too.

There are only a couple problems (leaking mechatronic sleeve, etc) that can be fixed in the field on these. 1st step is getting the codes read.
Reply With Quote
  #4  
Old 09-11-2012, 02:04 PM
fun2drive's Avatar
fun2drive fun2drive is offline
BMWCCA 149159
Location: Panhandle of Florida
 
Join Date: Nov 2005
Posts: 2,599
Mein Auto: 335 vert//M3/4/ 13Outback
Agree get the codes read and see what that says. It would help to provide supporting background information like how many miles, how you drive it, etc. I know from being on boostedbimmers this transmission is very robust and has taken a lot more hp and torque than what it was designed for. Failure of this transmission is rare but failure of a sensor or low fluid level which can burn the transmission out isn't...
Reply With Quote
  #5  
Old 09-11-2012, 06:52 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by david brown View Post
Guys, I have a 2008 335i convertible. 2 days ago my DSC LED along with "engine malfunction" LED and "problem with transmission" LED is on and my power is cut. I can only drive in what appears to be in a higher gear (its an automatic). From a stand still it pulls slowly until it gets up to speed and will not change gears. My question is, "am I looking at replacing a transmission?"
Help please and advise.

Insist on knowing exactly what failed - post in this forum - you'll have the attention of many, many owners!

Often it's just a solenoid, an inexpensive part.
Reply With Quote
  #6  
Old 09-12-2012, 12:19 PM
david brown david brown is offline
Registered User
Location: Greenville, SC
 
Join Date: Aug 2012
Posts: 4
Mein Auto: 08 335i conv & 07 X5
Guys, I did get it repaired. They replaced the "Crank Sensor" and reset the computer adaptations at a cost of $600. I have 77K miles on this car and I don't drive it hard just around town and sometimes I take it out of town.
Reply With Quote
  #7  
Old 09-12-2012, 12:39 PM
TheGuest TheGuest is offline
Officially Welcomed to the 'Fest
Location: SF
 
Join Date: Apr 2007
Posts: 290
Mein Auto: 328i
that's why you don't buy 335 especially with auto tranny =)
Reply With Quote
  #8  
Old 09-12-2012, 01:05 PM
Zooks527's Avatar
Zooks527 Zooks527 is offline
Officially Welcomed to the 'Fest
Location: Mansfield, MA
 
Join Date: Mar 2009
Posts: 3,665
Mein Auto: 2009 335i xDrive coupe
Quote:
Originally Posted by david brown View Post
Guys, I did get it repaired. They replaced the "Crank Sensor" and reset the computer adaptations at a cost of $600. I have 77K miles on this car and I don't drive it hard just around town and sometimes I take it out of town.


Glad to see it was a repair and not a full replace!
__________________
2009 335i xDrive coupe, Jet Black, Black Leather, Grey Poplar, Steptronic, ZPP, ZSP, ZCW, iPod/USB, HD radio, Parking Assist. Rear Fogs, Hardwire V1, ProFit G3.
ED May 12, 2009, Munich dropoff May 16, Redelivery June 22, 2009




Prior 33 years of cars: 1967 BelAir wagon / 1968 LeMans Tempest / 1970 Mustang Mach 1 / 1972 El Dorado / 1978 Corvette (kept until first Bronco) / 1981 Subaru GL wagon AWD / 1983 s10 Blazer 4x4 (big mistake) / 1985 Bronco 4x4 / 1996 Bronco 4x4 / 2004 Passat 4motion
Reply With Quote
  #9  
Old 09-12-2012, 01:09 PM
David330gr David330gr is offline
Registered User
Location: ATHENS
 
Join Date: Sep 2012
Posts: 5
Mein Auto: e46 coupe 330xd
Quote:
Originally Posted by david brown View Post
Guys, I have a 2008 335i convertible. 2 days ago my DSC LED along with "engine malfunction" LED and "problem with transmission" LED is on and my power is cut. I can only drive in what appears to be in a higher gear (its an automatic). From a stand still it pulls slowly until it gets up to speed and will not change gears. My question is, "am I looking at replacing a transmission?"
Help please and advise.
Hello everybody .
I am a new member and it is the first Thread that took my attention.
My friend David, I had the same problem with my e46 xd with auto transmition.
My technician change the Transmition Filter and the Transmition Oil ATF and the problem has sold.The cost for changing was 200 euros and the gear box is like a brand new.
The main problem is the filter after 80 000 kilometers is a litle blocked and reduse the flow rate of ATF.
I hope to help you this information and i am sorry for my litle bad english.!!!

I wish you the best

David
Reply With Quote
  #10  
Old 09-12-2012, 01:17 PM
Zooks527's Avatar
Zooks527 Zooks527 is offline
Officially Welcomed to the 'Fest
Location: Mansfield, MA
 
Join Date: Mar 2009
Posts: 3,665
Mein Auto: 2009 335i xDrive coupe
Quote:
Originally Posted by David330gr View Post
I hope to help you this information and i am sorry for my litle bad english.!!!
Welcome to the 'Fest.

I guarantee that your ability to make yourself understood in English far exceeds most of our abilities to make ourselves understood in Greek!
__________________
2009 335i xDrive coupe, Jet Black, Black Leather, Grey Poplar, Steptronic, ZPP, ZSP, ZCW, iPod/USB, HD radio, Parking Assist. Rear Fogs, Hardwire V1, ProFit G3.
ED May 12, 2009, Munich dropoff May 16, Redelivery June 22, 2009




Prior 33 years of cars: 1967 BelAir wagon / 1968 LeMans Tempest / 1970 Mustang Mach 1 / 1972 El Dorado / 1978 Corvette (kept until first Bronco) / 1981 Subaru GL wagon AWD / 1983 s10 Blazer 4x4 (big mistake) / 1985 Bronco 4x4 / 1996 Bronco 4x4 / 2004 Passat 4motion
Reply With Quote
  #11  
Old 09-12-2012, 01:32 PM
David330gr David330gr is offline
Registered User
Location: ATHENS
 
Join Date: Sep 2012
Posts: 5
Mein Auto: e46 coupe 330xd
Quote:
Originally Posted by Zooks527 View Post
Welcome to the 'Fest.

I guarantee that your ability to make yourself understood in English far exceeds most of our abilities to make ourselves understood in Greek!
Neither Greeks understood Greek 100%..!!!
Reply With Quote
  #12  
Old 09-12-2012, 04:00 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by david brown View Post
Guys, I did get it repaired. They replaced the "Crank Sensor" and reset the computer adaptations at a cost of $600. I have 77K miles on this car and I don't drive it hard just around town and sometimes I take it out of town.

Not fer nothin' but here's the sensor, held in by one [1] torx bolt:




To knock, what, $500 off your bill, do this easy N54 crank sensor DIY replacement.
Reply With Quote
  #13  
Old 09-13-2012, 02:52 PM
david brown david brown is offline
Registered User
Location: Greenville, SC
 
Join Date: Aug 2012
Posts: 4
Mein Auto: 08 335i conv & 07 X5
Guys, thanks for all the valuble information.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms