Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-18-2012, 05:43 PM
marynesmith marynesmith is offline
Registered User
Location: ok
 
Join Date: Sep 2012
Posts: 2
Mein Auto: x5
Alternator issues

I have a 2004 bmw x5. I have ahd the alternator replaced twice since December 2011. Battery was replaced in December 2011. Alternator light is on yet again. Any suggestions???
Reply With Quote
Ads by Google
  #2  
Old 09-18-2012, 10:09 PM
ard ard is online now
Resident Curmudgeon
Location: CA
 
Join Date: Jul 2009
Posts: 8,693
Mein Auto: '12 X5 35d/E39M5/996TTX50
who is doing the work, WHY are they doing the things they are doing? What exactly has been done. Any diagnostic tests?
__________________
Keep it as simple as possible...but no simpler.
Reply With Quote
  #3  
Old 09-19-2012, 07:28 AM
UncleJ UncleJ is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: May 2006
Posts: 6,414
Mein Auto: '06 X3
Mary, you might want to repost this over on the 1999-2006 X5 board here in case someone there has experience with this situation in the earlier X5's. Of course Ard's questions are valid for any year and would help determine the problem/cause/possible solution. Just on your initial question it sounds like you need another opinion besides the service provider you are using now.
Reply With Quote
  #4  
Old 09-19-2012, 07:35 PM
marynesmith marynesmith is offline
Registered User
Location: ok
 
Join Date: Sep 2012
Posts: 2
Mein Auto: x5
First time, Service shop second time BMW dealership. dash board lit up like a christmas tree and then eventaully everything wen tdead. At first one of the battery cells was dead so I replaced battery and then "the alternator was not working." I replaced it. I was on the way to San Antonio when alternator light came on again. BMW eventually went completely dead so I was towed to the BMW dealership and they said it was a "faulty alternator" so it was replaced for free. Here we are six months later and the alternator light is on once again.
Reply With Quote
  #5  
Old 09-20-2012, 08:24 AM
UncleJ UncleJ is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: May 2006
Posts: 6,414
Mein Auto: '06 X3
Well for sure it needs to go back to the BMW shop that replaced the alternator -- those repairs/parts are, should be, warranted. It is not beyond the realm of possibility that it was a bad part after all. Good luck and let us know how it turns out.
Reply With Quote
  #6  
Old 11-25-2012, 08:48 PM
MrMatarazzo MrMatarazzo is offline
Registered User
Location: Austin, TX
 
Join Date: Nov 2012
Posts: 1
Mein Auto: 2004 330ci & X5 3.0i
Leaking steering fluid reservior?

Our 2004 X5 would intermitently turn on the battery light. Took it to 2 different shops (not the dealer) and both told me they couldn't find anything wrong with the alternator or battery. After about a year, the alternator died. When I went to replace it, I noticed it was covered with power steering fluid - from a loose seal on the reservior, located directly above the alternator.

I've notice most of the hoses on the X5 use a crimp-on style hose clamp - and they suck. Replaced the alternator and replaced the crimp-on hose clamps for the reservoir with the screw-on type and have not seen the battery light since.
Reply With Quote
  #7  
Old 10-08-2013, 06:56 AM
Dex5 Dex5 is offline
Registered User
Location: Atlanta
 
Join Date: Jun 2013
Posts: 11
Mein Auto: 2004 X5
MrMatarazzo - Thank you for your reply to this post. I have a leak from my pwr steering hose and believe that is what caused my alternator to go bad. I will have a mechanic check for that, as well.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms