Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-19-2012, 09:31 AM
gaupbn gaupbn is offline
Registered User
Location: DC
 
Join Date: Sep 2012
Posts: 5
Mein Auto: 525i
525i Trunk won't latch

I cannot close my 2007 525i trunk because it doesnt latch.

Let me explain the issue as it happened.

On Sept 17th

Opened the trun using the remote and then when i closed it it didnt latch. So tried one more time and it latched.

Drove home and this time i opened the trunk using the button inside the car. When i closed it it didnt latch first time so i tried again and it worked. Then when I locked the car using the remote and i noticed that the lights didnt flash and also didnt beep. So i knew something was wrong so i tried to open the trunk again using the remote and this time it never opened. So tried the opener switch inside the car but nothing was working.

So i used the keys to open the trunk and it opened but after that i cannot close it. Tried several times but never latches. Had to tie it down.

On Sept 18th

I bought a new TRUNK LID LOCK, WITH MICRO S:512031 (51-24-7-840-617) thinking that the locking system is broke. So I replaced the lock with a great effort but unfortunately it didnt solve the issue. It still dosen't latch with the new lock.

So i tried playing with the old lock and figured out that if i connect the power cable to the micro switch on the lock, the latching just doesnt work. If i remove the power connection and try manually it works. I tried this with both new and old lock and both behaves the same way.
No idea why connecting the power cable keeps the lock in the opening position. So now i kept the power cable disconnected so that i can atleast close the trunk and can open with my keys.

Anybody knows what could be the reason for this issue?? I'm suspecting the opener switch inside the car has gone bad and thats the reason when you connect the power the lock stays in the open position. Any help/tips appreciated.

Thanks in advance.
Reply With Quote
Ads by Google
  #2  
Old 09-20-2012, 07:32 AM
gaupbn gaupbn is offline
Registered User
Location: DC
 
Join Date: Sep 2012
Posts: 5
Mein Auto: 525i
Found the problem. Short circuit because of busted trunk lid wiring.
Reply With Quote
  #3  
Old 11-18-2012, 08:15 AM
JJH JJH is offline
Registered User
Location: Ridgefield, CT
 
Join Date: Oct 2011
Posts: 28
Mein Auto: 2006 525xi; 2012 X5 35i
I just got the EXACT same problem last night. 2006 525xi. Can you elaborate a little on two things?

1. How can I disconnect the power so that at least I can close the trunk? Can I simply remove a fuse or is there a wire somewhere I can disconnect? What's easiest?

2. Exactly where is the trunk lid wiring problem you found? Somewhere inside the trunk or in another location? Maybe at the switch in the dash?

Thanks!

John
__________________
2006 525xi; 2012 X5 3.5i
Reply With Quote
  #4  
Old 11-18-2012, 08:50 AM
JJH JJH is offline
Registered User
Location: Ridgefield, CT
 
Join Date: Oct 2011
Posts: 28
Mein Auto: 2006 525xi; 2012 X5 35i
UPDATE:

I was able to close the trunk by holding it down with one hand and playing with the release button (above the license plate where you would normally open the trunk by hand). When I pressed it a couple of times I could hear the mechanism doing something, then the trunk was closed (finally!). So I then used the key to lock it in the horizontal position. At least for now I can drive around without a rope tying the trunk down.

I looked at the fuse chart -- I don't see anything that indicates trunk latch or similar. I did learn that some fuses are under the trunk floor, some are inside the glove box.

I still don't know what I'm going to do long term.
__________________
2006 525xi; 2012 X5 3.5i
Reply With Quote
  #5  
Old 12-02-2012, 04:45 AM
JJH JJH is offline
Registered User
Location: Ridgefield, CT
 
Join Date: Oct 2011
Posts: 28
Mein Auto: 2006 525xi; 2012 X5 35i
ANOTHER UPDATE:

Got it fixed at my local trustworthy place. About $300, said I needed a new latch installed.
__________________
2006 525xi; 2012 X5 3.5i
Reply With Quote
  #6  
Old 12-02-2012, 08:41 AM
tgerm528i tgerm528i is offline
Registered User
Location: brooklyn ny
 
Join Date: Dec 2012
Posts: 4
Mein Auto: 528i 2008
ok thanks but was the mechanism completely not working? or did it make a noise when you touched it?
Reply With Quote
  #7  
Old 12-02-2012, 12:20 PM
JJH JJH is offline
Registered User
Location: Ridgefield, CT
 
Join Date: Oct 2011
Posts: 28
Mein Auto: 2006 525xi; 2012 X5 35i
It seemed as though it was completely not working, but as I mentioned I was able to keep the trunk closed by holding the trunk down and then pressing the mechanism above the license plate. I don't recall hearing any clicking noise or anything -- I'm not sure why that worked.

Other than that, I never could make the mechanism do ANYTHING by pressing that button above the plate OR the inside button OR the button on the key fob. NOTHING. But once I got it to stay closed, using the key manually allowed me to both completely lock by turning all the way to the left (horizontally) to assure that it wouldn't fly up while driving around, and to open the trunk.
__________________
2006 525xi; 2012 X5 3.5i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms