Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-25-2012, 08:39 PM
boxtree619 boxtree619 is offline
Registered User
Location: California
 
Join Date: May 2012
Posts: 8
Mein Auto: E66 745Li / MKIV Supra
a few possible electrical problems we have come across...

So about four months ago, I made an account on here and introduced myself when my father and I picked up his new-to-him E66 745li (it's basically brand new being that its a 2003 with ~30k miles when we picked it up). It has proven to be quite a nice vehicle for him and he has enjoyed every moment he's driven it. We've even taken it on a 1300mile road trip all around the state of Arizona and powertrain-wise, it has proven to be quite reliable and powerful.

However, there are a few possible ELECTRICAL problems we have come across these past few months.

A week after we purchased the vehicle, we noticed that the power window switch on the front passengers side does not lower the front passenger window. However, the front passenger window rolls down just fine when you use the drivers side window controls. But the trippy part is that the front passenger side window switch can raise the window up. In a nutshell, the front passenger side window switch does not lower the front pass side window, but only raises it and to lower it, the drivers side window switch must be used.

In addition to the aforementioned problem, our radio no longer works anymore. I can still navigate through the iDrive options, however the radio itself does not work anymore, even after clicking the little black radio knob down as if I was going to turn it on.

Any idea what could be the cause of this problem? Any help would be greatly appreciated.

Thanks

Oh..and here's a photo of the farthest point in our trip along with the map if any of you are interested. This was taken just 40 or so miles shy of the New Mexico border at the Petrified Forest National Park. I had to take this picture quick before the park ranger noticed I backed up off the road

Reply With Quote
Advertisement
  #2  
Old 09-26-2012, 01:18 PM
Mr.750 Mr.750 is offline
A BMW, 7 Series of course
Location: Mt. Auburn, IA
 
Join Date: Jul 2012
Posts: 501
Mein Auto: LS460
Front passenger window, I have no idea. But I am guessing that it would be easier just to ask the driver to mess with it than go to the stealership and pay them a horrendous amount to fix it. And with the radio check your tone and try adjusting that. Also try using different CD's and not just the radio. Not sure if it will help but good luck!
Reply With Quote
  #3  
Old 09-26-2012, 01:26 PM
csmeance's Avatar
csmeance csmeance is offline
Officially Welcomed to the 'Fest
Location: Daytona Beach
 
Join Date: Dec 2007
Posts: 4,284
Mein Auto: 760Li
The easiest solution to try is the MOST BUS reset procedure. It's posted here in detail on how to perform but essentially it'll reset all the modules and you'll start off from a clean slate!
Reply With Quote
  #4  
Old 09-26-2012, 01:40 PM
OrgBimmerDude OrgBimmerDude is offline
Registered User
Location: Chicago
 
Join Date: May 2011
Posts: 86
Mein Auto: BMW 745LI
Also, just a thought, it could be your ASK unit going bad or gone bad... Check that out as well... its not a serious issue, but annoying one for sure... GOOD LUCK
__________________
Reply With Quote
  #5  
Old 09-26-2012, 05:46 PM
Expo BMW's Avatar
Expo BMW Expo BMW is online now
Local Enthusiast
Location: City of L.A.
 
Join Date: May 2008
Posts: 1,216
Mein Auto: E65,P71 Police Intercept.
Check ebay for a passenger window switch replacement. For the radio issue refer to the two posts above mine.
__________________

. 360infiniteusa Angel Eyes . H&R Springs . mObridge AUX Integration .
Reply With Quote
  #6  
Old 09-30-2012, 12:26 AM
boxtree619 boxtree619 is offline
Registered User
Location: California
 
Join Date: May 2012
Posts: 8
Mein Auto: E66 745Li / MKIV Supra
ok just a lil update..

I looked up the MOST BUS reset procedure and did it just now and it did not work. When I drove it earlier today, I realized that not only is the radio not working (my stations don't show or anything..), but the navigation does not work as well.

I'll have to look into checking out the ASK unit next when I have the time.
Reply With Quote
  #7  
Old 09-30-2012, 04:43 AM
dannyb1027 dannyb1027 is offline
Officially Welcomed to the 'Fest
Location: new jersey
 
Join Date: Oct 2008
Posts: 137
Mein Auto: White 2002 745I
For the P/S window I say it's a switch because you know the motor and regulator is working fine. I've been having a few problems with my audio system and was able to reset it by disconnection the battery cables and connecting them together for 30 mins. I use long screwdriver to connect the two. it worked for me with positive results.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms