Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 09-21-2012, 05:27 PM
TheCritic's Avatar
TheCritic TheCritic is offline
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Sep 2008
Posts: 443
Mein Auto: 2007 BMW X3
Windshield washer quit working, any easy solutions?

One downside of going for non-BMW oil-change/inspection, they didn't fill the windshield washer fluid. Light came on, ignored it for a bit, guess I ran it completely dry.

Refilled it and am getting nothing, front or rear. Don't hear any noise from the motor either--but not positive I could hear it before.

Already checked the fuse(s!), they are all good.

Is there any way to prime it or something else I should check before I take it in for service?
__________________
2007 X3 3.0i, Monaco Blue with black leather. AT, Sport: 19" staggered replaced with longer lasting 18", Premium, NAV, Heated Seats.
Previous: 2002 Jeep Liberty Limited ; 1999 Mercury 'new' Cougar ; 1987 Mercury Merkur XR4ti
BMWCCA Member since 10/2008
Reply With Quote
Advertisement
  #2  
Old 09-21-2012, 06:12 PM
Pooch528i Pooch528i is offline
Registered User
Location: Columbus
 
Join Date: Jan 2007
Posts: 52
Mein Auto: 98 528i 06 X3 01 M Road
Do you hear the pump making noise? If not it's an easy fix to replace it.
Reply With Quote
  #3  
Old 09-22-2012, 11:46 AM
x3brian x3brian is offline
Officially Welcomed to the 'Fest
Location: Sacramento CA
 
Join Date: Jan 2011
Posts: 989
Mein Auto: X3
The pump replacement takes 5 minutes and is a common failure point (both of mine have been replaced).

I started buying the $4 Uro aftermarket one from ecstuning. They work great and for that price I can replace 10 times more before it would make sense to buy the oem one.
Reply With Quote
  #4  
Old 09-22-2012, 11:53 AM
usaret usaret is offline
Officially Welcomed to the 'Fest
Location: All Over
 
Join Date: Feb 2012
Posts: 918
Mein Auto: A Gamma Goat
Quote:
Originally Posted by TheCritic View Post
One downside of going for non-BMW oil-change/inspection, they didn't fill the windshield washer fluid. Light came on, ignored it for a bit, guess I ran it completely dry.

Refilled it and am getting nothing, front or rear. Don't hear any noise from the motor either--but not positive I could hear it before.

Already checked the fuse(s!), they are all good.

Is there any way to prime it or something else I should check before I take it in for service?
If it ran dry I would check to see if the impellers are stuck to the sides of the pump (if this is even possible). Possibly just a matter of breaking them free.
Reply With Quote
  #5  
Old 09-24-2012, 01:32 AM
-jay- -jay- is offline
Registered User
Location: San Diego, CA
 
Join Date: Oct 2011
Posts: 96
Mein Auto: 2006 X3 3.0i
Quote:
Originally Posted by x3brian View Post
The pump replacement takes 5 minutes and is a common failure point (both of mine have been replaced).

I started buying the $4 Uro aftermarket one from ecstuning. They work great and for that price I can replace 10 times more before it would make sense to buy the oem one.
both of mine are out right now and have been out for the last 6 months or so. lol
guess i've just been too lazy or cheap to buy the replacement pumps.

how long have you had those aftermarket ones? i want to replace them before snowboard season starts.
__________________
Reply With Quote
  #6  
Old 09-24-2012, 05:59 AM
vern vern is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Apr 2002
Posts: 4,739
Send a message via AIM to vern
Mein Auto: 01 330ci 05 530i 06 X3
Thumbs up

Quote:
Originally Posted by -jay- View Post
both of mine are out right now and have been out for the last 6 months or so. lol
guess i've just been too lazy or cheap to buy the replacement pumps.

how long have you had those aftermarket ones? i want to replace them before snowboard season starts.
This is a repeat!!!!!!!!! Do a search there is tons of GOOD information to help you. Good luck
cheers
vern
__________________
2012 335iA Blk. Sapphire- Sport-Blk. Dakota Leather/Red-Brushed Alum.Trim-DAP-PP-CWP Rear View Camera-BMW Asst w/Enhanced BT&USB-High Gloss Blk.Trim Hghight-PSP-Speed Limit Info-Tech. Pkg-PDC-Rear Manual Sun Shades-SAT-Variable Sport Steering-Wheel Locks- Rubber Mats-Euro Del 5/14/12-Redelivery 7/16/12 2006 X3 3.0iA 4/6 Silver Gray Metallic-Black Leather-Nav-PP-SP-Xenon Headlights-PDC-Heated Front Seats-Privacy Glass-Servotronic Steering-Premium Sound System-R R R- Wheel Locks- Rubber Mats
Reply With Quote
  #7  
Old 09-24-2012, 12:04 PM
legalfee's Avatar
legalfee legalfee is offline
Officially Welcomed to the 'Fest
Location: Lexington, SC
 
Join Date: Jul 2008
Posts: 384
Mein Auto: 2004 X3 2.5i 5AT
Got the pumps on Ebay for $7. I went ahead and bought 2 although only 1 was bad:

http://www.ebay.com/itm/230544938850...84.m1497.l2649
Reply With Quote
  #8  
Old 09-25-2012, 02:59 PM
O7X3 O7X3 is offline
Registered User
Location: Texas
 
Join Date: Sep 2012
Posts: 23
Mein Auto: 2007 X3
Question

Both of these pumps are identical correct?
And can anyone tell me which fuses to check, I also have an 07 and the fuse diagram card was gone when the mrs bought it. Thanks
Reply With Quote
  #9  
Old 09-25-2012, 03:25 PM
legalfee's Avatar
legalfee legalfee is offline
Officially Welcomed to the 'Fest
Location: Lexington, SC
 
Join Date: Jul 2008
Posts: 384
Mein Auto: 2004 X3 2.5i 5AT
Yes the 2 pumps are identical. I didn't change them out myself I had the car in the shop for an oil change anyhow and let them do it. It didn't look that hard though.
Reply With Quote
  #10  
Old 09-25-2012, 03:44 PM
O7X3 O7X3 is offline
Registered User
Location: Texas
 
Join Date: Sep 2012
Posts: 23
Mein Auto: 2007 X3
Exclamation

Thanks, they looked the same just was curious. Ive already had them and the resivoir out and they r easy to remove.

Anyone with a pic of the fuse diagram or know which fuse(s) to check please help.
__________________
2007 BMW X3
Reply With Quote
  #11  
Old 09-26-2012, 09:07 PM
Ishniknork's Avatar
Ishniknork Ishniknork is offline
I hate doing dishes
Location: Ft. Worth, TX
 
Join Date: Aug 2005
Posts: 2,915
Mein Auto: '05 X3 3.0i
Quote:
Originally Posted by legalfee View Post
Got the pumps on Ebay for $7. I went ahead and bought 2 although only 1 was bad:

http://www.ebay.com/itm/230544938850...84.m1497.l2649
Thanks for that link, I just ordered one myself.

That grommet doesn't have the strainer though so I picked one off Amazon.
__________________
'05 X3 3.0i Alpine White/Gray Leather/Alum. Trim
Sport/Steptronic/Servotronic/Panoramic
Premium Sound/Staggered Style 114 18"ers
Reply With Quote
  #12  
Old 09-27-2012, 05:14 AM
O7X3 O7X3 is offline
Registered User
Location: Texas
 
Join Date: Sep 2012
Posts: 23
Mein Auto: 2007 X3
Quote:
Originally Posted by Ishniknork View Post
Thanks for that link, I just ordered one myself.

That grommet doesn't have the strainer though so I picked one off Amazon.
Same here checked the fuses and they r all good. Ordering two pumps as we speak, thanks.
__________________
2007 BMW X3
Reply With Quote
  #13  
Old 10-09-2012, 07:08 AM
jvest2000 jvest2000 is offline
Registered User
Location: Salt Lake City
 
Join Date: Oct 2012
Posts: 32
Mein Auto: 2006 X3
Replacing Washer Fluid Pumps

Not sure if your pumps are bad or not, but on my wife's 2006 X3 as well as my aunt's 2008 X3 i've had to replace 2 of the pumps because they started leaking. One of them so badly that all the washer fluid was gone within a week. This seems like a pretty common occurrence in these cars so i put together a page of instructions on how to pull the washer tank and replace a pump(s):

How To Replace Washer Pumps on a BMW X3

I shudder to think what the dealer would charge to replace one of these, but doing it yourself you can get both parts for $30 - $50 and fix it in under 30 minutes. It's pretty easy since the washer tank is so accessible.
Reply With Quote
  #14  
Old 10-09-2012, 08:06 AM
vern vern is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Apr 2002
Posts: 4,739
Send a message via AIM to vern
Mein Auto: 01 330ci 05 530i 06 X3
Thumbs up

Quote:
Originally Posted by jvest2000 View Post
Not sure if your pumps are bad or not, but on my wife's 2006 X3 as well as my aunt's 2008 X3 i've had to replace 2 of the pumps because they started leaking. One of them so badly that all the washer fluid was gone within a week. This seems like a pretty common occurrence in these cars so i put together a page of instructions on how to pull the washer tank and replace a pump(s):

How To Replace Washer Pumps on a BMW X3

I shudder to think what the dealer would charge to replace one of these, but doing it yourself you can get both parts for $30 - $50 and fix it in under 30 minutes. It's pretty easy since the washer tank is so accessible.
I also ordered from Amazon $10.95 OEM pump with grommet shipping included. One thing you forgot to mention in your write up, The electric connection is either round or flat make sure you order the one that fits your terminal. One of the easy est fixes on the X3. Good luck
cheers
vern
__________________
2012 335iA Blk. Sapphire- Sport-Blk. Dakota Leather/Red-Brushed Alum.Trim-DAP-PP-CWP Rear View Camera-BMW Asst w/Enhanced BT&USB-High Gloss Blk.Trim Hghight-PSP-Speed Limit Info-Tech. Pkg-PDC-Rear Manual Sun Shades-SAT-Variable Sport Steering-Wheel Locks- Rubber Mats-Euro Del 5/14/12-Redelivery 7/16/12 2006 X3 3.0iA 4/6 Silver Gray Metallic-Black Leather-Nav-PP-SP-Xenon Headlights-PDC-Heated Front Seats-Privacy Glass-Servotronic Steering-Premium Sound System-R R R- Wheel Locks- Rubber Mats
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms