Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-27-2012, 03:34 PM
LuisMediano LuisMediano is offline
Registered User
Location: Hobbs, NM
 
Join Date: Sep 2012
Posts: 9
Mein Auto: 2000 BMW 528I
528i won't accelerate, please help!

I drive a 2000 528I my car works good but after i drive it for a while and turn it off and back on the power is gone, it wont accelerate, i press the whole gas and it takes a lot to gain speed, its really dangerous when im driving in the traffic cause the car just has no power to accelerate, but like i said that only happens after i drive it for a while and turn it off, it can be working perfectly but as soon as i turn it back on that happens, i changed the gas filter, and my MAF seems to work good? i hope somebody can help me, thank you!
Reply With Quote
Advertisement
  #2  
Old 09-27-2012, 04:35 PM
anton831 anton831 is offline
Registered User
Location: KY
 
Join Date: Mar 2012
Posts: 31
Mein Auto: 528i
do you have amy dash board lights on or cel
Reply With Quote
  #3  
Old 09-28-2012, 04:08 AM
Flybot's Avatar
Flybot Flybot is offline
Officially Welcomed to the 'Fest
Location: Louisville, Ky
 
Join Date: Aug 2009
Posts: 773
Mein Auto: '98 528
Possible failing fuel pump. Check for misfire and lean mixture codes
Reply With Quote
  #4  
Old 09-28-2012, 05:24 AM
ztom's Avatar
ztom ztom is offline
I gotta have more cowbell
Location: Thousand Oaks CA
 
Join Date: Sep 2007
Posts: 844
Mein Auto: 1997 528i
Cps sensor maybe
Reply With Quote
  #5  
Old 09-28-2012, 02:08 PM
LuisMediano LuisMediano is offline
Registered User
Location: Hobbs, NM
 
Join Date: Sep 2012
Posts: 9
Mein Auto: 2000 BMW 528I
i checked the light and it shows me other different problems but not this one, i guess its gonna be the fuel pump? :/ because sometimes it has problems when i turn it on it takes a while and thats when it doesnt work, usually it turns on right away when i open the key, thank you for all your answers i really appreciate it!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms