Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2004 - 2010)

E63 / E64 6 Series (2004 - 2010)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2017, 10:08 PM
Bukkie645 Bukkie645 is offline
Registered User
 
Join Date: Mar 2015
Posts: 6
Mein Auto:
Transmission Fault? Drive Moderately

Hey guys i got a Tranmission Fault Drive Moderately message 2 days ago..The message goes away when you turn off the car & when you turn it on ts not there ,once you start driving its cool for about 5-10 mins then you can feel it wanting to jump & then the message comes back again & my hears shift hard & take a while to go into next gear.What does this mean?has anyone gotten this message?please help..i have a 2005 645ci with 115k miles..
Reply With Quote
Advertisement
  #2  
Old 01-28-2017, 03:53 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 4,886
Mein Auto: 2005 645Ci & 2007 750Li
Most likely your Mechatronic's Adapter has hardened & cracked. When the adapter starts failing allowing fluid to bypass the intended path, the warning will notify you. You could also be low on fluid, but with that many miles it is a good bet the adapter has failed. The adapter is only around 15.00 or less, & starts to fail at some point after 80k miles. The valve body must be dropped to replace the adapter. You need to address this problem ASAP, to keep from damaging the tranny. Parts 1 & 2 should be changed at the same time, along with the fluid, pan, & filter.

http://bmwfans.info/parts-catalog/E6...ounting_parts/

Last edited by HerbP; 01-28-2017 at 03:55 PM.
Reply With Quote
  #3  
Old 04-06-2017, 09:42 AM
pitbull1969 pitbull1969 is offline
Registered User
Location: newington
 
Join Date: Sep 2010
Posts: 8
Mein Auto: 2006 530 xi
I was having the same symptoms on my 2006 BMW 530Xi until the message did not reset anymore by shutting the car off and on.
I read a lot of solutions on line but i did fixed with out expending any money or parts. And my car is running better than before it have way more power.
the only thing i did it was to plug my car to my laptop and open INPA. clear the errors then when to E60 /special/adaptation /all
turn off your car on again and my car really step up on acceleration,incredible but true.
I though i was gonna have to flush the oil ,change the pan cover etc,etc nope.That did it

good luck with yours

Last edited by pitbull1969; 04-06-2017 at 09:44 AM.
Reply With Quote
  #4  
Old 04-06-2017, 09:24 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 4,886
Mein Auto: 2005 645Ci & 2007 750Li
That will work for a while, but the problem will show up again.
Reply With Quote
  #5  
Old 04-07-2017, 03:41 AM
pitbull1969 pitbull1969 is offline
Registered User
Location: newington
 
Join Date: Sep 2010
Posts: 8
Mein Auto: 2006 530 xi
Did you fix the problem with the solution above?
I will order the mechatronic adapter in case the problem return.
Some people say is the TCM but i think your solution is solid
To fix the problem permanently
Thanks

Last edited by pitbull1969; 04-07-2017 at 03:46 AM.
Reply With Quote
Reply

See More Related BMW Stories

Tags
645ci transmission fault


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms