Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-19-2014, 06:44 PM
aioros aioros is offline
aioros
Location: Wildomar, CA
 
Join Date: Feb 2009
Posts: 623
Mein Auto: '99 528i auto , '01 330xi
evap purge valve, p0441 not fix

i replaced the evap purge valve a couple of days ago due to a constant p0441 code. unfortunately, the new valve did not care of the "incorrect purge flow"
anyone with what would the next thing to check or replace?

Sent from BimmerApp mobile app
Reply With Quote
Advertisement
  #2  
Old 10-19-2014, 06:57 PM
JDeGraff89's Avatar
JDeGraff89 JDeGraff89 is online now
Officially Welcomed to the 'Fest
Location: Omaha, NE
 
Join Date: Mar 2013
Posts: 2,182
Mein Auto: 04/1997 528i Auto,
Hmmm vaccum hose seems logical? If its a vaccum controlled valve?
__________________
Sorry for any odd punctuation or random double letters, My phones keyboard is going Kaput.
Reply With Quote
  #3  
Old 10-19-2014, 07:57 PM
aioros aioros is offline
aioros
Location: Wildomar, CA
 
Join Date: Feb 2009
Posts: 623
Mein Auto: '99 528i auto , '01 330xi
Quote:
Originally Posted by JDeGraff89 View Post
Hmmm vaccum hose seems logical? If its a vaccum controlled valve?
im not 100% sure how it really works...yet. gas fumes go to the charcoal canister then pump to the intake. the purge valve opens to let those fumes go to the intake manifold.

Sent from BimmerApp mobile app
Reply With Quote
  #4  
Old 10-19-2014, 08:31 PM
JDeGraff89's Avatar
JDeGraff89 JDeGraff89 is online now
Officially Welcomed to the 'Fest
Location: Omaha, NE
 
Join Date: Mar 2013
Posts: 2,182
Mein Auto: 04/1997 528i Auto,
I'm geussing then vaccum. But I am also not sure, someone who knows should stop in shortly.
__________________
Sorry for any odd punctuation or random double letters, My phones keyboard is going Kaput.
Reply With Quote
  #5  
Old 10-19-2014, 09:11 PM
cn90 cn90 is offline
Officially Welcomed to the 'Fest
Location: Omaha NE
 
Join Date: Mar 2006
Posts: 13,050
Mein Auto: 1998 528i 5-sp 140K+
Was the 1-way valve re-installed correctly?
Reply With Quote
  #6  
Old 10-20-2014, 05:52 PM
kenr88 kenr88 is offline
Registered User
Location: Turlock, CA
 
Join Date: Dec 2008
Posts: 34
Mein Auto: 2000 528i Sedan
aioros, you were part of my original thread on this. Although this valve fixed my incorrect purge flow problem (I guessed it was stuck in the open position) and a multiple misfire issue, had it not, I would have started with the electrical signal next. I had already inspected the vacuum lines and was pretty confident there was no vacuum leak.

I'm sure you must have already checked you gas cap as this is most common. I would first check the system at the driver-side rear wheel well for any broken vacuum lines or connectors. Then the passenger side rear wheel well for integrity in the fueling system. After that, I would then look that the valve is being receiving the right commands
__________________
2000 528i Sedan Automatic M52
Build Date 6/99
Turlock, CA
Reply With Quote
  #7  
Old 10-20-2014, 11:04 PM
aioros aioros is offline
aioros
Location: Wildomar, CA
 
Join Date: Feb 2009
Posts: 623
Mein Auto: '99 528i auto , '01 330xi
Quote:
Originally Posted by cn90 View Post
Was the 1-way valve re-installed correctly?
aaaah yes.

Sent from BimmerApp mobile app
Reply With Quote
  #8  
Old 10-20-2014, 11:05 PM
aioros aioros is offline
aioros
Location: Wildomar, CA
 
Join Date: Feb 2009
Posts: 623
Mein Auto: '99 528i auto , '01 330xi
Quote:
Originally Posted by kenr88 View Post
aioros, you were part of my original thread on this. Although this valve fixed my incorrect purge flow problem (I guessed it was stuck in the open position) and a multiple misfire issue, had it not, I would have started with the electrical signal next. I had already inspected the vacuum lines and was pretty confident there was no vacuum leak.

I'm sure you must have already checked you gas cap as this is most common. I would first check the system at the driver-side rear wheel well for any broken vacuum lines or connectors. Then the passenger side rear wheel well for integrity in the fueling system. After that, I would then look that the valve is being receiving the right commands
i will check all the hoses again

Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms