Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-19-2012, 01:21 PM
520itouring 520itouring is offline
Registered User
Location: London
 
Join Date: Oct 2012
Posts: 57
Mein Auto: 520i touring
Need to know if I can install aux input in my new e39

Hi fellas.

I'm new to e39s so please be patient with my lack of knowledge in them. I have owned a few e46s but by god are they completely different???!!!!!

Anyway I was looking into what tips and tricks I can do with the e39 and came across a few threads about installing an aux input to my stereo.

My car is a 520 touring 52 plate so it's post 2002/09. How do I check what system the car is running so I know if I can run an aux input? Is it written on the mid label\sticker or on the sticker of the business cd unit. I don't have DSP and the display is completely ffffffd and not going to attempt a repair on it having read what people have done to them!!!!!

Also there's some wires where the cd changer was I think the prec owner took it out. The cd player plays mp3 disks if it helps.

Just read a thread about how to remove the mid so will be doing that tomorrow morning.

Also finally the reception is sooooo crappy on the radio I'm sure something is unplugged can someone point me in the direction of where the module is
Reply With Quote
Ads by Google
  #2  
Old 10-19-2012, 05:03 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 9,091
Mein Auto: '97 540i 6 speed
Might try reviewing the Stickies at the top of the page. Also, do a search on this forum. Lots has been posted on this subject.

The antenna amp is behind the left side C-pillar cover. However, the E39, and its diversity antenna, is not known for stellar reception.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.

Last edited by edjack; 10-19-2012 at 05:05 PM.
Reply With Quote
  #3  
Old 10-20-2012, 08:06 AM
rdl rdl is online now
Officially Welcomed to the 'Fest
Location: Ontario, Canada
 
Join Date: Jun 2010
Posts: 1,052
Mein Auto: 530i 2003
Edjack's advice is on the mark. There are many threads listing sound system variants over the years with DIYs for auxillary inputs.

Regards poor radio reception, I recall seeing a thread somewhere describing a problem with the antenna cable plug into the dash unit. I have a feeling that this thread may be in one of the less popular forums and I've seen the problem mentioned only once.

The issue described was a poor contact by the center post of the antenna cable into the dash unit. The split pin wasn't spread enough to make a good electrical connection. The solution was to use a thin screwdriver or knife blade to spread the sections apart slightly and thus make firm contact with the mating socket in the dash unit.
__________________
Regards
RDL
Reply With Quote
  #4  
Old 10-20-2012, 09:14 AM
DennisCooper!'s Avatar
DennisCooper! DennisCooper! is offline
Officially Welcomed to the 'Fest
Location: West London / Heathrow UK
 
Join Date: Jan 2011
Posts: 1,651
Mein Auto: 03 Ex Cop 530d Touring
Hi

Please do take a look over on bmw5.co.uk which is UK centric and will have links on all of the above that you mention. The above advice is also good as each aspect has been mentioned and discussed hundreds if not thousands of times previously across all the BMW forums.

As you are UK based, you'll know that holding a mobile phone is illegal, so do you perhaps have a car kit installed? some of those have an Aux in already. Are you looking to put your iPod through the Aux in? if so, you'll get the sound, but if you pick up your iPod to change tracks and a Police officer sees you, you'll most likely get the points and fine. Even though an iPod is not a mobile phone, you still need to look away from the road to operate it and I'd suspect you'd be charged for the offence regardless if it's a phone or not.

If you MID pixels are missing, there are places to have the unit fixed and reconditioned. The 'ribbon' is often a cause and that is available, and also other parts which can be changed in order to fix. Also, you can get complete new MID modules as well.

The AM/FM signal amplifier is behind the rear left C pillar (or is it D pillar in our Tourings?!) and it does need a 12V feed in order to 'switch it on'. That is often a wire in the dash area loom which connects to the back of the MID or Radio/Cassette via the harness adaptor. If you have a 'break' in that wire, then the signal amplifier of course won't switch on, and yes, they're not so great in terms of radio reception either. I'm soon going to find myself a small bee sting type DAB+, DVB-T and GPS all in one type antenna - as FM/AM in a few years will be switched off.

Cheers, Dennis!
Reply With Quote
  #5  
Old 10-21-2012, 02:49 AM
520itouring 520itouring is offline
Registered User
Location: London
 
Join Date: Oct 2012
Posts: 57
Mein Auto: 520i touring
Hi guys thanks for the info. I found the antenna and sure enough one if the wires was loose!! Sounds much better now.

I pulled out the CD player it's a may 02 one but software 42! Even though my car was registered jan 03!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms