Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-05-2012, 10:10 PM
Robert Morris Robert Morris is offline
Registered User
Location: Waco Tx
 
Join Date: Oct 2012
Posts: 2
Mein Auto: 1993 525i
1993 525i won't ccrank

just changed starter. no clicking or dimming of lights now. no anything when turning key. Aaaaaargh.
Reply With Quote
Ads by Google
  #2  
Old 10-06-2012, 12:10 AM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
What happened before that? Why did you change the starter ? You probably messed something up during installation (happens all the time). Which means that its fixable. Go through exactly what you did in your mind. Its best to stand in front of the car while you do this. Be slow and methodical, and be zen about it. Don't worry....its probably something really minor that you'll laugh about when you discover.

Basically, make sure everything electrical is connected, your gear shift is in park, and all of your fuses are working. Make sure your fusible link is properly connected. Check your battery connections - you probably unhooked them for the installation. Then check if all your relays are working. Then download the bentley manual and check the starter troubleshooting list.

Its best to get a good nights sleep before you start looking at this again.
Reply With Quote
  #3  
Old 10-06-2012, 10:17 AM
My525iT My525iT is offline
Officially Welcomed to the 'Fest
Location: Florida
 
Join Date: Aug 2011
Posts: 127
Mein Auto: 92 525iT Wagon M50
Quote:
Originally Posted by robertobaggio20 View Post
Check your battery connections
Sometimes might still be loose.
Reply With Quote
  #4  
Old 10-06-2012, 07:23 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 1,908
Mein Auto: E23;E30;E38;E32;E34 +
or not as clean as you thought. Did you accidently connect the small wire to the 'cold start' terminal of the solonoid? Been there - done that.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E30 318i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #5  
Old 10-13-2012, 11:06 PM
paperplane94 paperplane94 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jan 2012
Posts: 927
Mein Auto: 1989 525i M20B25
Yup, check connections.
Reply With Quote
  #6  
Old 10-14-2012, 09:37 PM
luckydog's Avatar
luckydog luckydog is offline
Lucky to drive a BMW
Location: Ca
 
Join Date: Nov 2010
Posts: 1,356
Mein Auto: 2006 M5///
I would check fuses and starter connections.
Reply With Quote
  #7  
Old 10-14-2012, 09:44 PM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
I would update this thread !
Reply With Quote
  #8  
Old 10-14-2012, 10:34 PM
paperplane94 paperplane94 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jan 2012
Posts: 927
Mein Auto: 1989 525i M20B25
Quote:
Originally Posted by robertobaggio20 View Post
i would update this thread !
+1
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms