Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-08-2012, 08:54 PM
my2convertibles my2convertibles is offline
Registered User
Location: palms area
 
Join Date: Aug 2012
Posts: 8
Mein Auto: m3 , 325ci , X5
2003 X5 battery drain

after several weeks of trying to solve the problem about my battery draining just after two days of non use, i still cannot find what causing my battery to drain if i dont use my x5 within two days. After reading here the same issue by most x5 users, I had the FSU replaced, i did not use my x5 for this weekend, I tried to start it, it started but just after a few seconds, lights on the dash start flickering and slowly my engine died. I tried starting it back again but not even a clicking sound, i jump started it and luckily it run and never died down again. Wondering now if there's just another problem causing my battery to drain or the FSU was defective. By the way, when my mechanic put the replacement part, he told me to start and keep the engine running, when i finally turn it off, he tried to put it back but the new FSU is just way too hot, is this normal or he has to put it back before starting the engine? Im afraid now that if it gets too hot inside, it might cause fire or something. Please help!!!!
Reply With Quote
Advertisement
  #2  
Old 10-09-2012, 07:04 AM
Zulu95's Avatar
Zulu95 Zulu95 is online now
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 847
Mein Auto: 2001 X5 3.0L
Any non-OEM electrical equipment? I have read of people using Ipod docks or phone chargers, who leave them on, having all sorts of discharge problems. The item may not consume a lot of power but if it is more than around 38mA then the modules in the X5 never enter sleep mode and pull the battery down in a hurry.
If you have a look at the "FSU" you'll see it is pretty much all heatsink. (The prongs.) Given the amount of surface area they present I would expect it to get on the hot side at times.
I take it you have already had the battery/charging circuit checked?
GL.
Reply With Quote
  #3  
Old 10-09-2012, 08:59 AM
my2convertibles my2convertibles is offline
Registered User
Location: palms area
 
Join Date: Aug 2012
Posts: 8
Mein Auto: m3 , 325ci , X5
battery drain on my x5

Hi Zulu 95, i really appreciate the input, i tried checking the battery circuits and like i mentioned, i changed the battery and alternator and recently the FSU. Now that you mentioned it, there was a line for ipod etc. that has been laying beside my shifter , i'm going to mention that to my mechanic, maybe I should just have it taken out completely just for the sake for eliminating one probable problem. I will keep you posted and again, thank you for your help.
Reply With Quote
  #4  
Old 10-09-2012, 10:37 AM
my2convertibles my2convertibles is offline
Registered User
Location: palms area
 
Join Date: Aug 2012
Posts: 8
Mein Auto: m3 , 325ci , X5
Hi again Zulu 95. I forgot to mention, i took out the temperature control unit last night after parking the car. As usual , the small fan keeps on spinning after i turned the engine off. I did this because my mechanic said that this is the one that is draining my battery. One thing though is the blower ( I think is the heater) keeps on running although the whole unit is already out, is this normal? I can feel too that there is too much heat under the steering column whenever i drive the car without the temperature control engaged.

Thought this might give you another idea. thanks again.

rudy
Reply With Quote
  #5  
Old 10-10-2012, 07:19 AM
Zulu95's Avatar
Zulu95 Zulu95 is online now
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 847
Mein Auto: 2001 X5 3.0L
If the blower keeps on running then you need to check the FSU. When you replaced it did you use an after-market ebay special or the OEM part? The "cheapo" just like OEM FSU replacements you get usually fail very quickly. If I remember correctly on xoutpost one owner did the job himself and it failed right away or within a few hours.
What small fan? there are small fans behind the mini grills on the HVAC head unit to feed the cabin temperature sensors for each side. Do you mean these? They should be off when the vehicle is off.
The ipod cable should be treated as suspect if it has some sort of charging circuit.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms