Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Thread Tools Display Modes
Old 01-18-2011, 07:28 AM
skpatter skpatter is offline
Registered User
Location: alabama
Join Date: Jan 2011
Posts: 8
Mein Auto: 330i
Has this ever happend to your car???

2006 330I 88K. iI noticed a coolant leak under my expantion tank. I assumed it was cracked so I replaced. A couple days later more coolant uner tank. Low coolant light would not go off because Thermostat failed in closed position. I could not get radiator to fill. I ran the bleed process 5 times 12 min each. I replaced thermostat and was able to fill radiator with coolant and distilled water. Ran great for a couple of days. Cold morning Sunday and I went outside to warm up car let idle for 10 min. no heat. I proceeded down street to warm engine and yellow engine temp light flashed. Returned home checked coolant and had coolant under expantion tank again. Thermostat failed to open again and engine overheated blowing coolant out bypass in expantion tank. I cycled the key switch cranked engine and noticed the thermostat opened and was operating fine. Filled with coolant. Let sit overnight . Cranked this am, let warm about 15 min. No heat. Cycled key switch and recranked thermostat opened and operated fine. Drove car 70 miles operated fine no coolant leaks.
My question is What sensor operates the thermostat? I am pretty sure that is my problem. Anyone have any similar issues?
Reply With Quote
Old 01-18-2011, 08:40 AM
hpowders hpowders is offline
Ahh!! Florida Weather!!
Location: Tampa
Join Date: Jun 2005
Posts: 13,500
Mein Auto: BMW's: E90 and F22
2015 Alpine White 228i Coupe ("El Chapo") with Sport Line, Premium Package, Black Dakota Leather, FineLine Stream Wood Trim, Lighting Package, Driver Assistance Package and Track Handling Package and those wonderful non-runflat Michelin Pilot Super Sport Summer Tires.
Reply With Quote
Old 10-11-2012, 12:26 PM
Registered User
Location: Virginia Beach
Join Date: Oct 2012
Posts: 7
Mein Auto: 2006 330I, 2007 530I
im having the same issue with my 330I, what was the outcome of your situation?
Reply With Quote

See More Related BMW Stories

Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -7. The time now is 05:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms