Rear Defroster not working - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-12-2012, 09:04 AM
JCBAGNELL JCBAGNELL is offline
Registered User
Location: Massachusetts USA
 
Join Date: Oct 2012
Posts: 5
Mein Auto: 1998 528i
Question Rear Defroster not working

Hi all,
I am a new owner of a 98 528i which I LOVE, the only problem with the car is that the rear defroster only works on 2 pairs of lines from the driver side to the center of the window, and when I activate the defroster the FM radio goes to static. I had a friend who's a mechanic check and he said that there is power going to the defroster. There doesn't appear to be any breaks in the defroster lines and i don't want to replace the window if I don't have to. I'm hoping someone can help, and keep in my I'm definitely NOT a mechanic!
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.