Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-08-2012, 04:25 AM
veez87 veez87 is offline
Registered User
Location: south africa
 
Join Date: Oct 2012
Posts: 2
Mein Auto: e30 bmw 325i
misfire

hi, i seem 2 be having a problem with my 89' e30 bmw 325i, the car is only firing on 3 cylinders(2, 4 & 6), while the other 3(1, 3 & 5) aren't firing. car has constant spark, i even put in a new coil, then i thought it was the cylinder head, so i took out the head, had it completely overhauled, after re-assembling it, the car is exactly the same, i then took of the intake manifold, thinking maybe the injectors were blocked, which they all spray fine when i put directed power on them, lastly i thought maybe its my comp box, i replaced that n still the problem exists. i really don't know what else could be the problem, i would really appreciate it if i could get some help with this problem
Reply With Quote
Advertisement
  #2  
Old 10-08-2012, 06:42 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,713
Mein Auto: E23;E30;E38;E32;E34 +
Odd that it is 1-3-5. My guess is electrical only. Anything else would affect all cylinders. I would also guess not CPS or ICV. Other than that I shall just wait till someone else comes up with the fix and learn something.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #3  
Old 10-08-2012, 07:45 PM
E30 hobby car E30 hobby car is offline
Officially Welcomed to the 'Fest
Location: canada
 
Join Date: Dec 2009
Posts: 423
Mein Auto: 1986 325e 4 door auto
I had this same problem however, it seems that i only had 2 of them firing.

so, I replaced my spark plugs and no fix. Then i replaced my distributor cap and rotor and no fix. then ignition wires and no fix.

then i removed my injectors and bench tested them, They seemed fine however, I took them into a shop and had them sonicly cleaned. Put them back in and it fixed the problem.

I also replaced a bunch of fuel line during that time.


Car is running great now
Reply With Quote
  #4  
Old 10-08-2012, 07:49 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 7,293
Mein Auto: 2012 hypermotard 796
so based off this firing order 1-5-3-6-2-4, either you dizzy cap is completely f'd to the a, the injector wires are at some area are pinched/broken, the spark plug wires are bad.

its all gunna come to something electrical thats gunna be a pain to find, unless the dizzy cap just has some major gapeage at the terminals.
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
  #5  
Old 10-08-2012, 08:13 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,713
Mein Auto: E23;E30;E38;E32;E34 +
I guess I was thinking too complex. +1 on bench clean/test on injectors.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #6  
Old 10-09-2012, 08:41 AM
BrittnyMarie BrittnyMarie is offline
Brittny
Location: York
 
Join Date: Aug 2011
Posts: 79
Mein Auto: E30 325es E34 530i
if you still have constant spark, it's not anything from the ignition coil to the distributor. the distributor and rotor are fine. Since you are getting constant spark, your wires and everything else electrical is fine there is no need to replace any of those parts. The problem is all mechanical. Since your BMW has a distributor system, there is a thing called dwell which has to do with the timing that your engine fires at. If the dwell is too short, you will have misfires or no fire at all. There is a tool you can get that measures dwell and you can time your car so that all cylinders will fire and fire correctly. There is a "cheaper" way to do it. and you can turn your car on and turn the distributor left, till the car runs really crappy, then turn it right till it runs really crappy and find the middle "crappy" point. If that doesn't work, then get the dwell tool or just take it to your nearest shop and tell them you need your dwell fixed.
__________________
"You gotta have a passion. If you wake up every morning doing what you love, you'll never work a day in your life."
Reply With Quote
  #7  
Old 10-09-2012, 09:30 AM
E30 hobby car E30 hobby car is offline
Officially Welcomed to the 'Fest
Location: canada
 
Join Date: Dec 2009
Posts: 423
Mein Auto: 1986 325e 4 door auto
while Brittney is correct about dwell, in this case thats not the issue. Also, the distributor can not be adjusted in that manner on this car. at least not from my experience.

From what i saw, it appeared that i only had 2 cylinders firing, however, they all had some sort of fire otherwise the car would not run. The car shook terribly but it did run. Once i bench tested and cleaned my injectors, they all sprayed fine, but i still took them in to get professionally cleaned, new caps, and new o rings.

Since they have beeen back in, it runs so much smoother.

Has this car been sitting for a long time?
Reply With Quote
  #8  
Old 10-09-2012, 07:21 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 7,293
Mein Auto: 2012 hypermotard 796
Quote:
Originally Posted by BrittnyMarie View Post
if you still have constant spark, it's not anything from the ignition coil to the distributor. the distributor and rotor are fine. Since you are getting constant spark, your wires and everything else electrical is fine there is no need to replace any of those parts. The problem is all mechanical.
this is where it gets techy. even though he has spark, is it strong enough? a weak spark can cause a misfire. so too much gap in the cap and rotor plus spark plugs can cause a weak spark which simple turbulence can blow it out.
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
  #9  
Old 10-09-2012, 08:27 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,713
Mein Auto: E23;E30;E38;E32;E34 +
pretty sure no points on E30 325. Weak spark good path to follow. Get those injectors bench cleaned and tested. Please don't throw in a can of 'injector cleaner'. They don't work.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #10  
Old 10-10-2012, 07:52 AM
veez87 veez87 is offline
Registered User
Location: south africa
 
Join Date: Oct 2012
Posts: 2
Mein Auto: e30 bmw 325i
thanks 4 the help guys, think i'll try getting an auto electrician 2 check my wiring out 1st n if that doesn't work, then get the injectors properly cleaned & see what happens. the car was running fine just as i was driving approx 70km/h it just started to misfire & was battling 2 climb the hill. so i had it towed home. its gone like 3 months now, its just sitting in the yard and i got no wheels to move around
Reply With Quote
  #11  
Old 10-13-2012, 07:48 PM
BigBoy740il's Avatar
BigBoy740il BigBoy740il is online now
Officially Welcomed to the 'Fest
Location: Arizona
 
Join Date: Jan 2012
Posts: 289
Mein Auto: 1989/1991 E30; 2000 E38
+1 fuel system.
Since you said that you car idles fine but the problem appears at 70km, I would lean toward the fuel system. What is the fuel pressure at idle and at 2500 rpm. Check the fuel pressure, this validates the fuel pump and pressure regulator. Sonic cleaning the injectors ensures they produce the proper spray pattern all the way through redline. You should also check the coil's and plug wire resitance. Bad lead would register as open, have huge variances in impedance or would have electrical arc you can see at night. The E30 motronic system is self adjusting. Therefore, things such as idle speed, ignition timing, fuel injector spray duration, etc are all controlled by the ECU. Check the condition of the cap and rigor. It they are severely pitted or have carbon tracks, clean or replace them.

Big Boyz with Bad Toyz
__________________


Big Boyz with Bad Toyz.

Last edited by BigBoy740il; 12-01-2012 at 08:03 PM.
Reply With Quote
  #12  
Old 10-14-2012, 11:42 AM
BMWEnthus BMWEnthus is offline
Banned
Location: texas
 
Join Date: Oct 2012
Posts: 49
Mein Auto: 89 325i
I was given the idea to switch out the injectors put 135 in 246 and see if they still miss if not its the injectors if so its electrical

Sent from my PG06100 using Bimmer App
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms