Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-14-2012, 01:21 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Question Transmission "Jolting"

Hey everyone. So I bought a 2004 525i with 106k miles a couple months ago. However it has a trans issue I believe. In automatic mode, as I'm coming to a stop, I can actually feel the trans shifting into 1st gear.....RIGHT as a come to a stop. It's almost like I'm suddenly stomping the breaks if that makes sense. SO I started experimenting. At rest, I put the trans in Manual Mode, it automatically starts out at "MS" then you push the shifter forward to put it into 1st gear. When this is done, I can feel the car jolt forward as it shifts into 1st, and still at rest, I move the shifter backward to shift into 2nd, it jolts again. To me, it just feels like the transmission fluid a filter probably needs to be changed (I'll get into that in a second). I found the jolting to be weird so the experimenting continues....

I then take it for a drive in Manual Mode. There is no jolt what so ever as I shift through all the gears. It shifts normal according to what I think is normal. As I come to a stop, it automatically downshifts back down the gears, given I don't downshift myself, and as I come to a stop the trans stops down shifting at 2nd. To me, this doesn't sound right. Could anyone give me any insight on what it is i am experiencing? And what I can do to correct the issues.

Now, on the trans oil/filter change. I've read numerous things on this forum in regards to doing a trans fluid/filter change. One, that it's fairly simple if you remotely know anything about maintenance on vehicles. And two, That (my car specifically) apparently has a "lifetime lubrication" transmission....And that changing the trans fluid/filter would be tranny suicide and will probably be FUBAR after it gets changed, and never be the same. I just find this hard to believe.

So recap of questions that I need answers on:
-Insight on the trans down shifting only down to 2nd? what am I feeling/experiencing?
-What can I do (besides bring it to a stealer) to correct the problem?
-Would it be okay for me to do the trans fluid/filter change myself? how long would it take?


Thank you to all who reply!
Reply With Quote
Advertisement
  #2  
Old 10-14-2012, 02:23 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
There's a huge thread on this, check the stickied threads in this section. There are a couple of issues--one is software related and can be updated, the other is something wrong with the mechatronics unit (valve body that is electronically controlled. usually it's the EGS solenoids that go out). Worst case, if the whole mechatronics has to be replaced, the parts are about $1500 from ZF. A BMW dealership will charge several times that for it, so don't let them rape you.

It's a software issue most likely so start there after fluid/filter change. Software can be updated by the dealer, or you could possibly do it yourself if you buy the right cables and learn to use the software.

Yes you can do the fluid/filter change. It took me 2-3 hours to do it. The majority of that was just getting the car up on jack stands on all 4 corners, and getting the cover off (mine had one big cover that went from the front bumper to transmission). Pay attention to the fill procedure. https://www.thectsc.com/ has a kit with filter/fluid (filter is built into the pan so you have to replace the whole thing to replcae the filter). Personally I would only use ZF's transmission fluid. Others have found cheaper ones that seemed to have worked, but doesn't seem worth the risk to me to save a few bucks.

http://forums.5series.net/diy-do-you...-refill-88129/ is a link to a write up on it. Unfortunately the pictures stopped working a week or two ago for some reason. Make sure you take out the fill plug before you drain any fluid out (don't want to drain the fluid then realize you can't put more back in..)

Hopefully that helps!
Reply With Quote
  #3  
Old 10-15-2012, 10:15 AM
jsimon7777 jsimon7777 is offline
Giant Robot
Location: Fremont, CA
 
Join Date: Mar 2008
Posts: 604
Mein Auto: Scion FR-S
The software update fixed this for me.
__________________
2013 Scion FR-S
2007 550i Sport - GONE
2008 528i - GONE
"What are you going to replace your BMW with?"
"Another BMW, with a bigger engine!"
Reply With Quote
  #4  
Old 10-15-2012, 10:28 AM
ArtchredTTU ArtchredTTU is offline
Officially Welcomed to the 'Fest
Location: texas
 
Join Date: Dec 2010
Posts: 522
Mein Auto: 550i
BMW had to install a new tranny, They did software updates and all... Nothing fixed it, they replaced 2-3 parts before and it still didn't help. It's most likely a tranny issue. sorry man =(
Reply With Quote
  #5  
Old 10-15-2012, 11:24 AM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
It's all good. I'm not taking my car to a $tealer unless I absolutely have to. Pretty confident in my abilities. All I need tiger is the software, and a cable to upload it. I have a OBD Diag/Reset tool heading to me too. The $tealers can keep their tools.
Reply With Quote
  #6  
Old 10-15-2012, 12:04 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by Frenchyrider267 View Post
It's all good. I'm not taking my car to a $tealer unless I absolutely have to. Pretty confident in my abilities. All I need tiger is the software, and a cable to upload it. I have a OBD Diag/Reset tool heading to me too. The $tealers can keep their tools.
Amen, lol

If you need any help finding any of the software just let me know.
Reply With Quote
  #7  
Old 10-15-2012, 12:11 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Awesome! thanks brother. I may hit you up soon as I get the cable.
Reply With Quote
  #8  
Old 10-15-2012, 01:43 PM
ArtchredTTU ArtchredTTU is offline
Officially Welcomed to the 'Fest
Location: texas
 
Join Date: Dec 2010
Posts: 522
Mein Auto: 550i
I hope you're more lucky than me, I wish the software update would have fixed the problem.
Reply With Quote
  #9  
Old 10-15-2012, 02:43 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Well, if it turns out that I need a whole new tranny, ill just put up with it till it dies. It's really not a big issue at the monement. It's bareable. If I just drive in manual mode all the time, I don't even know te problem exists. It's more about just making the car as perfect as possible really at this point.
Reply With Quote
  #10  
Old 10-15-2012, 02:45 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by Frenchyrider267 View Post
Well, if it turns out that I need a whole new tranny, ill just put up with it till it dies. It's really not a big issue at the monement. It's bareable. If I just drive in manual mode all the time, I don't even know te problem exists. It's more about just making the car as perfect as possible really at this point.
Says who?

The 2-->1 issue has been fixed 99+% of the time by either software or a rebuilt mechatronics assembly. The problem is most dealers won't bother and just replace the whole transmission because that's what BMW says to do

Last edited by schpenxel; 10-15-2012 at 02:49 PM.
Reply With Quote
  #11  
Old 10-15-2012, 03:14 PM
ArtchredTTU ArtchredTTU is offline
Officially Welcomed to the 'Fest
Location: texas
 
Join Date: Dec 2010
Posts: 522
Mein Auto: 550i
Quote:
Originally Posted by schpenxel View Post
Says who?

The 2-->1 issue has been fixed 99+% of the time by either software or a rebuilt mechatronics assembly. The problem is most dealers won't bother and just replace the whole transmission because that's what BMW says to do
I didn't have to pay a dime, so i say "go right ahead, give me a tranny" lol
Reply With Quote
  #12  
Old 10-15-2012, 04:02 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by ArtchredTTU View Post
I didn't have to pay a dime, so i say "go right ahead, give me a tranny" lol
Well, in THAT case, BMW's "just replace the whole thing" policy works out great, lol
Reply With Quote
  #13  
Old 10-15-2012, 09:59 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
i kinda dont have that nice "replace anything for free" plan. I sort of purchased this car from a private party, and i'm pretty sure it no longer is under any kind of warranty. Sucks for me.....But in the same breath, Sucks for BMW that I can fix Sh**. Haha!
Reply With Quote
  #14  
Old 10-15-2012, 10:16 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
So I have found a few USB interface cables on Amazon. Any of these look familiar? Look like the right one that I need in order to upload the latest software?
Click image for larger version

Name:	ImageUploadedByBimmerApp1350360951.112259.jpg
Views:	112
Size:	35.9 KB
ID:	345906
Click image for larger version

Name:	ImageUploadedByBimmerApp1350360963.591749.jpg
Views:	116
Size:	37.1 KB
ID:	345907
Click image for larger version

Name:	ImageUploadedByBimmerApp1350360974.936161.jpg
Views:	112
Size:	42.5 KB
ID:	345908
Reply With Quote
  #15  
Old 10-15-2012, 10:35 PM
ArtchredTTU ArtchredTTU is offline
Officially Welcomed to the 'Fest
Location: texas
 
Join Date: Dec 2010
Posts: 522
Mein Auto: 550i
Quote:
Originally Posted by schpenxel View Post
Well, in THAT case, BMW's "just replace the whole thing" policy works out great, lol





Let us know if you fix the problem. Goodluck!!!
Reply With Quote
  #16  
Old 10-16-2012, 06:05 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
I'd just order the one from http://www.one-stop-electronics.com/shop/ and be done with it. It's been confirmed to work again and again.

If you google you can find people in the US that are getting rid of theirs, so that may save you some time (Wish I had went that route)
Reply With Quote
  #17  
Old 10-16-2012, 08:52 AM
dolfan13's Avatar
dolfan13 dolfan13 is offline
Officially Welcomed to the 'Fest
Location: lexington,ky usa
 
Join Date: Jan 2011
Posts: 938
Mein Auto: 545i
http://www.bimmerfest.com/forums/sho...d.php?t=645557 says it all.
Reply With Quote
  #18  
Old 10-16-2012, 09:26 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
That was actually a very helpful posted thread. So I think it's safe to say that I can do a trans oil/filter change, just as long the reset is done.
Reply With Quote
  #19  
Old 10-17-2012, 06:05 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by Frenchyrider267 View Post
That was actually a very helpful posted thread. So I think it's safe to say that I can do a trans oil/filter change, just as long the reset is done.
Consider a software update as well
Reply With Quote
  #20  
Old 10-17-2012, 09:27 AM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Yes, absolutely. Just waiting on all the supplies to arrive. :-)
Reply With Quote
  #21  
Old 10-17-2012, 09:46 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Me and you both, lol.

I finally broke down and just bought a used cable from someone on the forum. Should be here tomorrow. My new one is still stuck in customs somewhere
Reply With Quote
  #22  
Old 10-18-2012, 09:56 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
This is probably one of the only times I hate living in Hawaii... Long shipping times, as well as outrageous shipping prices. Usually it costs just as much for shipping as the item I purchased..... Ugh!!!
Reply With Quote
  #23  
Old 10-21-2012, 04:33 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Quote:
Originally Posted by schpenxel View Post
Amen, lol

If you need any help finding any of the software just let me know.
So I finally got my OBD tool. Creator C100. So now I need to learn how to use it. Anyone able to give me a crash course on how to update the info on it before I get started diagnosing?Click image for larger version

Name:	ImageUploadedByBimmerApp1350858805.182794.jpg
Views:	90
Size:	88.7 KB
ID:	346776
Reply With Quote
  #24  
Old 10-21-2012, 04:43 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by Frenchyrider267 View Post
So I finally got my OBD tool. Creator C100. So now I need to learn how to use it. Anyone able to give me a crash course on how to update the info on it before I get started diagnosing?Attachment 346776
I'm not even sure what that is, or how/if it works to update transmission software.

http://www.one-stop-electronics.com/...&product_id=16 is the one most people around here prefer

edit: after a very quick glance over the specs on that unit, I'm not sure it can really do anything useful for you in this situation. You need a cable you can connect to a computer.

Last edited by schpenxel; 10-21-2012 at 04:44 PM.
Reply With Quote
  #25  
Old 10-21-2012, 05:28 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Oh no.... I'm not using this to update the software for the trans issue. I'm still waiting on that cable. This was just to get rid of the check eng light, and reset the SRS fault.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms