Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-23-2012, 04:22 PM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
No CAFD entry on AHM unit

Hello,

i retrofited the trailer hitch and it works fine. The automatic folding and CIC messages also works without problem. Also is disconnect the rear PDC perfectly.

I retrofited it before i have ESYS and the ENET cable, and now i can see that it hasn´t got the CAFD entry.

I speaked with Shawn and he told me that it could be because i retrofitted without a codification.

Could anyone confirm me if this unit has cafd entry? What´s could be the number?

Here is a picture:

Click image for larger version

Name:	Captura de pantalla 2012-10-24 a la(s) 01.14.20.png
Views:	149
Size:	340.4 KB
ID:	347078


Also, i don´t have the 3AC option added to my VO, What´s the unit in relation with the AHA?

Maybe DSC, FRM, KOMBI and CIC? LCW?

Remember that it works fine, i only have an issue in the dashboard that says Lane change warning disconnect with i have my bicycles support attached to the trailer hitch.

I know that it should be by the obstruction of the rear sensors for this features.

Regards

Last edited by mateforrest; 10-27-2012 at 09:54 AM.
Reply With Quote
Ads by Google
  #2  
Old 10-27-2012, 09:57 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Solved!!!

Now is ok:



Just Detect CAF for SWE and after coded the unit.
Reply With Quote
  #3  
Old 10-27-2012, 10:26 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,682
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by mateforrest View Post
Solved!!!

Now is ok:



Just Detect CAF for SWE and after coded the unit.
Is Lane change warning disconnect issue solved?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #4  
Old 10-27-2012, 10:35 AM
mateforrest mateforrest is offline
Officially Welcomed to the 'Fest
Location: Madrid, Spain
 
Join Date: Oct 2012
Posts: 142
Mein Auto: BMW F10 530D SILVER
Quote:
Originally Posted by shawnsheridan View Post
Is Lane change warning disconnect issue solved?
Hello Shawn,

Still i don´t try it, i will tell you.

Thanks
Reply With Quote
  #5  
Old 11-12-2013, 09:07 AM
grisu grisu is offline
Registered User
Location: Germany
 
Join Date: Oct 2013
Posts: 6
Mein Auto: 530d
Hallo,

I have the same Problem. I also retrofitted a trailer hitch and want to code the module.

The code for the automatic hitch 3ac. What is the code for the manual hitch?

regards
Dirk
Reply With Quote
  #6  
Old 11-12-2013, 09:19 AM
grisu grisu is offline
Registered User
Location: Germany
 
Join Date: Oct 2013
Posts: 6
Mein Auto: 530d
Quote:
Originally Posted by mateforrest View Post
Solved!!!

Now is ok:



Just Detect CAF for SWE and after coded the unit.
What did you mean with SWE?
Reply With Quote
  #7  
Old 11-12-2013, 09:21 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,682
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by grisu View Post
Hallo,

I have the same Problem. I also retrofitted a trailer hitch and want to code the module.

The code for the automatic hitch 3ac. What is the code for the manual hitch?

regards
Dirk
Quote:
Originally Posted by grisu View Post
What did you mean with SWE?
Connect => Read FA (VO) => Activate FA (VO) => Read SVT (VCM) => Left-Click on AHM ECU => Click on "Detect CAF for SWE" => Select the CAFD matching your I-Level => Select OK => Right-Click on AHM (the ECU itself not the underlying CAFD) => Select CODE.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #8  
Old 11-15-2013, 08:11 AM
grisu grisu is offline
Registered User
Location: Germany
 
Join Date: Oct 2013
Posts: 6
Mein Auto: 530d
Thanks! That works.

Know anyone the code for the manual hitch? I try 230 but I get an error.



I code 3AC in the FA and then Code with FDL not to use the LIN of the automatic hitch.
That works. But I think the better way is to code the correct Code in the FA.
Reply With Quote
  #9  
Old 06-22-2014, 03:38 AM
jamesls jamesls is offline
Registered User
Location: Winchester (UK)
 
Join Date: Jan 2014
Posts: 6
Mein Auto: 2013 F11 LCI 530d
I've just retrofitted the trailer hitch to my F11 and have added the 3AC option to my VO but which ECU do I code? I don't have an AHM ECU?!

Thanks,

James
Reply With Quote
  #10  
Old 06-22-2014, 03:41 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,682
Mein Auto: 2011 535i M-Sport
Did you read ECU instead of Read SVT?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #11  
Old 06-22-2014, 04:02 AM
jamesls jamesls is offline
Registered User
Location: Winchester (UK)
 
Join Date: Jan 2014
Posts: 6
Mein Auto: 2013 F11 LCI 530d
Just tried that but still no AHM (but then I don't have adaptive headlights so is that expected?). What ECU am I looking for to code option 3AC?
Reply With Quote
  #12  
Old 06-22-2014, 04:06 AM
jamesls jamesls is offline
Registered User
Location: Winchester (UK)
 
Join Date: Jan 2014
Posts: 6
Mein Auto: 2013 F11 LCI 530d
Attached are the ECUs I see after Read ECU.

Thanks
Attached Thumbnails
Click image for larger version

Name:	ECUs.png
Views:	25
Size:	10.7 KB
ID:	447323  
Reply With Quote
  #13  
Old 06-22-2014, 04:43 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,682
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by jamesls View Post
Just tried that but still no AHM (but then I don't have adaptive headlights so is that expected?). What ECU am I looking for to code option 3AC?
AHM has nothing to do with Adaptive Headlights, which are in FRM. AHM is Anhänger-Modul, German for Trailer Module.

Still, something is not right. If Trailer Module is installed properly, you should see AHM in SVT when you read ECU.

Try creating SVT Target as follows, and see if AHM then shows up in Red:

Go to Comfort Mode => TAL-Calculating
- Read and Save FA
- Activate FA
- Read and Save SVT Actual as SVT_ist
- Create an SVT Target
Under KIS/SVT Target Calculation Strategy, select Complete Flash
Select I-Step (shipm.) to match your original I-Level as read and shown in VCM I-Step (Shipment)
I-Step (target.) will be unselectable as it is fixed based on current PSdZData I-Level
Do a KIS/SVT Target Calculation
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #14  
Old 06-22-2014, 05:18 AM
jamesls jamesls is offline
Registered User
Location: Winchester (UK)
 
Join Date: Jan 2014
Posts: 6
Mein Auto: 2013 F11 LCI 530d
Mystery solved - I tried the above and still no AHM so I re-visited the installation instructions and noticed that they refer to the AAG control unit (which is listed in the attachment above) - as soon as I coded that then everything's working. Not sure what the difference is between AHM and AAG - possibly related to LHD vs RHD, NA vs Europe or pre/post LCI?!

My only remaining issue is an "SOS call system failure" check control message since restoring power after the install - can this be reset using eSys?

Thanks,

James
Reply With Quote
  #15  
Old 06-22-2014, 05:24 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,682
Mein Auto: 2011 535i M-Sport
Interesting. When I looked at your SVT, AAG was the only one I did not know what it was for, and I Googled it and found nothing. Good to know it is also Trailer Module.

Try and clear SOS with E-Sys as follows:

Click "External Applications" in the left menu.
Click "External Application"
Double-click "Transmitter"
Scroll to the bottom and double-click "... Clear all DTCs ..."
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #16  
Old 06-22-2014, 05:41 AM
jamesls jamesls is offline
Registered User
Location: Winchester (UK)
 
Join Date: Jan 2014
Posts: 6
Mein Auto: 2013 F11 LCI 530d
Great - that fixed it - thanks Shawn.

Also noticed that there haven't been many retrofits for the F11 trailer module so thought I may come across a few challenges but pleased it all went well in the end and now at least we're aware of AAG!

Thanks,

James
Reply With Quote
  #17  
Old 06-22-2014, 05:43 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,682
Mein Auto: 2011 535i M-Sport
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms