Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)

X3 F25 (2011 - current)
The latest X3 brings some added style and some new features to the BMW SUV family. Talk about the new F25 now!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-16-2015, 08:59 PM
Lasybones Lasybones is offline
Registered User
Location: Canada
 
Join Date: Jan 2015
Posts: 5
Mein Auto: X3 M3
Trailer Hitch

I have installed an after market trailer hitch, simple to install, all wiring reconnected everything seems to be fine. (The hitch came from CURT hitches) When putting the vehicle in reverse the backup camera does not turn on but I get a message saying I should contact service. I have an option to accept the notification and the camera turns on and all is good and I have a visual when I back up. When I told the dealer they basically told me this is an after market hitch and the mechanic would have to trouble should the problem and this would not be covered by warranty. I suspect this is a software issue or some sort of reprogramming, can anyone help me out?
Reply With Quote
Advertisement
  #2  
Old 01-17-2015, 10:30 AM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
What was done to the wiring?
Reply With Quote
  #3  
Old 01-17-2015, 10:41 AM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
Quote:
Originally Posted by wingless View Post
What was done to the wiring?
Was it this Tow Ready kit or this Tow Ready kit?

Do you have / can you post the instructions / steps followed?
Reply With Quote
  #4  
Old 01-17-2015, 11:36 AM
Lasybones Lasybones is offline
Registered User
Location: Canada
 
Join Date: Jan 2015
Posts: 5
Mein Auto: X3 M3
No changes to the wiring. In order to install the hitch you need to unplug a wiring harness. I simply plugged it back in and finished installing hitch and bumper.
Reply With Quote
  #5  
Old 01-17-2015, 11:51 AM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
So the hitch was added, but no provision was made for trailer lights?

Does your vehicle have either / both the backup parking sensors and / or the toe kick hatch lift sensor?
Reply With Quote
  #6  
Old 01-17-2015, 11:59 AM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
It sounds like one of the body modules is now confused about the vehicle's configuration. Was the vehicle started while the harness was unplugged?

It MIGHT be possible to fix the problem by disconnecting / reconnecting the battery aft a minute (not a recommendation, but it could work).

The likely fix will be to plug into the vehicle and "remind" it of the configuration.

This topic has links to the process. Good luck!
Reply With Quote
  #7  
Old 01-17-2015, 12:10 PM
Lasybones Lasybones is offline
Registered User
Location: Canada
 
Join Date: Jan 2015
Posts: 5
Mein Auto: X3 M3
It has parking sensors and backup camera. I don't know if it has a toe kick hatch lift sensor. I will check . I have unplugged the battery for approx. 12 hours and no result. I have asked the dealer to run diagnostics or reset the vehicle S/W back to factory defaults they were telling me that that will take quite some time and expense. The vehicle wasn't started when the sensor was unplugged.
FYI... is this toe sensor visible if I crawl under the vehicle ? Thanks for your help.
Reply With Quote
  #8  
Old 01-17-2015, 12:15 PM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
No the toe kick sensor is not visible.

There would have been two connectors to disconnect under the bumper if it has the toe kick, one under the bumper for just the backup.

The vehicle body programming is the way to fix the problem.

The dealership can do it, or you, or there might be a local expert. Where in Canada are you located and do you want local help?
Reply With Quote
  #9  
Old 01-17-2015, 12:55 PM
Lasybones Lasybones is offline
Registered User
Location: Canada
 
Join Date: Jan 2015
Posts: 5
Mein Auto: X3 M3
Thanks, I'm in Saskatachewan. I may take it back to the dealer to do this. I read through the Coding and Programming threads, would I be correct in assuming that I would be able to do the same thing on my own ?
Reply With Quote
  #10  
Old 01-17-2015, 01:08 PM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
Yes, a cable and a laptop are required for DIY programming.

This company offers remote programming service through your laptop. Only the cable and a laptop connected to the Internet are required. They also offer configuration options, like removing the legal disclaimer NAV startup splash screen.
Reply With Quote
  #11  
Old 01-17-2015, 01:33 PM
Lasybones Lasybones is offline
Registered User
Location: Canada
 
Join Date: Jan 2015
Posts: 5
Mein Auto: X3 M3
Thank you for your help
Reply With Quote
  #12  
Old 01-19-2015, 05:13 AM
wingless wingless is offline
Registered User
Location: FL
 
Join Date: Apr 2007
Posts: 52
Mein Auto: 2015 BMW X3 xDrive28i
The passive proximity antenna connector and the toe kick / parking sensor connector were both unplugged / reconnected w/o the vehicle's electronics getting weird during my trailer hitch installation.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms