Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-20-2012, 02:16 PM
davidspyle davidspyle is offline
Registered User
Location: Loveland, Co.
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 1987 BMW 325 cpe.
'87 325 Instrument Panel/plus problem

Hello . . .

I'm having an electrical problem with my 1987 BMW 325 and not sure why. The instrument panel is not lighting up, nor are the fuel/tachometer/fuel consumption/coolant temp guages working. Additionally, the heater fan and outside mirror adjuster are not working either. Everything quit, apparently, at the same time.

I've replaced the fuses but the problem persists. Not sure whether it could be a relay or if the fuse box itself is bad. Any suggestions or recommendations as to where to look and/or how to proceed would be greatly appreciated.

Thanks.

David
Reply With Quote
Ads by Google
  #2  
Old 11-20-2012, 03:49 PM
woodenbmw's Avatar
woodenbmw woodenbmw is online now
Officially Welcomed to the 'Fest
Location: Virginia Beach, VA
 
Join Date: Apr 2012
Posts: 123
Mein Auto: 1987 BMW 325
Hi David,
I had an issue with my '87 325 somewhat like yours. I wound up fixing it simply by taking the panel out, cleaning the contacts, and replacing the SI batteries. I think it was more replacing batteries than it was cleaning the contacts lol. I hope this helps. Rob
Reply With Quote
  #3  
Old 11-20-2012, 04:20 PM
davidspyle davidspyle is offline
Registered User
Location: Loveland, Co.
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 1987 BMW 325 cpe.
Thanks, Rob.
Unfortunately, I think it is a little more involved than that.The instrument panel guages are not working, along with the fan blower an outside mirror adjusters. So, it would seem that there are other factors. In any case, your response is appreciated.

dsp
Reply With Quote
  #4  
Old 11-20-2012, 04:34 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 6,945
Mein Auto: 2012 hypermotard 796
SI batteries will explain some of the gauges not working. lights are either gunna be the bulbs blew, bad ground, or bad contacts. blower and mirror motors i have nothing.
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
  #5  
Old 11-20-2012, 05:00 PM
davidspyle davidspyle is offline
Registered User
Location: Loveland, Co.
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 1987 BMW 325 cpe.
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming.


Funny, funny. :-)
Reply With Quote
  #6  
Old 11-20-2012, 06:13 PM
woodenbmw's Avatar
woodenbmw woodenbmw is online now
Officially Welcomed to the 'Fest
Location: Virginia Beach, VA
 
Join Date: Apr 2012
Posts: 123
Mein Auto: 1987 BMW 325
Quote:
Originally Posted by davidspyle View Post
Everything quit, apparently, at the same time.

David
Is this a car you recently acquired or did you have it garaged for a while ?
Reply With Quote
  #7  
Old 11-20-2012, 07:15 PM
davidspyle davidspyle is offline
Registered User
Location: Loveland, Co.
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 1987 BMW 325 cpe.
I've had the car for about four years and have driven it regularly since then. It has approximately 180K on it.
Everything was working until the other day when they all just quit functioning.
Reply With Quote
  #8  
Old 11-20-2012, 07:27 PM
woodenbmw's Avatar
woodenbmw woodenbmw is online now
Officially Welcomed to the 'Fest
Location: Virginia Beach, VA
 
Join Date: Apr 2012
Posts: 123
Mein Auto: 1987 BMW 325
I don't think it would hurt to pull the fuse box and look for obvious signs of damage. I'm not completely sure what relays are in the fuse box as I don't have a manual.
Reply With Quote
  #9  
Old 11-21-2012, 02:55 AM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,099
Mein Auto: E23;E30;E38;E32;E34 +
Start checking plugs, contacts and grounds (earths). A large half out plug will bring on all sorts of problems. Check where loom sections join front/rear/engine bay.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms