Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-01-2012, 08:38 AM
bfinta bfinta is offline
Registered User
Location: Ottawa
 
Join Date: Jul 2010
Posts: 25
Mein Auto: 2004 325xi
Aux input problem

Hi everyone, first post here i have an '04 325xi, i recently installed the genuine aux input kit from the dealer, installed it in the cubby hole beneath the climate control unit, anyways its been working fine for a few days, all of a sudden today while working in the car listening to the stereo it switched on its own from 'aux' to FM, then i tried to cycle back to AUX and wasnt even an option. tried again and it worked but now it seems when it does find the AUX it only stays on that input for a few seconds and then automatically switches back to FM... any ideas of whats wrong?
Reply With Quote
Advertisement
  #2  
Old 11-01-2012, 09:25 AM
smolck's Avatar
smolck smolck is online now
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,348
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by bfinta View Post
Hi everyone, first post here i have an '04 325xi, i recently installed the genuine aux input kit from the dealer, installed it in the cubby hole beneath the climate control unit, anyways its been working fine for a few days, all of a sudden today while working in the car listening to the stereo it switched on its own from 'aux' to FM, then i tried to cycle back to AUX and wasnt even an option. tried again and it worked but now it seems when it does find the AUX it only stays on that input for a few seconds and then automatically switches back to FM... any ideas of whats wrong?
Can only tell you that mine does that from time to time, but I can switch right back to aux and it works fine again. Might be the connectors on the back of the radio are loose, I'd check those leads for starters.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #3  
Old 11-01-2012, 09:27 AM
bfinta bfinta is offline
Registered User
Location: Ottawa
 
Join Date: Jul 2010
Posts: 25
Mein Auto: 2004 325xi
ok i guess ill see how it behaves over the next few days, id prefer to not have to take it apart again. its just the one cable attaching to the back of the stereo... i would have thought with that clip that pushes down it would hold it in place well.
Reply With Quote
  #4  
Old 11-01-2012, 09:30 AM
smolck's Avatar
smolck smolck is online now
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,348
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by bfinta View Post
ok i guess ill see how it behaves over the next few days, id prefer to not have to take it apart again. its just the one cable attaching to the back of the stereo... i would have thought with that clip that pushes down it would hold it in place well.
One would think, but if it isn't working then you have to go through process of elimination.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #5  
Old 11-01-2012, 11:32 AM
Gryphon's Avatar
Gryphon Gryphon is online now
I brew life
Location: Mt. Holly, NJ
 
Join Date: Oct 2007
Posts: 3,580
Mein Auto: 2005 ZHP, Wife's Prius
When it refuses to cycle to AUX, do you have the device plugged in to charge? This can cause a ground loop situation which the head unit changes to save itself.
__________________
Arthur John
Born 02-24-11

Has already been awarded the title "Destroyer of Sleep"
Reply With Quote
  #6  
Old 11-01-2012, 09:50 PM
bfinta bfinta is offline
Registered User
Location: Ottawa
 
Join Date: Jul 2010
Posts: 25
Mein Auto: 2004 325xi
not sure what a ground loop is, but the times it did switch away from Aux to FM it was charging (through USB / cig lighter), tonight it did it again, then i unplugged the charger and so far it hasnt done it while not charging.
Reply With Quote
  #7  
Old 11-02-2012, 07:52 AM
Gryphon's Avatar
Gryphon Gryphon is online now
I brew life
Location: Mt. Holly, NJ
 
Join Date: Oct 2007
Posts: 3,580
Mein Auto: 2005 ZHP, Wife's Prius
Yeah, you cannot charge your device while playing it through the AUX connector. This causes an electrical situation that could damage the head unit so it switches away from that mode to prevent damage. Some of the better AUX IN setups have what's called a Ground Loop Interrupt which will allow for charging and playing simultaneously.
__________________
Arthur John
Born 02-24-11

Has already been awarded the title "Destroyer of Sleep"
Reply With Quote
  #8  
Old 11-04-2012, 03:07 AM
nl318 nl318 is offline
Registered User
Location: Netherlands
 
Join Date: Oct 2011
Posts: 22
Mein Auto: 318i 2000
You can buy something what's called a ground loop isolator. You just have to plug it in between your 3.5mm wire and you can use aux while charging perfectly!

Sent from my HTC Desire HD A9191 using Bimmer App
Reply With Quote
  #9  
Old 11-04-2012, 05:26 AM
bfinta bfinta is offline
Registered User
Location: Ottawa
 
Join Date: Jul 2010
Posts: 25
Mein Auto: 2004 325xi
thanks for the replies guys / gals... i never thought this would be a problem, for the 80$ i paid for the darned aux input kit you'd think BMW would have known this could be an issue and implemented this device in the kit.
So would this do the trick? http://www.ebay.ca/itm/3-5mm-Earphon...item3a60c689e3
if im not allowed to post links to auctions sorry...
Reply With Quote
  #10  
Old 11-04-2012, 06:08 AM
nl318 nl318 is offline
Registered User
Location: Netherlands
 
Join Date: Oct 2011
Posts: 22
Mein Auto: 318i 2000
Yes, that's it!

Sent from my HTC Desire HD A9191 using Bimmer App
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms