Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-02-2013, 08:47 PM
moggie707 moggie707 is offline
Registered User
Location: Gold Coast Australia
 
Join Date: Apr 2013
Posts: 3
Mein Auto: E60 530d
06 530d Active Steering Failed with smoke

I am trying to figure out what happened and what I will have to fix my Active Steering

I was pulling a U turn at full lock right, when I tried to straighten up I couldn't almost ran up the gutter. The steering felt like it was locked

When I stopped I noticed a cloud of brown smoke come from under the bonnet/ car
I then got a message on the screen saying charging fault. a few seconds later the steering freed up and then I get a message saying active steering fault.

I turned the car off and back on, I am not getting any error messages but the steering does not feel right especially when you start to get close to full lock.

I am guessing the electric motor burned out hence the smoke and the charging fault caused by the huge current draw from the motor burning out.

Can anyone shed some light, This is a very dangerous fault having the steering lock up like it did, luckily I wasn't going very fast and was able to stop.

Thanks Ash
Reply With Quote
Ads by Google
  #2  
Old 04-03-2013, 07:33 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,287
Mein Auto: '06 530i, '07 C280, ML320
Quote:
Originally Posted by moggie707 View Post
...
I then got a message on the screen saying charging fault. a few seconds later the steering freed up and then I get a message saying active steering fault.
...
Did you open the bonnet and check? Look at the drive belt, possibly that drive belt broke. For your car's engine, I am not sure if you have one belt or 2 belts. Very likely the belt that runs the alternator [along with other accessories] must've broken.
Reply With Quote
  #3  
Old 04-03-2013, 05:11 PM
moggie707 moggie707 is offline
Registered User
Location: Gold Coast Australia
 
Join Date: Apr 2013
Posts: 3
Mein Auto: E60 530d
Quote:
Originally Posted by pcy View Post
Did you open the bonnet and check? Look at the drive belt, possibly that drive belt broke. For your car's engine, I am not sure if you have one belt or 2 belts. Very likely the belt that runs the alternator [along with other accessories] must've broken.
Yes I checked that, There is no charge fault or steering fault in the idrive now, But when I start the car and move the steering wheel now it doesn't feel right and I can start to smell the burning smell again.

When the car is off and I move the steering wheel lock to lock about 3/4 of a rotation in each direction from center the front wheels only turn a little bit is this normal?
Reply With Quote
  #4  
Old 04-03-2013, 05:40 PM
JFIVE JFIVE is online now
Registered User
Location: Gaithersburg Maryland
 
Join Date: Jan 2013
Posts: 46
Mein Auto: 545i
I'm not an expert but sounds like your power steering rack is toast, check your fluid level, belts, pump and hose's
I wouldn't drive it at this point if you are getting very little movement in the wheels when trying to steer, That is not normal.

Sent from my SPH-L710 using Bimmer App
Reply With Quote
  #5  
Old 04-03-2013, 06:24 PM
dwlink's Avatar
dwlink dwlink is online now
Officially Welcomed to the 'Fest
Location: St. Louis
 
Join Date: May 2007
Posts: 1,436
Mein Auto: 530i
I'd start with the steering rack, but would also be concerned about the power steering pump.

Unfortunately, both of these items are a fairly big ticket to replace. I thought my pump was going, but it turned out to be a loose belt so here's a link to the pump I was about to buy.

Might want to double check fitment for your exact car, but this is the pump for the M54 530i WITH active steering AND WITHOUT dynamic drive.

http://www.autopartswarehous3.com/sk...n+%26+Steering
replace the 3 with an "e" above to get the link to work

Its re-manufactured, but only 1/2 the price of what a dealer would charge you.

As for the steering rack itself - of course you'll need the more expensive one that accommodates active steering. I believe you can find those re-manufactured for low $1000s.

You could probably do the pump yourself with the right guide if you have the tools and are mechanically inclined, but replacing the rack is a bit more involved.
__________________
2004 BMW 530i (his) -Titanium Silver -Grey Dakota -Dark Poplar -Premium -Sport -Cold Weather -Xenons -Heated Rear Seats -Active Steering -Logic 7 -Sirius
2015 BMW 435i GC MSport (his-planned) -Estoril Blue -Black Dakota -Aluminum Hex -Premium -Cold Weather -Technology -Lighting -HK Sound
2010 Lexus RX350 AWD (hers) -Smokey Granite Mica -Black -Premium -Comfort -Nav -Tow Prep -Premium Sound -Wood Steering Wheel/Shifter

Last edited by dwlink; 04-03-2013 at 06:27 PM.
Reply With Quote
  #6  
Old 04-03-2013, 09:44 PM
moggie707 moggie707 is offline
Registered User
Location: Gold Coast Australia
 
Join Date: Apr 2013
Posts: 3
Mein Auto: E60 530d
Well I did some more investigation today, found that the harmonic balancer is stuffed. Everything looks fine untill you get some load on it, then all the pulleys stop turning and smoke starts pouring out of the balancer.
Thanks everyone for your replies.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms