Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-06-2012, 12:18 AM
white_lancer white_lancer is offline
Officially Welcomed to the 'Fest
Location: uk
 
Join Date: Aug 2012
Posts: 203
Mein Auto: E53 X5 2004 3.0 SPORT
PDC Parking Sensors

I managed to fix my PDC parking sensors on the X5. When I put the car into reverse I had a constant high pitch tone for a few seconds and the little green light on the PDC button used to flash on and off indicating a fault.

I put the car into reverse and asked my son to listen to each sensor in turn and tell me which one was not clicking. He identfied the culprit as one of the corner sensors as this was silent.

I ordered a replacement from ebay for 15 and installed the sensor. the PDC system now works absolutely fine with the front and rear sensors functioning perfectly.
__________________
E90 318i 2007 N46 2.0 Manual
E53 X5 2004 M54 3.0 Sport Auto
E83 X3 2004 M54 2.5 Auto

Last edited by white_lancer; 11-07-2012 at 11:57 PM.
Reply With Quote
Advertisement
  #2  
Old 11-10-2012, 07:51 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,977
Mein Auto: 1997 740iL / 2006 X5 4.4
Great tip...thanks for sharing. This will definitely go into my mental rolodex.
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #3  
Old 11-14-2013, 10:38 AM
tolgatt tolgatt is offline
Registered User
Location: Calgary,AB
 
Join Date: Aug 2013
Posts: 36
Mein Auto: 2005 BMW X5 4.4 Sport
I have the same symptoms now , I have listened all the sensors at the back and they all make that clicking sound.
I tried listening the front sensors and I had 2 of them that dont quite click.
Is it true if the front sensors go bad then rear sensors stop working as well ?
I dont get how 2 sensors go bad at the same time.
Is it easy to replace the front sensors?
Reply With Quote
  #4  
Old 12-03-2013, 02:36 AM
itechbimmerfest itechbimmerfest is offline
tech_bimmer
Location: Florida
 
Join Date: Dec 2013
Posts: 27
Mein Auto: 2006 X5 E53
I blame the drive through car wash for faulting my PDC sensors. It is true. Once one goes bad, they all go bad. My PDC light doesn't even come on now.
__________________
A man of great courage is the man who brakes the latest.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms