Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series & 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion of BMW's 4th generation E65/E66 7 Series flagship. The E65 generated much controversy, due to its radical styling and iDrive user difficulties. Nonetheless, the E65 broke records to become the best-selling 7-series iteration ever, especially after its 2005 facelift.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-28-2014, 01:17 PM
docphi12 docphi12 is offline
Registered User
Location: PA
 
Join Date: Jun 2014
Posts: 9
Mein Auto: 745Li
745Li DMTL Pump

I've got a 2005 745Li. Anyone know where this pump is located and how to get to it? Thanks!
Reply With Quote
Advertisement
  #2  
Old 06-28-2014, 04:59 PM
Rick in Yuma's Avatar
Rick in Yuma Rick in Yuma is offline
bimmerfest Supporting Member
Location: Arizona
 
Join Date: Dec 2006
Posts: 1,323
Mein Auto: 05' 760li,94' H1,08'Smart
http://workshop-manuals.com/bmw/7_se...all_u/page_67/

Try this
Reply With Quote
  #3  
Old 06-28-2014, 05:12 PM
dvanlare dvanlare is offline
Officially Welcomed to the 'Fest
Location: Phoenix, AZ
 
Join Date: Apr 2008
Posts: 375
Mein Auto: '95 E31, '05 E66, '15 F02
Behind right rear wheel arch trim

http://www.bimmerfest.com/forums/sho...578&highlight=
Reply With Quote
  #4  
Old 06-28-2014, 07:01 PM
docphi12 docphi12 is offline
Registered User
Location: PA
 
Join Date: Jun 2014
Posts: 9
Mein Auto: 745Li
Thanks for the info guys. That's where I thought it might be. How hard is it to remove the wheel well liner? Thanks again!
Reply With Quote
  #5  
Old 07-10-2014, 01:18 PM
docphi12 docphi12 is offline
Registered User
Location: PA
 
Join Date: Jun 2014
Posts: 9
Mein Auto: 745Li
Ok. Changed the pump. The pump was easy. Removing and replacing the wheel liner was a bear! Those pop rivets are worthless. Anyone know what the white and blue cylinders are that are clipped to the inside of the liner? Some kind of sensors?
Reply With Quote
  #6  
Old 07-11-2014, 07:13 PM
docphi12 docphi12 is offline
Registered User
Location: PA
 
Join Date: Jun 2014
Posts: 9
Mein Auto: 745Li
So the pump replacement didn't work. I'm still getting the same error codes. The dealer scoped the car and said it was the pump and that's why I replaced it myself to save a few bucks. Anyone have any suggestions?
Reply With Quote
  #7  
Old 07-11-2014, 07:50 PM
dvanlare dvanlare is offline
Officially Welcomed to the 'Fest
Location: Phoenix, AZ
 
Join Date: Apr 2008
Posts: 375
Mein Auto: '95 E31, '05 E66, '15 F02
Did you reset the code and complete a drive cycle?
Reply With Quote
  #8  
Old 07-11-2014, 08:08 PM
docphi12 docphi12 is offline
Registered User
Location: PA
 
Join Date: Jun 2014
Posts: 9
Mein Auto: 745Li
Quote:
Originally Posted by dvanlare View Post
Did you reset the code and complete a drive cycle?
Yup. Reset the code and I've been driving it since yesterday with no issues. Today the code popped up again.
Reply With Quote
  #9  
Old 07-17-2014, 05:27 PM
docphi12 docphi12 is offline
Registered User
Location: PA
 
Join Date: Jun 2014
Posts: 9
Mein Auto: 745Li
So my type A personality was driving me nuts and I had to figure this out. I had already changed the DMTL pump and drove a few drive cycles without any luck in resetting the monitors. So I dumped Seafoam in the gas tank and drove around for a couple of days without any luck. I pulled out my old laptop and booted up INPA to have a look around today. The mass air flow output was wacky and the EVAP and secondary air monitors weren't resetting. I ran a few rev tests and DMTL leak tests. The mass flow output improved so I reset all the codes and turned off the car. When I turned it back on it was intermittently revving and idling and finally settled down. Imagine my surprise when I found all monitors were functioning normally. Hopefully it'll stay that way. We'll see what happens over the next few days.
Reply With Quote
  #10  
Old 12-21-2016, 11:53 AM
Tony F. Tony F. is offline
Registered User
Location: Georgia
 
Join Date: Nov 2016
Posts: 5
Mein Auto: 2004 745li
Issue

Sorry for the addition to an old post. I changed my DMTL pump (yes @docphi: the shield IS a bear to remove). Anyway, after removing and replacing pump. I am now getting DSC/ABS/Parking Brake Malfunction lights. Anyone know what i did wrong? Need help as soon as someone can get back to me. Need to know what to do before car has to be driven tomorrow!
Reply With Quote
  #11  
Old 12-27-2016, 09:05 AM
Tony F. Tony F. is offline
Registered User
Location: Georgia
 
Join Date: Nov 2016
Posts: 5
Mein Auto: 2004 745li
Any help???

I am still trying to track down source of problem. Anyone???
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series & 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms