Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-08-2012, 09:34 AM
repoman75 repoman75 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Dec 2010
Posts: 108
Mein Auto: 2008 535 xi
Check Engine Light

So for over a month now, the check engine light (the yellow light on the dashboard shaped like an engine) has come on.... it stays on for like 2 days, then goes off for 2 days, then back on for 2 days, then back off, etc. No errors in the iDrive, no performance issues whatsoever.

I will have the dealer look at it when I bring it in for inspection next month, but what do you guys think? Faulty sensor somewhere?

It first appeared after I had the turbos replaced... but again, no performance issues whatsoever.
Reply With Quote
Ads by Google
  #2  
Old 11-08-2012, 04:25 PM
GSG1 GSG1 is offline
Registered User
Location: Toronto
 
Join Date: Nov 2012
Posts: 12
Mein Auto: 07 525i, 05 S500 4Matic
Happend to me a few weeks ago. Did a scan and it was the MAF sensor. If it is, take the MAF out and try cleaning it with a MAF spray cleaner. One of the easiest DIY you can do. Sometimes that is enough. Clear the light and see how it goes. If it comes back with the MAF code again then you have to replace it.
Reply With Quote
  #3  
Old 11-08-2012, 05:24 PM
repoman75 repoman75 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Dec 2010
Posts: 108
Mein Auto: 2008 535 xi
Thanks! Can you detail where the MAF sensor is and how to remove it?
Reply With Quote
  #4  
Old 11-08-2012, 06:01 PM
GSG1 GSG1 is offline
Registered User
Location: Toronto
 
Join Date: Nov 2012
Posts: 12
Mein Auto: 07 525i, 05 S500 4Matic
Quote:
Originally Posted by repoman75 View Post
Thanks! Can you detail where the MAF sensor is and how to remove it?
It's on the intake manifold near the air box. You have to remove 2 torx screws.

Here is a good post on it.

http://forums.5series.net/diy-do-you...diy-n52-98032/
Reply With Quote
  #5  
Old 11-08-2012, 08:25 PM
booyaazaa's Avatar
booyaazaa booyaazaa is offline
Officially Welcomed to the 'Fest
Location: East Bay, CA
 
Join Date: May 2012
Posts: 1,025
Mein Auto: '09 AW 535i
Quote:
Originally Posted by GSG1 View Post
It's on the intake manifold near the air box. You have to remove 2 torx screws.

Here is a good post on it.

http://forums.5series.net/diy-do-you...diy-n52-98032/
The n54 engine does not have a maf sensor.

Repo man, if your car is under warranty take it to the dealer for them to pull error codes or if you have a code reader pull the codes yourself. It could be numerous different things so the error codes will help narrow down the issue.
__________________

2009 AW 535i
-Sport, Premium Package, and Comfort Access
-FBO, custom Cobb E30 map, Performance Gearing LSD.
Reply With Quote
  #6  
Old 11-09-2012, 06:14 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,292
Mein Auto: '06 530i, '07 C280, ML320
Quote:
Originally Posted by booyaazaa View Post
The n54 engine does not have a maf sensor.

...
Mass Air Flow (MAF) sensor measures the amount of air going in to intake. All cars need some type of mechanism to measure the amount of air going in to intake. Almost all modern cars have MAF - on some cars, it's located in an obvious place right after the air filter on the intake tube and on other cars it may be buried along the intake.
Reply With Quote
  #7  
Old 11-09-2012, 06:43 AM
Gustavoerod's Avatar
Gustavoerod Gustavoerod is offline
Officially Welcomed to the 'Fest
Location: Orlando, FL
 
Join Date: Oct 2012
Posts: 132
Mein Auto: 2006 530i
From experience if it is the MAF sensor it will give you performance issues, specially having turbos,
No disrespect, but if you do not know where to start looking for this sensor, take it to the dealer. Nothing better than knowing where to start looking based on a code.
Reply With Quote
  #8  
Old 11-09-2012, 07:04 AM
booyaazaa's Avatar
booyaazaa booyaazaa is offline
Officially Welcomed to the 'Fest
Location: East Bay, CA
 
Join Date: May 2012
Posts: 1,025
Mein Auto: '09 AW 535i
Quote:
Originally Posted by Gustavoerod View Post
From experience if it is the MAF sensor it will give you performance issues, specially having turbos,
No disrespect, but if you do not know where to start looking for this sensor, take it to the dealer. Nothing better than knowing where to start looking based on a code.
Yes if you have a NA engine then you will have a maf sensor. But since the OP has a 08 535xi he has the n54 twin turbo engine that has a tmap sensor that measures temperature and manifold air pressure.
__________________

2009 AW 535i
-Sport, Premium Package, and Comfort Access
-FBO, custom Cobb E30 map, Performance Gearing LSD.
Reply With Quote
  #9  
Old 11-09-2012, 10:04 AM
repoman75 repoman75 is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Dec 2010
Posts: 108
Mein Auto: 2008 535 xi
Quote:
Originally Posted by booyaazaa View Post
Yes if you have a NA engine then you will have a maf sensor. But since the OP has a 08 535xi he has the n54 twin turbo engine that has a tmap sensor that measures temperature and manifold air pressure.

Dealer it is I guess. And yes, NO performance issues whatsoever. And it goes off and comes back on almost regularly, every 48 hours.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms