Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-11-2012, 04:43 PM
devsfan26 devsfan26 is offline
Registered User
Location: Alexandria, VA
 
Join Date: Nov 2012
Posts: 2
Mein Auto: 533i
Why is this 533i Idling Like Garbage

All,

My 533i is idling rough. After the car heats up, the engine revvs from about 800RPM to about 1800RPM, then cuts off. Above 2500RPM, the car revvs just fine, but the car sputters below 2000RPM, even in gear. My friends and I are completely stumped on this one. We have replaced the Throttle Position Sensor, the O2 Sensor, and cleaned the throttle body.

Here is a video to give a better idea of what I am dealing with:


Any ideas on what the issue is? Any solutions?

Thanks much!_a_
Reply With Quote
Advertisement
  #2  
Old 11-12-2012, 02:13 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 805
Mein Auto: 535i 1989
you might try disconnecting the o2 sensor. If it does not change then it is bad. Have you tried changing the spark plugs? Cap and rotor? or at least looking at them.


Andy
Reply With Quote
  #3  
Old 11-12-2012, 02:39 PM
devsfan26 devsfan26 is offline
Registered User
Location: Alexandria, VA
 
Join Date: Nov 2012
Posts: 2
Mein Auto: 533i
We have checked the spark plugs, and they are in good shape. The distributor cap is in rough shape, but appears to be functioning correctly. I have not tried disconnecting the O2 sensor; however, it is possible the connection to the sensor may be need to be replaced as it was rather rusty when I replaced the sensor itself.
Reply With Quote
  #4  
Old 11-15-2012, 02:20 AM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,625
Mein Auto: E23;E30;E38;E32;E34 +
Fuel filter, fuel rail pressure and 'rig' injector clean/test/pattern check.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #5  
Old 12-04-2012, 10:31 AM
waehrik waehrik is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Feb 2012
Posts: 122
Mein Auto: e39 530i/5, e28 535i
Try a voltage check on the air flow meter. Mine was bad and putting out erratic voltages, causing a very bizarre idle problem. It went from annoying to randomly stalling while driving very quickly.
Reply With Quote
  #6  
Old 01-16-2013, 04:05 PM
DHoang's Avatar
DHoang DHoang is offline
Gearhead
Location: Austin, Texas
 
Join Date: Dec 2008
Posts: 985
Mein Auto: '98 528i, '82 323i
That idle problem sounds like it's caused by a bad idle control valve that's either sticking or not opening up. Does your 535 motor have something that looks like this part?

__________________
http://www.bimmerfest.com/forums/picture.php?albumid=4132&pictureid=24642
Reply With Quote
  #7  
Old 01-16-2013, 05:12 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 805
Mein Auto: 535i 1989
He does have the ICV, but is the older model. It could also be your idle control module, which is below your ECU in the glove box. It is green. The idle in the 533i was not controlled by the ecu but this module. When it is idling badly try fitting the box. If it helps then you know it is the module.

Andy
Reply With Quote
  #8  
Old 02-02-2013, 02:39 AM
BeaterBimmerGuy BeaterBimmerGuy is offline
Registered User
Location: Seattle Wa
 
Join Date: Feb 2013
Posts: 7
Mein Auto: Daily rotation
I have the correct idle control boxes and valves to fix that problem. 4 or 5 of each to choose from all from known working cars. In the CL post below you can see a few in the bottom right hand corner in the picture of parts on the bench. I test most parts I sell that are easy to test so i will test the control box and if I have time the idle valve.

http://seattle.craigslist.org/see/pts/3588180215.html
Reply With Quote
Reply

Bookmarks

Tags
533i, idle, idling


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms