Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-12-2012, 06:47 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Did some work yesterday

Changed the seals on my vacuum pump (o rings)
But before i even took out the pump i noticed my oil pressure switch was dripping oil at a fast rate so i changed that before i took the pump out Deep socket 24 and a 3" extension and i got it out without removing the vacuum pump, although i did remove it and replace the o rings anyway.

After that oily mess I had the SES come on a couple days before so i read it out with INPA and got P2187 P2189 (too lean at idle both banks) and then pending codes for both banks for the secondary air system throughput too low.

What are the chances that these 4 codes could have something to do with eachother? I read somewhere somebody changed a precat o2 sensor, and they lost one bank code of the secondary air, also read that too lean could be o2 sensors, fuel filter, vacuum leak. car now has 144K on it. Keep in mind my car is running a euro DME ZUSB and has a lot more tolerance for the secondary air system.

Any insight would be appreciated

Edit: Also I have the updated CCV's that i have put in recently (within a few months) so i dont think its the CCV's (for the lean codes)
Attached Thumbnails
Click image for larger version

Name:	IMG_0188.jpg
Views:	203
Size:	132.8 KB
ID:	349232   Click image for larger version

Name:	IMG_0192.jpg
Views:	192
Size:	156.2 KB
ID:	349233  
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i

Last edited by 745iguy; 11-12-2012 at 07:58 AM.
Reply With Quote
Ads by Google
  #2  
Old 11-13-2012, 12:03 AM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Too lean usually related to air leak.
Check ccvs and those vacuum hoses
Reply With Quote
  #3  
Old 11-13-2012, 05:19 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Quote:
Originally Posted by SFbay View Post
Too lean usually related to air leak.
Check ccvs and those vacuum hoses
Hey SFbay thanks for the reply
I went and checked them and they appear just the same as when I installed them a few months ago. bought both sides from bmw of newport (they are updated versions my old ones had round nozzles and the new ones are more squared) edit: also replaced crankcase vent hoses with the updated ones
As far as the vacuum hoses; I replaced the hose going from the front of the vacuum pump (the skinny hose) and i replaced the hose that is connected to the elbow boot after the MAF (another skinny hose); both when I replaced the alternator/generator not too long ago also as the old ones were rotted and had visible cracks and holes in them. i checked them as well but they appear to be as new as when i put them on
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i

Last edited by 745iguy; 11-13-2012 at 05:20 AM.
Reply With Quote
  #4  
Old 11-13-2012, 03:25 PM
stuartjohn24 stuartjohn24 is offline
Officially Welcomed to the 'Fest
Location: Chippenham, Wiltshire, UK
 
Join Date: May 2011
Posts: 667
Mein Auto: BMW E65 745i
Hey 745iguy,

I had the same issue with the oil pressure switch! it had been leaking for ages and meade a complete mess of the engine bay and air con pump! all cam off with a steam cleaner though!

Anyway, interestingly i have exactly the same codes as you, do you have any driveability problems? mine bogs down and is sluggish, im suspecting a fuel pressure issue as ive fitted a brand new MAF and cannot find any vacuum leaks, engine vacuum seems OK as its very difficult to remove the oil filler cap with the engine running.

Im busy buying gaskets, timing chains, chain guides, water pipe etc... to overhaul the engine in the new year, strip heads, re-cut valves and seats, fit new valve stem seals, clean secondary air inlet ports etc.... will swap out the O2 sensors too and hope for the best!

Stuart
Reply With Quote
  #5  
Old 11-13-2012, 07:14 PM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Quote:
Originally Posted by stuartjohn24 View Post
Hey 745iguy,

I had the same issue with the oil pressure switch! it had been leaking for ages and meade a complete mess of the engine bay and air con pump! all cam off with a steam cleaner though!

Anyway, interestingly i have exactly the same codes as you, do you have any driveability problems? mine bogs down and is sluggish, im suspecting a fuel pressure issue as ive fitted a brand new MAF and cannot find any vacuum leaks, engine vacuum seems OK as its very difficult to remove the oil filler cap with the engine running.

Im busy buying gaskets, timing chains, chain guides, water pipe etc... to overhaul the engine in the new year, strip heads, re-cut valves and seats, fit new valve stem seals, clean secondary air inlet ports etc.... will swap out the O2 sensors too and hope for the best!

Stuart
Hello stuart

ya its a mess over there, once im positive there isnt anything else leaking over there im going to try and get in there with something also, when i was watching it drip every few seconds and the engine had been off for 30 mins, I can imagine with the engine running
Well, for the sake of just replacing things as apparently the PO of my car probably didn't do much other than maybe oil changes; I will probably just replace the front O2's but first ill replace the Fuel filter as its much cheaper and see what that does as far as the lean codes and my idle, engine idles around 600-700 at idle, i hear people say theirs idles at 500.
as far as my secondary air codes go IDEK what to say they stood off for so long with the eu3 DME flash and they were there with the lean codes when i checked so now but im definitely not paying more than or equal to the value of the car to fix that

as far as driving, I have no issues what so ever; no jerking or hesitation, just a high idle and poor gas mileage
good luck with your overhaul also; but im sure with the wealth of information here you will have no problem
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i

Last edited by 745iguy; 11-13-2012 at 07:18 PM.
Reply With Quote
  #6  
Old 11-15-2012, 10:21 AM
stuartjohn24 stuartjohn24 is offline
Officially Welcomed to the 'Fest
Location: Chippenham, Wiltshire, UK
 
Join Date: May 2011
Posts: 667
Mein Auto: BMW E65 745i
Quote:
Originally Posted by 745iguy View Post
Hello stuart

ya its a mess over there, once im positive there isnt anything else leaking over there im going to try and get in there with something also, when i was watching it drip every few seconds and the engine had been off for 30 mins, I can imagine with the engine running
Well, for the sake of just replacing things as apparently the PO of my car probably didn't do much other than maybe oil changes; I will probably just replace the front O2's but first ill replace the Fuel filter as its much cheaper and see what that does as far as the lean codes and my idle, engine idles around 600-700 at idle, i hear people say theirs idles at 500.
as far as my secondary air codes go IDEK what to say they stood off for so long with the eu3 DME flash and they were there with the lean codes when i checked so now but im definitely not paying more than or equal to the value of the car to fix that

as far as driving, I have no issues what so ever; no jerking or hesitation, just a high idle and poor gas mileage
good luck with your overhaul also; but im sure with the wealth of information here you will have no problem
Hi,

Yeah mine was a very small leak leaving a tiny drip every time I parked it. The oil sits in the under tray, when you drive it gets blown all over the gearbox and exhaust heat shields!

It started getting real bad very quickly and eventually was squirting out! When I took the pressure switch off you could blow air through it using your mouth!

Glad it was just the switch!

Strange, mine is sluggish an has poor performance, could be a fuel pressure issue, I haven't got a tester to hand will try and get something from work tomorrow. Does anybody know what the correct fuel pressure should be?

My lean codes have gone and not some back yet, I did find a small leak on the breather pipes.

As I'm having it all apart I will clean the carbon out. I'm just hoping the valve guides themselves are not too worn! It's done 100k miles now.

Stuart
Reply With Quote
  #7  
Old 11-15-2012, 06:36 PM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
found this about fuel pressure: http://tis.spaghetticoder.org/s/view.pl?1/05/38/45
ive got a fuel filter on the way so when it comes and I change it, ill see if anything changes.

as far as since i change the switch, not a drop of oil on the floor after cleaning the bottom belly pan
also noticed a slightly lower idle than before , but still around 550-600 according to inpa with ac/heat off
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
  #8  
Old 11-17-2012, 02:25 AM
stuartjohn24 stuartjohn24 is offline
Officially Welcomed to the 'Fest
Location: Chippenham, Wiltshire, UK
 
Join Date: May 2011
Posts: 667
Mein Auto: BMW E65 745i
Thanks, I found that too, problem is it does not tell you what the nominal fuel pressure should be. I guess is should be around 5 bar but I have no idea!

That's good work with the oil pressure switch!

My car seems to be going a little better now with the colder weather, far less sluggish, and better low end torque. It must be a mixture issue, hopefully servicing the injectors, cleaning and de-coking the heads and cylinders and changing the O2 sensors will improve things!
Reply With Quote
  #9  
Old 11-30-2012, 09:18 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Just wanted to update this,
close to two weeks ago i changed my fuel filter, also that coolant hose that is connected to the rear top of the exp tank and goes to behind the throttle body (unrelated)
since replacing the fuel filter, i havent had any lean codes come back, SES light has been off for 500 miles now. Maybe i'm in the clear
anyways; i decided to cut open the fuel filter with a hacksaw in my basement (dried out for a few hours of course) and look at it, idk how old it was TBH. looked nasty, then again first time ive ever cut open a fuel filter out of curiosity.
Attached Thumbnails
Click image for larger version

Name:	photo.jpg
Views:	79
Size:	121.2 KB
ID:	351451  
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
  #10  
Old 11-30-2012, 11:16 AM
stuartjohn24 stuartjohn24 is offline
Officially Welcomed to the 'Fest
Location: Chippenham, Wiltshire, UK
 
Join Date: May 2011
Posts: 667
Mein Auto: BMW E65 745i
Quote:
Originally Posted by 745iguy View Post
Just wanted to update this,
close to two weeks ago i changed my fuel filter, also that coolant hose that is connected to the rear top of the exp tank and goes to behind the throttle body (unrelated)
since replacing the fuel filter, i havent had any lean codes come back, SES light has been off for 500 miles now. Maybe i'm in the clear
anyways; i decided to cut open the fuel filter with a hacksaw in my basement (dried out for a few hours of course) and look at it, idk how old it was TBH. looked nasty, then again first time ive ever cut open a fuel filter out of curiosity.
Hi,

Thanks for the update, I may seriously consider changing the fuel filter then, how many miles do you have on your 7?

Thanks

Stuart
Reply With Quote
  #11  
Old 11-30-2012, 11:30 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
bought it on january 2nd with about 120K on it, its a little bit past 145K currently,
with the mileage i've put on this car this year alone i'm surprised its held up as well as it has, considering the known issues. the actual money i've spent in repairs was mostly for replacing the L7, nav(by choice for the dvd instead of cd), and putting in my oem ipod integration(mmi, kit, and new silver piece to replace cdc one; thanks again, paper for the help). the other non electronic stuff i've replaced wasnt so bad considering i did the labor myself.
having a place like here to read and ask questions and then the TIS, INPA etc makes it a little bit easier to own one of these cars

(edit: also wanted to add in since the fuel filter i have been getting noticeably better fuel economy, wonder why)
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i

Last edited by 745iguy; 11-30-2012 at 11:33 AM.
Reply With Quote
  #12  
Old 11-30-2012, 11:39 AM
stuartjohn24 stuartjohn24 is offline
Officially Welcomed to the 'Fest
Location: Chippenham, Wiltshire, UK
 
Join Date: May 2011
Posts: 667
Mein Auto: BMW E65 745i
Thats great, ive owned mine now for 18 months or so, had to replace the NAV, upgraded iDrive, fitted ipod kit, repaired trans mechatronics adapter and sleeve, PDC sensors etc... I agree, the knowledge on here is amazing, I dont know what i would have done without this forum! suffered in silence no doubt! ha ha!

Anyway im sold on the fuel filter change, will get on on order!

Thanks!
Reply With Quote
  #13  
Old 11-30-2012, 04:39 PM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
good luck to you it is what seems to have solved my issues
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms