Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-12-2012, 02:56 PM
jaasher jaasher is offline
Registered User
Location: Westchester County, NY
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 2003 530i
New Ignition Switch?

The other morning my 2003 530i wouldn't start. The car had electricity, the starter was working, I smelled gas, but the engine just didn't grab. Finally, after about 20 minutes of trying and feeling like the car was a push away from grabbing, I just kept turning the ignition and finally the engine grabbed. Since then the car has been starting fine.

Brought it my dealer, and they tell me they don't see anything wrong with the camshaft positioning sensor, the fuel pump, or the fuel filter. The car shows a code for a failed ignition switch. The dealer says it's probably a failed ignition switch.

Has anyone else experienced anything like this? Could it be a failed ignition switch?

Much thanks.
Reply With Quote
Ads by Google
  #2  
Old 11-12-2012, 06:07 PM
radd radd is offline
Registered User
Location: Jakarta
 
Join Date: May 2009
Posts: 60
Mein Auto: e39
where did you smell gas at? cabin or outside?

if it was in the cabin, you need to check fuel distribution (assuming fuel pump had been checked properly)
__________________
Reply With Quote
  #3  
Old 11-12-2012, 06:10 PM
jaasher jaasher is offline
Registered User
Location: Westchester County, NY
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 2003 530i
Outside. Just generally in the air. I chalked it up to having to crank the engine for so long before it grabbed.
__________________
2003 530i with 108,000 miles
Reply With Quote
  #4  
Old 11-12-2012, 07:19 PM
JimLev JimLev is online now
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,478
Mein Auto: 540/6, S60 Volvo, Tribeca
It's not the switch, it was flooded.
__________________

2000 540/6 Slightly tweeked...everywhere
Reply With Quote
  #5  
Old 11-12-2012, 07:35 PM
jaasher jaasher is offline
Registered User
Location: Westchester County, NY
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 2003 530i
Jim,

I don't think so. Not unless the car could become flooded sitting over night. It was in the morning, first thing, that I tried to start it. It didn't start. I understand that it could have become flooded with the amount of times I tried to get it started and the length of time I cranked it. But, no flooding should have caused the problem in the first instance. Especially not with an "ignition switch" code. Thanks, though.
__________________
2003 530i with 108,000 miles
Reply With Quote
  #6  
Old 11-12-2012, 07:36 PM
Wesam1994 Wesam1994 is offline
Registered User
Location: Miami
 
Join Date: Nov 2012
Posts: 1
Mein Auto: Bmw 530i
I just got a 530i 2005 I am just trying to see if you connect your phone to the car can you play your music
Reply With Quote
  #7  
Old 11-12-2012, 07:38 PM
jaasher jaasher is offline
Registered User
Location: Westchester County, NY
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 2003 530i
2003 does not have Bluetooth so I wouldn't know.
__________________
2003 530i with 108,000 miles
Reply With Quote
  #8  
Old 11-13-2012, 03:55 AM
JimLev JimLev is online now
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,478
Mein Auto: 540/6, S60 Volvo, Tribeca
Jaasher, never seen a code for an ignition switch before. Did they tell you what the actual code was? Maybe a DIS xx number on your paperwork from the dealer.
If you continue to have starting problems do you know how to replace the switch? It's very easy to do, about a $50 part.
__________________

2000 540/6 Slightly tweeked...everywhere
Reply With Quote
  #9  
Old 11-13-2012, 06:02 AM
16valex's Avatar
16valex 16valex is offline
Officially Welcomed to the 'Fest
Location: Albany NY
 
Join Date: Jul 2004
Posts: 2,556
Mein Auto: 530I/5SC 97-528/5
Quote:
Originally Posted by jaasher View Post
Jim,

I don't think so. Not unless the car could become flooded sitting over night. It was in the morning, first thing, that I tried to start it. It didn't start. I understand that it could have become flooded with the amount of times I tried to get it started and the length of time I cranked it. But, no flooding should have caused the problem in the first instance. Especially not with an "ignition switch" code. Thanks, though.
The question is what did the car do the night before you put it away?
Reply With Quote
  #10  
Old 11-13-2012, 06:49 PM
EconoBox EconoBox is offline
Officially Welcomed to the 'Fest
Location: LA
 
Join Date: Aug 2011
Posts: 923
Mein Auto: 2001 530i (E39) 120k
Replace the ignition switch, just in case.
Reply With Quote
  #11  
Old 11-13-2012, 10:14 PM
radd radd is offline
Registered User
Location: Jakarta
 
Join Date: May 2009
Posts: 60
Mein Auto: e39
you might need to check the computer unit. sometimes, it's a simple error in ECU where you can just have to clean up with proper spray

what i'm trying to say is that check all the simpler possibilities first before you start to throw some money for changing parts
__________________
Reply With Quote
Reply

Bookmarks

Tags
fuel pump issue, ignition switch


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms