Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2012, 10:54 AM
3zeerider 3zeerider is offline
Registered User
Location: Chichester
 
Join Date: Nov 2012
Posts: 7
Mein Auto: Z3 2.2i (yr.2000, M54)
Question M54 Engine Management Woes !

Hi Guys, and thanks for the invaluable advice & experience. Awesome! I've owned a lovely, well-cared for, year 2000 Z3 2.2i (M54 B22) since March '12. With over 86k on the clock, it has a persistent problem, thought to do with the emissions control system, which effectively prevents me taking the motor over about 4,000 rpm some - but not all- of the time.
I've quickly discovered that there could be quite a large number of reasons for the ECU triggering a fault code and going into limp mode ! This even happened once on cold start-up. However, I often find that, once thoroughly warmed, the car will run perfectly, even with enthusiastic use of the gas pedal.
I'm gradually working through the usual suspects, and have so far changed oil, fuel filter/reg., air filter, plugs, and the rearmost rubber elbow (air intake) to the manifold, which had cracks. A new MAF was fitted early on as a knee-jerk reaction by a local mechanic (who billed me 300 and threw away the original Bosch part !)
This past weekend, I serviced the DISA valve using a new parts kit from the States (as a precaution really.) Great kit but what a fiddly job ! ( The old OE parts were in surprisingly good shape apart from the 'O' ring mounting seal.)
I also find it hard to believe that it may be due to a faulty coil-pack, but I've got a new one on standby....
The car always runs sweetly below 4k with smooth pick-up and lovely linear torque, and really comes alive at around 5k. I tried Raj's plastic bag test over the oil-filler, and it seems to suck at idle -quite a lot ! Do I take this to be a bad thing ?!
Sorry for prattling on at some length, but I would like to mention that there's an odd expansion/resonator/collector box just aft of the MAF sensor, attached to the bottom of the main air intake trunk. I say odd because it doesn't seem to show on BMW microfiche for my vehicle...
This type of engine would appear to be air-leak city with advancing age, but if any of this sounds horribly familar to anyone, please let me know before I lose any more hair !!

Cheers
Reply With Quote
Ads by Google
  #2  
Old 11-13-2012, 11:21 AM
Guus Guus is offline
Registered User
Location: Netherlands
 
Join Date: Nov 2012
Posts: 8
Mein Auto: BMW Z3 2.0 I
Hi,

To me it sounds like a LAMDA sensor. Ratio air petrol mixture after burn.
This is part is located in the exaust manifold and has mostly 2 wires coming out of it.

How to check.
Connect a computer and check the readings of the sensor.

Just curious on witch Gasoline are you using I mean the mixture in octane.

greetings Guus
Reply With Quote
  #3  
Old 11-14-2012, 10:02 AM
3zeerider 3zeerider is offline
Registered User
Location: Chichester
 
Join Date: Nov 2012
Posts: 7
Mein Auto: Z3 2.2i (yr.2000, M54)
Smile M54 Engine Management Woes !

Hey Guus,

Many, many thanks for responding so swiftly. From memory, I believe that this engine has two O2 lambda sensors, one upstream and one downstream of the cat. Are you referring to the latter i.e. the post-catalytic sensor ?
Since it seems that you know your onions, is this sensor a) difficult to change, and b) are the cheaper brands (other than Bosch) worth fitting ? They would appear to be about 50% cheaper here in the UK !
You ask about fuel octane. Whenever possible, I try to use Shell V-Power which I think is rated about 98. I give her a good, long drive every weekend. Isn't that sad ?!!

Cheers,
Mike
Reply With Quote
  #4  
Old 11-14-2012, 11:33 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 374
Mein Auto: BMW Z4 3.0
Hey Mike, Have you had the codes pulled to see what is causing the car to go into limp mode ? It should not cost much at all to have this done. Everytime your ECU triggers a fault code it is stored in the ECU. Just have the codes pulled and the car will tell you what is wrong with it. You will save a lot of money in the long run. There is a plug on the drivers side of the car by the lower dash that a code reader has to be pluged into and it will read the stored codes and tell you what is triggering the code. You might also want to try a real good fuel system cleaner add it to a near empty tank and then fill up with preimium gas get on the highway and do some fast careful driving keeping the rpm's above 3 thousand for a while and see if this will help. These cars are prone to get carboned up and need a good fuel system cleaner added to help keep them running good. Have you cleaned the throttlebody ? These cars need to be pushed hard once in a while it cleans carbon out of the motor it will do your car good. Good luck Mike !
Reply With Quote
  #5  
Old 11-15-2012, 10:07 AM
3zeerider 3zeerider is offline
Registered User
Location: Chichester
 
Join Date: Nov 2012
Posts: 7
Mein Auto: Z3 2.2i (yr.2000, M54)
Wink Z3 2.2 M54 Engine Management Woes !

Yeah, thanks Mikey - that sounds like really good advice. I did get the OBD fault codes read by the same guy who threw in the MAF sensor, but they seemed quite vague (relating to certain cylinders). Although he re-set the diagnostics & suggested that I took her back for a second go, I decided not to because I didn't warm to him, and I didn't want any more dings in my tail through dodgy parking....
But you're dead right. Without a code reader, it seems that you're stumbling in the dark with modern vehicles, so I've got a handheld device on order. Can't wait to give it a try !

Kind regards,
Mike
Reply With Quote
  #6  
Old 11-15-2012, 11:36 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 374
Mein Auto: BMW Z4 3.0
Hey Mike, I think you will be glad you did. It will come in handy and pay for itself in time. Take care and Happy Holiday's !
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms