Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-14-2012, 04:52 PM
Graf545 Graf545 is offline
Registered User
Location: Boston, MA
 
Join Date: Nov 2012
Posts: 4
Mein Auto: 545i
Angry E60 Mechatronics for RPM Surge

I have read many posts regarding issues with BMW's with the steptronic transmission where RPM's either: stutter; flutter; surge; hiccups; bounces; etc....

This seems to occur when cruising around 30-40 MPH and @ ~ 2,000 RPMs. It is ever so slight, you might miss it if you blink,m but a quick RPM drop, then returns. Does not appear to occur at higher speed/RPM combo, or at same RPM in Sport or Manual mode.

Another associated symptom seems to be a slight delay when shifting into reverse. As it progresses you start to leak tranny fluid, so unless you have an extra car, time to resolve becomes an issue, so forced to pay to have resolved asap.

I have a 2004 E60 545 with 39,000 miles that recently started experiencing this issue. Several trips to indy and BMW mechanics were unable to resolve at much time and expense. So I took to the internet. This website has been most informative.

There have been many suggested fixes such as: bad gas; MAF (Mass Air Flow) sensor; 02 sensor; fly by wire; fuel filter; CCV; carbon buildup; tourque converter; spark plugs; VANOS; computer software updates; retrain the "learned transmission"; transmission control module; etc...

Other suggested workarounds were to drive in the Sport or semi manual mode, however this only masks the issue into other RPM ranges.

After reading many posts, it appears there seems to be a manufacturing defect with the ZF mechatronics plastic parts were micro cracks impair the functionality.

There are no error codes, so BMW does not cover under warranty. There are no service bulletins directly. Related SIB's are: 24 08 06 and 24 03 09.

Sort of a catch 22 here. BMW warranty won't cover the repair because there are no error codes, but BMW didn't program any error codes for this issue.

Unfortunately repairing the mechatronics is a $3,000 - $4,000 job which occurs near or after warranty expiration.

There are some stories of PUMA cases (the highest level of BMW tech support) and others of BMW goodwill warranties for parts and owner pays ~$1K labor, but these are diminishing in today's economy.

There are many other's calling for a BMW recall, or class action lawsuit, but I didn't see any final formalization.

Does anyone have any update? Has BMW accepted responsibilty to resolve? How many BMW's are impacted by this?

Can you buy a new mechatronic, a rebult one, or best to replace components of your existing?

Can this be done by an Indy? I read has to have the program on site, else can't drive without risking damage to transmission.

BMW needs to come clean on this, else I'll never buy another BMW product again. I don't have a problem with issues, just have to own up to them to instill product quality and loyalty.

I'm disappointed in BMW and will likey choose a different make in the future.
Reply With Quote
Ads by Google
  #2  
Old 11-14-2012, 06:30 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,274
Mein Auto: 2004 545i
http://www.bimmerfest.com/forums/sho...d.php?t=654634 is what I did on mine, but I'm at 180K miles so no warranty

I saw a post once where someone found that if you floored it right when that blip happened it would get it to throw a transmission error but no clue if that will help

You can buy a rebuilt mechatronics / valvebody unit (that comes from ZF ultimately) with oil pan for about $1500. If a mechanic couldn't change it out in 3 hours I would be finding a new mechanic. I pulled mine, changed solenoids, put it back in (1st time), spent a while getting the oil level right, put the plastic covers back on the bottom of the car, took a shower and played with the dog in about 5 hours total. And that was on the ground in my parents driveway.

I'm surprised it's doing it at such low mileage though, that really sucks. I'm not sure how BMW's warranties work.. If your mechatronics seal suddenly sprung a leak and fried the whole transmission after you lost a lot of fluid, would they replace it under warranty?

Last edited by schpenxel; 11-14-2012 at 06:32 PM.
Reply With Quote
  #3  
Old 08-04-2013, 03:08 AM
Estone Estone is offline
Registered User
Location: Australia
 
Join Date: Aug 2013
Posts: 1
Mein Auto: Bmw e60 545i 2004
I just read another post that had 26 pages about this god awful issue. I am the pretty far from a mechanic but have the most basic of clues. My car has all the tell tale symptoms of the ZF failure. My question where can I order this replacement 1500 part? I live in Australia so would have to ship it. The reason I ask is my Indy has told me the gearbox is all sealed on those cars so it will need to be like replaced! Like **** it will, I need to find the cheapest but most reliable way out of this as I love my car but its starting to stress me a little now.

Anyhow any help you can give is extremely appreciated.
Reply With Quote
  #4  
Old 08-04-2013, 06:36 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,274
Mein Auto: 2004 545i
Thectsc.com
Reply With Quote
  #5  
Old 08-05-2013, 07:17 AM
ronmexico ronmexico is offline
Registered User
Location: SATX
 
Join Date: Feb 2012
Posts: 30
Mein Auto: 550i
Ive been having this issue for a few months....


I would reccomend looking at the gearbox update or the 2-1 "step-in" procedure. Basically it's a coding change that causes you to launch in 2nd gear instead of first, and changes the throttle response to give less jerky response.

I did it on my 550i last week and there's a noticable improvement. Although not fixed, it is MUCH better.

Instead of buying a new mechatronic, look into replacing the solenoids. Thectsc.com has the solenoid kits, and 90% of the time the solenoids and the sleeve replacement will resolve the transmission issues outright.
Reply With Quote
  #6  
Old 08-05-2013, 07:19 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,274
Mein Auto: 2004 545i
I agree on the software update.. I am going to do it on mine as soon as my power supply gets here. I'm too much of a chicken to try it before then, even with ISTA, lol

Also, I agree in regards to changing solenoids instead of anything bigger/more expensive.
Reply With Quote
  #7  
Old 08-05-2013, 07:21 AM
ronmexico ronmexico is offline
Registered User
Location: SATX
 
Join Date: Feb 2012
Posts: 30
Mein Auto: 550i
I got lucky and my budy's shop uses an AutoLogic. We just hooked it up to the OBD2 port, and pushed the update. Took like 2 minutes.

Using WinFDP to do it made me nervous, but I'll have to learn how eventually....


I know for a fact BMW fixed the surging issues even more dramatically with the 545 using software updates. Updating the software might save you a couple hundred bucks.
Reply With Quote
Reply

Bookmarks

Tags
e60, flutter, hiccups, maf, mechatronics, rmp, studder, surge, vanos


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms