Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-16-2012, 10:15 AM
artman005 artman005 is offline
Registered User
Location: Atl, Ga
 
Join Date: Nov 2012
Posts: 11
Mein Auto: 2003 X5, 1995 318is
Angry 1995 318is Window/door lock issues

Hi guys,

Ive been lurking for a while since i got my e36 and learned a lot but with all the reading and researching I can not solve an issue so i have to ask.

My car is a 1995 (10/1994 production date) 318is.

The issue at is my driver door microswitch was acting up and i fixed that. Now my passenger door is not rolling down or up (.5in) and i though microswitch...but i put 3 diff switches nothing....I checked ground and its good. I took out the regulator and it works off the car meaning just motor and regulator i can roll up or down with the window switch but once i put on the car the window jams or drops.. ..i think the clutch in the motor is bad or logic board anyway thats one issue

second is the microswitch according to the electrical diagrams the switch goes into the ZKE IV module and no were else. it can not be the comfort relay since driver side works. and even if i press the switch with my finger etc nothing happens no click no sound but the drive side works still and since both wires for drive / passenger go into the zke iv module im confused driver side is getting power....but not passenger. Can this be a bad zke iv module? ive read about the module failing which leads to everything not working but not like my case? any input? ive spend a week tracing wires and stuff all is good. Continuity is good in wires. fuses are good, their old but good. I bought a pack of new fuses just in case but still nothing. i figured even if the mother is bad the switch should click it etc but the witch is not getting any power etc. what am I missing? I also swapped drive door motor to just make sure if switch is pressed but still nothing so it comes down to an issue with the microswitch on the striker not getting power....


Also, if the microswitch is not getting power and the model probably doesnt now if the door is closed or not might be causing my central lock issue? if i press from inside on door with the nub to lock it locks all locks but from outside if i lock with key from passenger side it locks passenger and trunk but not driver door? if i lock driver door from outside it locks itself and trunk but not passenger door?

and it all kinda points to the zke iv or micro switch ( which work when plugged to the driver side btw)

Last edited by artman005; 11-16-2012 at 10:27 AM.
Reply With Quote
Ads by Google
  #2  
Old 11-17-2012, 03:24 PM
artman005 artman005 is offline
Registered User
Location: Atl, Ga
 
Join Date: Nov 2012
Posts: 11
Mein Auto: 2003 X5, 1995 318is
ok, just to update


I had some free time. So i decided to look at the door jam microswitch again. Like i had said i suspected that the module would be bad. I took out the module and opened it up and there are 5 relays inside it. 3 small ones that work with the locks and 2 big ones that deal with the windows. Either way i shook the module and pluged things back and voila it works. but after some time it stopped agian.....I think the relays in there are bad and i found this guy online he rebuilds the unit.. http://www.bmwgm5.com/ and in our cars the module is the gm4.

so anyone use his services....I think that my issue is the module. Anyway just wanted to update you guys in case some one has similar issues.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms