Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 09-27-2013, 01:01 PM
X3700 X3700 is offline
Driver
Location: Charlotte
 
Join Date: Aug 2013
Posts: 12
Mein Auto: X3
FUSE Help!

My 05 x3 driver side window switch panel is not working. Does anyone have or know where I can find the fuse box label for my 2005 X3. Thanks
Reply With Quote
Advertisement
  #2  
Old 09-27-2013, 01:19 PM
bobbyjoe bobbyjoe is offline
Registered User
Location: Toronto
 
Join Date: Oct 2007
Posts: 65
Mein Auto: 2008 X3 3.0si
For the 2008 X3 (Sorry if it's not the same for 2005) the fuse box is at the top of the glove compartment (inside) held up by two clips. Once you loosen, the box will drop down. The labels (indicating which fuse does what) is tucked underneath the bottom row of fuses. It's a white card.
Reply With Quote
  #3  
Old 09-27-2013, 02:01 PM
Supercourse Supercourse is online now
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,240
Mein Auto: 2004 X3 2.5i
Fuse #57 you could check, but whether it's blown or not, you are probably looking at having to replace that master switch.

Contacts might be corroded and drawing too many amps.

I wish that people who sell their X3 would put the damn fuse chart back where it belongs.

2004 Fuse Chart: https://dl.dropboxusercontent.com/u/.../fusechart.jpg
Reply With Quote
  #4  
Old 09-27-2013, 02:47 PM
X3700 X3700 is offline
Driver
Location: Charlotte
 
Join Date: Aug 2013
Posts: 12
Mein Auto: X3
Quote:
Originally Posted by Supercourse View Post
Fuse #57 you could check, but whether it's blown or not, you are probably looking at having to replace that master switch.

Contacts might be corroded and drawing too many amps.

I wish that people who sell their X3 would put the damn fuse chart back where it belongs.

2004 Fuse Chart: https://dl.dropboxusercontent.com/u/.../fusechart.jpg
Thx for your help. I will take a look at it. Called the local bmw dealership and they want 180.00 plus tax for the thing.
Reply With Quote
  #5  
Old 09-27-2013, 03:06 PM
Supercourse Supercourse is online now
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,240
Mein Auto: 2004 X3 2.5i
Quote:
Originally Posted by X3700 View Post
..... Called the local bmw dealership and they want 180.00 plus tax for the thing.
Doing a search here on this problem, it seems you might be able to get everything working by unplugging the mirrors and re-initilizing the windows.

Requires disconnecting the battery and touching the terminals together to clear things.
Then the windows may be back to working, after which mirrors can be reconnected.

Not sure how that works, but no point in getting a new switch if you don't have to.
Reply With Quote
  #6  
Old 09-27-2013, 05:10 PM
X3700 X3700 is offline
Driver
Location: Charlotte
 
Join Date: Aug 2013
Posts: 12
Mein Auto: X3
Quote:
Originally Posted by Supercourse View Post
Doing a search here on this problem, it seems you might be able to get everything working by unplugging the mirrors and re-initilizing the windows.

Requires disconnecting the battery and touching the terminals together to clear things.
Then the windows may be back to working, after which mirrors can be reconnected.

Not sure how that works, but no point in getting a new switch if you don't have to.
How do I unplug the mirrors? Every other window works when you're using its respective switch, but when using the master one on the driver side, none of the buttons works to move any window. I've disconnected the battery terminals twice and still nothing. I've also checked all the fuses regarding windows and still nothing.

Any other suggestions besides buying a new one? Thanks fellows!
Reply With Quote
  #7  
Old 09-27-2013, 05:22 PM
mlukas161's Avatar
mlukas161 mlukas161 is offline
Officially Welcomed to the 'Fest
Location: WNY
 
Join Date: Oct 2008
Posts: 937
Mein Auto: 03 330i, 04 X3
Re: FUSE Help!

Most likely a short in the switch or one of the side mirrors. I've been experiencing this problem with our 2004.
I disconnected the driver side mirror by opening the black plastic triangle trim piece at the inside corner of the door. Near the dash. There is a white ribbon wire in there. Disconnect that and see if the driver switch works. If it does, you may need a new side mirror actuator.
__________________
Reply With Quote
  #8  
Old 09-27-2013, 05:35 PM
X3700 X3700 is offline
Driver
Location: Charlotte
 
Join Date: Aug 2013
Posts: 12
Mein Auto: X3
Quote:
Originally Posted by mlukas161 View Post
Most likely a short in the switch or one of the side mirrors. I've been experiencing this problem with our 2004.
I disconnected the driver side mirror by opening the black plastic triangle trim piece at the inside corner of the door. Near the dash. There is a white ribbon wire in there. Disconnect that and see if the driver switch works. If it does, you may need a new side mirror actuator.
Hey bud, I can't seem to find that trim piece you're talking about. Do u have a picture of it?
Reply With Quote
  #9  
Old 09-27-2013, 06:38 PM
Supercourse Supercourse is online now
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,240
Mein Auto: 2004 X3 2.5i
See: http://www.bimmerfest.com/forums/sho...3&postcount=21
Reply With Quote
  #10  
Old 09-29-2013, 09:51 AM
X3700 X3700 is offline
Driver
Location: Charlotte
 
Join Date: Aug 2013
Posts: 12
Mein Auto: X3
Ok guys, I've tried disconnecting both white ribbons on both mirrors and still nothing. Any other suggestions?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms